This commit is contained in:
Than Ngo 2010-07-19 13:04:42 +00:00
parent 3908434c1a
commit 8d12f97154
4 changed files with 52 additions and 44 deletions

View File

@ -1,9 +1,7 @@
diff -up doxygen-1.6.0/src/config.cpp.orig doxygen-1.6.0/src/config.cpp
diff -up doxygen-1.6.0/src/config.l.orig doxygen-1.6.0/src/config.l
diff -up doxygen-1.6.0/src/configoptions.cpp.orig doxygen-1.6.0/src/configoptions.cpp
--- doxygen-1.6.0/src/configoptions.cpp.orig 2009-08-24 12:04:45.000000000 +0200
+++ doxygen-1.6.0/src/configoptions.cpp 2009-08-24 12:06:34.000000000 +0200
@@ -1072,6 +1072,14 @@ void addConfigOptions(Config *cfg)
diff -up doxygen-1.6.2/src/configoptions.cpp.timestamp doxygen-1.6.2/src/configoptions.cpp
--- doxygen-1.6.2/src/configoptions.cpp.timestamp 2009-12-28 11:39:11.000000000 +0100
+++ doxygen-1.6.2/src/configoptions.cpp 2010-01-04 11:58:33.000000000 +0100
@@ -1088,6 +1088,14 @@ void addConfigOptions(Config *cfg)
cs->setWidgetType(ConfigString::File);
cs->addDependency("GENERATE_HTML");
//----
@ -18,10 +16,10 @@ diff -up doxygen-1.6.0/src/configoptions.cpp.orig doxygen-1.6.0/src/configoption
cs = cfg->addString(
"HTML_STYLESHEET",
"The HTML_STYLESHEET tag can be used to specify a user-defined cascading\n"
diff -up doxygen-1.6.0/src/config.xml.orig doxygen-1.6.0/src/config.xml
--- doxygen-1.6.0/src/config.xml.orig 2009-08-24 11:55:46.000000000 +0200
+++ doxygen-1.6.0/src/config.xml 2009-08-24 12:03:06.000000000 +0200
@@ -751,6 +751,10 @@ The HTML_FOOTER tag can be used to speci
diff -up doxygen-1.6.2/src/config.xml.timestamp doxygen-1.6.2/src/config.xml
--- doxygen-1.6.2/src/config.xml.timestamp 2009-12-28 11:38:55.000000000 +0100
+++ doxygen-1.6.2/src/config.xml 2010-01-04 11:58:33.000000000 +0100
@@ -761,6 +761,10 @@ The HTML_FOOTER tag can be used to speci
each generated HTML page. If it is left blank doxygen will generate a
standard footer.
' defval='' depends='GENERATE_HTML'/>
@ -32,10 +30,10 @@ diff -up doxygen-1.6.0/src/config.xml.orig doxygen-1.6.0/src/config.xml
<option type='string' id='HTML_STYLESHEET' format='file' docs='
The HTML_STYLESHEET tag can be used to specify a user-defined cascading
style sheet that is used by each HTML page. It can be used to
diff -up doxygen-1.6.0/src/htmlgen.cpp.orig doxygen-1.6.0/src/htmlgen.cpp
--- doxygen-1.6.0/src/htmlgen.cpp.orig 2009-08-24 11:55:20.000000000 +0200
+++ doxygen-1.6.0/src/htmlgen.cpp 2009-08-24 11:53:29.000000000 +0200
@@ -56,6 +56,7 @@ static const char search_script[]=
diff -up doxygen-1.6.2/src/htmlgen.cpp.timestamp doxygen-1.6.2/src/htmlgen.cpp
--- doxygen-1.6.2/src/htmlgen.cpp.timestamp 2009-12-21 11:24:22.000000000 +0100
+++ doxygen-1.6.2/src/htmlgen.cpp 2010-01-04 12:04:31.000000000 +0100
@@ -54,6 +54,7 @@ static const char search_script[]=
static QCString g_header;
static QCString g_footer;
@ -43,7 +41,7 @@ diff -up doxygen-1.6.0/src/htmlgen.cpp.orig doxygen-1.6.0/src/htmlgen.cpp
//------------------------- Pictures for the Tabs ------------------------
@@ -640,6 +641,8 @@ void HtmlGenerator::init()
@@ -693,6 +694,8 @@ void HtmlGenerator::init()
if (!Config_getString("HTML_FOOTER").isEmpty())
{
g_footer=fileToString(Config_getString("HTML_FOOTER"));
@ -52,12 +50,12 @@ diff -up doxygen-1.6.0/src/htmlgen.cpp.orig doxygen-1.6.0/src/htmlgen.cpp
//printf("g_footer='%s'\n",g_footer.data());
}
createSubDirs(d);
@@ -864,7 +867,7 @@ static void writePageFooter(QTextStream
{
t << "<hr size=\"1\"/><address style=\"text-align: right;\"><small>";
t << theTranslator->trGeneratedAt(
- dateToString(TRUE),
+ dateToString(timestamp),
Config_getString("PROJECT_NAME")
);
t << "&nbsp;" << endl << "<a href=\"http://www.doxygen.org/index.html\">";
@@ -932,7 +935,7 @@ static void writePageFooter(QTextStream
if (timeStamp)
{
t << theTranslator->trGeneratedAt(
- dateToString(TRUE),
+ dateToString(timestamp),
Config_getString("PROJECT_NAME")
);
}

View File

@ -1,11 +1,11 @@
diff -up doxygen-1.6.0/addon/doxywizard/Makefile.in.config doxygen-1.6.0/addon/doxywizard/Makefile.in
--- doxygen-1.6.0/addon/doxywizard/Makefile.in.config 2009-07-13 22:09:03.000000000 +0200
+++ doxygen-1.6.0/addon/doxywizard/Makefile.in 2009-08-21 16:42:13.000000000 +0200
diff -up doxygen-1.7.1/addon/doxywizard/Makefile.in.config doxygen-1.7.1/addon/doxywizard/Makefile.in
--- doxygen-1.7.1/addon/doxywizard/Makefile.in.config 2010-05-23 16:51:31.000000000 +0200
+++ doxygen-1.7.1/addon/doxywizard/Makefile.in 2010-07-19 13:38:33.000000000 +0200
@@ -10,8 +10,6 @@
# See the GNU General Public License for more details.
#
-QMAKE=qmake
-QMAKE=qmake $(MKSPECS)
-
all: Makefile.doxywizard
$(MAKE) -f Makefile.doxywizard
@ -26,15 +26,15 @@ diff -up doxygen-1.6.0/addon/doxywizard/Makefile.in.config doxygen-1.6.0/addon/d
rm doxywizard.1
FORCE:
diff -up doxygen-1.6.0/configure.config doxygen-1.6.0/configure
--- doxygen-1.6.0/configure.config 2009-08-20 14:15:07.000000000 +0200
+++ doxygen-1.6.0/configure 2009-08-21 16:41:36.000000000 +0200
diff -up doxygen-1.7.1/configure.config doxygen-1.7.1/configure
--- doxygen-1.7.1/configure.config 2010-06-25 11:46:38.000000000 +0200
+++ doxygen-1.7.1/configure 2010-07-19 12:03:53.000000000 +0200
@@ -268,9 +268,10 @@ if test "$f_wizard" = YES; then
if test -z "$QTDIR"; then
echo " QTDIR environment variable not set!"
echo -n " Checking for Qt..."
- for d in /usr/{lib,share,qt}/{qt-4,qt4,qt,qt*,4}; do
+ for d in /usr/{lib64,lib,share,qt}/{qt-4,qt4,qt,qt*,4}; do
- for d in /usr/{lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
+ for d in /usr/{lib64,lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
if test -x "$d/bin/qmake"; then
QTDIR=$d
+ QMAKE=$d/bin/qmake
@ -50,9 +50,9 @@ diff -up doxygen-1.6.0/configure.config doxygen-1.6.0/configure
EOF
if test "$f_dot" != NO; then
diff -up doxygen-1.6.0/Makefile.in.config doxygen-1.6.0/Makefile.in
--- doxygen-1.6.0/Makefile.in.config 2009-08-14 15:58:42.000000000 +0200
+++ doxygen-1.6.0/Makefile.in 2009-08-21 16:34:02.000000000 +0200
diff -up doxygen-1.7.1/Makefile.in.config doxygen-1.7.1/Makefile.in
--- doxygen-1.7.1/Makefile.in.config 2009-08-20 21:41:13.000000000 +0200
+++ doxygen-1.7.1/Makefile.in 2010-07-19 12:03:53.000000000 +0200
@@ -44,8 +44,6 @@ distclean: clean
DATE=$(shell date "+%B %Y")
@ -62,9 +62,9 @@ diff -up doxygen-1.6.0/Makefile.in.config doxygen-1.6.0/Makefile.in
install: doxywizard_install
$(INSTTOOL) -d $(DESTDIR)/$(INSTALL)/bin
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)/$(INSTALL)/bin
diff -up doxygen-1.6.0/tmake/lib/linux-g++/tmake.conf.config doxygen-1.6.0/tmake/lib/linux-g++/tmake.conf
--- doxygen-1.6.0/tmake/lib/linux-g++/tmake.conf.config 2008-12-06 14:16:20.000000000 +0100
+++ doxygen-1.6.0/tmake/lib/linux-g++/tmake.conf 2009-08-21 16:34:02.000000000 +0200
diff -up doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf.config doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf
--- doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf.config 2008-12-06 14:16:20.000000000 +0100
+++ doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf 2010-07-19 12:03:53.000000000 +0200
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
TMAKE_CFLAGS = -pipe
TMAKE_CFLAGS_WARN_ON = -Wall -W -fno-exceptions

View File

@ -1,12 +1,13 @@
Summary: A documentation system for C/C++
Name: doxygen
Version: 1.6.1
Release: 4%{?dist}
Version: 1.7.1
Release: 1%{?dist}
Epoch: 1
Url: http://www.stack.nl/~dimitri/doxygen/index.html
Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
Patch1: doxygen-1.6.0-config.patch
Patch2: doxygen-1.6.0-timestamp.patch
Patch1: doxygen-1.7.1-config.patch
Patch2: doxygen-1.6.2-timestamp.patch
Group: Development/Tools
# No version is specified.
License: GPL+
@ -96,6 +97,15 @@ rm -rf %{buildroot}
%{_mandir}/man1/doxywizard*
%changelog
* Mon Jul 19 2010 Than Ngo <than@redhat.com> - 1.7.1-1
- 1.7.1
* Fri Feb 12 2010 Than Ngo <than@redhat.com> - 1.6.2-1.svn20100208
- fix #555526, snapshot 1.6.2-20100208
* Mon Jan 04 2010 Than Ngo <than@redhat.com> - 1:1.6.2-1
- 1.6.2
* Fri Dec 18 2009 Than Ngo <than@redhat.com> - 1:1.6.1-4
- drop _default_patch_fuzz

View File

@ -1 +1 @@
2ec343643e134f0d3ce2069420bcb4f0 doxygen-1.6.1.src.tar.gz
13e76e10fb55581a16ee04de35c264f0 doxygen-1.7.1.src.tar.gz