Merge branch 'master' into f25
This commit is contained in:
commit
86b5211513
1
.gitignore
vendored
1
.gitignore
vendored
@ -45,3 +45,4 @@ doxygen-1.7.1.src.tar.gz
|
||||
/doxygen-1.8.10.src.tar.gz
|
||||
/doxygen-1.8.11.src.tar.gz
|
||||
/doxygen-1.8.12.src.tar.gz
|
||||
/doxygen-1.8.13.src.tar.gz
|
||||
|
@ -1,43 +0,0 @@
|
||||
commit b5e1e195bc207c7bb93df4e51253f9f3a1026a3d
|
||||
Author: Dimitri van Heesch <dimitri@stack.nl>
|
||||
Date: Wed Sep 21 20:24:15 2016 +0200
|
||||
|
||||
Bug 771310 - French description for "Namespace Members" is wrong and causes fatal javascript error
|
||||
|
||||
diff --git a/src/index.cpp b/src/index.cpp
|
||||
index 96909c7..41e3318 100644
|
||||
--- a/src/index.cpp
|
||||
+++ b/src/index.cpp
|
||||
@@ -4327,8 +4327,8 @@ void renderMemberIndicesAsJs(FTextStream &t,
|
||||
t << "children:[";
|
||||
firstMember=FALSE;
|
||||
}
|
||||
- t << endl << "{text:'" << convertToJSString(getInfo(i)->title) << "',url:'"
|
||||
- << convertToJSString(getInfo(i)->fname+Doxygen::htmlFileExtension) << "'";
|
||||
+ t << endl << "{text:\"" << convertToJSString(getInfo(i)->title) << "\",url:\""
|
||||
+ << convertToJSString(getInfo(i)->fname+Doxygen::htmlFileExtension) << "\"";
|
||||
|
||||
// Check if we have many members, then add sub entries per letter...
|
||||
// quick alphabetical index
|
||||
@@ -4357,8 +4357,8 @@ void renderMemberIndicesAsJs(FTextStream &t,
|
||||
anchor=fullName+extension+"#index_";
|
||||
else // other pages of multi page index
|
||||
anchor=fullName+"_"+is+extension+"#index_";
|
||||
- t << "{text:'" << convertToJSString(ci) << "',url:'"
|
||||
- << convertToJSString(anchor+is) << "'}";
|
||||
+ t << "{text:\"" << convertToJSString(ci) << "\",url:\""
|
||||
+ << convertToJSString(anchor+is) << "\"}";
|
||||
firstLetter=FALSE;
|
||||
}
|
||||
t << "]";
|
||||
@@ -4393,8 +4393,8 @@ static bool renderQuickLinksAsJs(FTextStream &t,LayoutNavEntry *root,bool first)
|
||||
if (!firstChild) t << "," << endl;
|
||||
firstChild=FALSE;
|
||||
QCString url = entry->url();
|
||||
- t << "{text:'" << convertToJSString(entry->title()) << "',url:'"
|
||||
- << convertToJSString(url) << "'";
|
||||
+ t << "{text:\"" << convertToJSString(entry->title()) << "\",url:\""
|
||||
+ << convertToJSString(url) << "\"";
|
||||
bool hasChildren=FALSE;
|
||||
if (entry->kind()==LayoutNavEntry::NamespaceMembers)
|
||||
{
|
@ -1,23 +0,0 @@
|
||||
commit b93dbcdab6dfc5681ec49f1d567698b7c4dc6846
|
||||
Author: albert-github <albert.tests@gmail.com>
|
||||
Date: Sun Sep 18 17:58:30 2016 +0200
|
||||
|
||||
Bug 771344 - Class name 'internal' breaks class hierarchy in C++
|
||||
|
||||
Analogous to the rule for:
|
||||
<FindMembers>{B}*"internal"{BN}*":"{BN}*
|
||||
reject the "internal" keyword in case not in Cli
|
||||
|
||||
diff --git a/src/scanner.l b/src/scanner.l
|
||||
index 6c69224..68eb8fc 100644
|
||||
--- a/src/scanner.l
|
||||
+++ b/src/scanner.l
|
||||
@@ -5771,7 +5771,7 @@ OPERATOR "operator"{B}*({ARITHOP}|{ASSIGNOP}|{LOGICOP}|{BITOP})
|
||||
<BasesProt>"virtual"{BN}+ { lineCount(); baseVirt = Virtual; }
|
||||
<BasesProt>"public"{BN}+ { lineCount(); baseProt = Public; }
|
||||
<BasesProt>"protected"{BN}+ { lineCount(); baseProt = Protected; }
|
||||
-<BasesProt>"internal"{BN}+ { lineCount(); baseProt = Package; }
|
||||
+<BasesProt>"internal"{BN}+ { if (!insideCli) REJECT ; lineCount(); baseProt = Package; }
|
||||
<BasesProt>"private"{BN}+ { lineCount(); baseProt = Private; }
|
||||
<BasesProt>{BN} { lineCount(); }
|
||||
<BasesProt>. { unput(*yytext); BEGIN(Bases); }
|
@ -1,217 +0,0 @@
|
||||
commit d2593e56cd52ecee2424d844916f95e12fef27c8
|
||||
Author: albert-github <albert.tests@gmail.com>
|
||||
Date: Sun Nov 13 11:24:51 2016 +0100
|
||||
|
||||
Bug 774138 - Please add HTML classes to "Definition at..." & "Referenced by..." for CSS
|
||||
|
||||
Added class= to html output for "Definition at..." resulting in p.definition in the css file and for "Referenced by .. " and "References ..." resulting in p.definition in css file.
|
||||
(also corrected some error messages).
|
||||
|
||||
diff --git a/src/definition.cpp b/src/definition.cpp
|
||||
index 7e6e8ec..68201da 100644
|
||||
--- a/src/definition.cpp
|
||||
+++ b/src/definition.cpp
|
||||
@@ -933,7 +933,7 @@ void Definition::writeSourceDef(OutputList &ol,const char *)
|
||||
QCString lineStr;
|
||||
lineStr.sprintf("%d",m_impl->body->startLine);
|
||||
QCString anchorStr = getSourceAnchor();
|
||||
- ol.startParagraph();
|
||||
+ ol.startParagraph("definition");
|
||||
if (lineMarkerPos<fileMarkerPos) // line marker before file marker
|
||||
{
|
||||
// write text left from linePos marker
|
||||
@@ -1067,7 +1067,7 @@ void Definition::writeSourceDef(OutputList &ol,const char *)
|
||||
}
|
||||
else
|
||||
{
|
||||
- err("translation error: invalid markers in trDefinedInSourceFile()\n");
|
||||
+ err("translation error: invalid markers in trDefinedAtLineInSourceFile()\n");
|
||||
}
|
||||
}
|
||||
ol.popGeneratorState();
|
||||
@@ -1152,7 +1152,7 @@ void Definition::_writeSourceRefList(OutputList &ol,const char *scopeName,
|
||||
{
|
||||
members->sort();
|
||||
|
||||
- ol.startParagraph();
|
||||
+ ol.startParagraph("reference");
|
||||
ol.parseText(text);
|
||||
ol.docify(" ");
|
||||
|
||||
diff --git a/src/filedef.cpp b/src/filedef.cpp
|
||||
index 9c04dc8..3fa896a 100644
|
||||
--- a/src/filedef.cpp
|
||||
+++ b/src/filedef.cpp
|
||||
@@ -344,7 +344,7 @@ void FileDef::writeDetailedDescription(OutputList &ol,const QCString &title)
|
||||
ol.disable(OutputGenerator::RTF);
|
||||
}
|
||||
|
||||
- ol.startParagraph();
|
||||
+ ol.startParagraph("definition");
|
||||
QCString refText = theTranslator->trDefinedInSourceFile();
|
||||
int fileMarkerPos = refText.find("@0");
|
||||
if (fileMarkerPos!=-1) // should always pass this.
|
||||
@@ -355,6 +355,10 @@ void FileDef::writeDetailedDescription(OutputList &ol,const QCString &title)
|
||||
ol.parseText(refText.right(
|
||||
refText.length()-fileMarkerPos-2)); // text right from marker 2
|
||||
}
|
||||
+ else
|
||||
+ {
|
||||
+ err("translation error: invalid marker in trDefinedInSourceFile()\n");
|
||||
+ }
|
||||
ol.endParagraph();
|
||||
//Restore settings, bug_738548
|
||||
ol.popGeneratorState();
|
||||
diff --git a/src/htmlgen.cpp b/src/htmlgen.cpp
|
||||
index a5ec7ff..28a363b 100644
|
||||
--- a/src/htmlgen.cpp
|
||||
+++ b/src/htmlgen.cpp
|
||||
@@ -1052,9 +1052,12 @@ void HtmlGenerator::endDoxyAnchor(const char *,const char *)
|
||||
// t << endl << "<p>" << endl;
|
||||
//}
|
||||
|
||||
-void HtmlGenerator::startParagraph()
|
||||
+void HtmlGenerator::startParagraph(const char *classDef)
|
||||
{
|
||||
- t << endl << "<p>";
|
||||
+ if (classDef)
|
||||
+ t << endl << "<p class=\"" << classDef << "\">";
|
||||
+ else
|
||||
+ t << endl << "<p>";
|
||||
}
|
||||
|
||||
void HtmlGenerator::endParagraph()
|
||||
diff --git a/src/htmlgen.h b/src/htmlgen.h
|
||||
index 30f54f4..1618fb2 100644
|
||||
--- a/src/htmlgen.h
|
||||
+++ b/src/htmlgen.h
|
||||
@@ -140,7 +140,7 @@ class HtmlGenerator : public OutputGenerator
|
||||
void startTitle() { t << "<div class=\"title\">"; }
|
||||
void endTitle() { t << "</div>"; }
|
||||
|
||||
- void startParagraph();
|
||||
+ void startParagraph(const char *classDef = NULL);
|
||||
void endParagraph();
|
||||
void writeString(const char *text);
|
||||
void startIndexListItem();
|
||||
diff --git a/src/latexgen.cpp b/src/latexgen.cpp
|
||||
index 37eacdb..f61360c 100644
|
||||
--- a/src/latexgen.cpp
|
||||
+++ b/src/latexgen.cpp
|
||||
@@ -1256,7 +1256,7 @@ void LatexGenerator::newParagraph()
|
||||
t << endl << endl;
|
||||
}
|
||||
|
||||
-void LatexGenerator::startParagraph()
|
||||
+void LatexGenerator::startParagraph(const char *)
|
||||
{
|
||||
t << endl << endl;
|
||||
}
|
||||
diff --git a/src/latexgen.h b/src/latexgen.h
|
||||
index 7b21ea4..844c9be 100644
|
||||
--- a/src/latexgen.h
|
||||
+++ b/src/latexgen.h
|
||||
@@ -135,7 +135,7 @@ class LatexGenerator : public OutputGenerator
|
||||
void endTitle() { t << "}"; }
|
||||
|
||||
void newParagraph();
|
||||
- void startParagraph();
|
||||
+ void startParagraph(const char *classDef = NULL);
|
||||
void endParagraph();
|
||||
void writeString(const char *text);
|
||||
void startIndexListItem() {}
|
||||
diff --git a/src/mangen.cpp b/src/mangen.cpp
|
||||
index 2f4d3ae..17e6003 100644
|
||||
--- a/src/mangen.cpp
|
||||
+++ b/src/mangen.cpp
|
||||
@@ -208,7 +208,7 @@ void ManGenerator::newParagraph()
|
||||
paragraph=TRUE;
|
||||
}
|
||||
|
||||
-void ManGenerator::startParagraph()
|
||||
+void ManGenerator::startParagraph(const char *)
|
||||
{
|
||||
if (!paragraph)
|
||||
{
|
||||
diff --git a/src/mangen.h b/src/mangen.h
|
||||
index daaae0c..5d0f6f1 100644
|
||||
--- a/src/mangen.h
|
||||
+++ b/src/mangen.h
|
||||
@@ -62,7 +62,7 @@ class ManGenerator : public OutputGenerator
|
||||
void endTitle();
|
||||
|
||||
void newParagraph();
|
||||
- void startParagraph();
|
||||
+ void startParagraph(const char *classDef = NULL);
|
||||
void endParagraph();
|
||||
void writeString(const char *text);
|
||||
void startIndexListItem() {}
|
||||
diff --git a/src/outputgen.h b/src/outputgen.h
|
||||
index 830fd49..a7da269 100644
|
||||
--- a/src/outputgen.h
|
||||
+++ b/src/outputgen.h
|
||||
@@ -188,7 +188,7 @@ class BaseOutputDocInterface : public CodeOutputInterface
|
||||
//virtual void newParagraph() = 0;
|
||||
|
||||
/*! Starts a new paragraph */
|
||||
- virtual void startParagraph() = 0;
|
||||
+ virtual void startParagraph(const char *classDef = NULL) = 0;
|
||||
/*! Ends a paragraph */
|
||||
virtual void endParagraph() = 0;
|
||||
|
||||
diff --git a/src/outputlist.h b/src/outputlist.h
|
||||
index 78a2ea0..c4ec3e4 100644
|
||||
--- a/src/outputlist.h
|
||||
+++ b/src/outputlist.h
|
||||
@@ -112,8 +112,8 @@ class OutputList : public OutputDocInterface
|
||||
{ forall(&OutputGenerator::endTitle); }
|
||||
//void newParagraph()
|
||||
//{ forall(&OutputGenerator::newParagraph); }
|
||||
- void startParagraph()
|
||||
- { forall(&OutputGenerator::startParagraph); }
|
||||
+ void startParagraph(const char *classDef = NULL)
|
||||
+ { forall(&OutputGenerator::startParagraph,classDef); }
|
||||
void endParagraph()
|
||||
{ forall(&OutputGenerator::endParagraph); }
|
||||
void writeString(const char *text)
|
||||
diff --git a/src/rtfgen.cpp b/src/rtfgen.cpp
|
||||
index 053d450..349d97d 100644
|
||||
--- a/src/rtfgen.cpp
|
||||
+++ b/src/rtfgen.cpp
|
||||
@@ -2144,7 +2144,7 @@ void RTFGenerator::newParagraph()
|
||||
m_omitParagraph = FALSE;
|
||||
}
|
||||
|
||||
-void RTFGenerator::startParagraph()
|
||||
+void RTFGenerator::startParagraph(const char *)
|
||||
{
|
||||
DBG_RTF(t << "{\\comment startParagraph}" << endl)
|
||||
newParagraph();
|
||||
diff --git a/src/rtfgen.h b/src/rtfgen.h
|
||||
index 27dd490..4d3c0ed 100644
|
||||
--- a/src/rtfgen.h
|
||||
+++ b/src/rtfgen.h
|
||||
@@ -62,7 +62,7 @@ class RTFGenerator : public OutputGenerator
|
||||
void endTitle() {}
|
||||
|
||||
void newParagraph();
|
||||
- void startParagraph();
|
||||
+ void startParagraph(const char *classDef = NULL);
|
||||
void endParagraph();
|
||||
void writeString(const char *text);
|
||||
void startIndexListItem();
|
||||
diff --git a/templates/html/doxygen.css b/templates/html/doxygen.css
|
||||
index db80bc8..26169de 100644
|
||||
--- a/templates/html/doxygen.css
|
||||
+++ b/templates/html/doxygen.css
|
||||
@@ -4,6 +4,10 @@ body, table, div, p, dl {
|
||||
font: 400 14px/22px Roboto,sans-serif;
|
||||
}
|
||||
|
||||
+p.reference, p.definition {
|
||||
+ font: 400 14px/22px Roboto,sans-serif;
|
||||
+}
|
||||
+
|
||||
/* @group Heading Levels */
|
||||
|
||||
h1.groupheader {
|
@ -1,15 +0,0 @@
|
||||
diff --git a/src/classdef.cpp b/src/classdef.cpp
|
||||
index 51fb8c6..111d59b 100644
|
||||
--- a/src/classdef.cpp
|
||||
+++ b/src/classdef.cpp
|
||||
@@ -573,7 +573,9 @@ void ClassDef::internalInsertMember(MemberDef *md,
|
||||
break;
|
||||
case Public:
|
||||
addMemberToList(MemberListType_pubTypes,md,TRUE);
|
||||
- isSimple=QCString(md->typeString()).find(")(")==-1;
|
||||
+ isSimple=!md->isEnumerate() &&
|
||||
+ !md->isEnumValue() &&
|
||||
+ QCString(md->typeString()).find(")(")==-1; // func ptr typedef
|
||||
break;
|
||||
case Private:
|
||||
addMemberToList(MemberListType_priTypes,md,TRUE);
|
24
doxygen.spec
24
doxygen.spec
@ -1,8 +1,8 @@
|
||||
Summary: A documentation system for C/C++
|
||||
Name: doxygen
|
||||
Epoch: 1
|
||||
Version: 1.8.12
|
||||
Release: 5%{?dist}
|
||||
Version: 1.8.13
|
||||
Release: 1%{?dist}
|
||||
|
||||
# No version is specified.
|
||||
License: GPL+
|
||||
@ -12,12 +12,6 @@ Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
|
||||
Source1: doxywizard.png
|
||||
Source2: doxywizard.desktop
|
||||
|
||||
# upstream fixes
|
||||
Patch1: doxygen-771310.patch
|
||||
Patch2: doxygen-771344.patch
|
||||
Patch3: doxygen-774273.patch
|
||||
Patch4: doxygen-774138.patch
|
||||
|
||||
BuildRequires: perl
|
||||
BuildRequires: tex(dvips)
|
||||
BuildRequires: tex(latex)
|
||||
@ -136,6 +130,20 @@ desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE2}
|
||||
# intentionally left blank
|
||||
|
||||
%changelog
|
||||
* Thu Dec 29 2016 Orion Poplawski <orion@cora.nwra.com> - 1:1.8.13-1
|
||||
- Update to 1.8.13
|
||||
- Drop upstream patches
|
||||
|
||||
* Thu Dec 22 2016 Orion Poplawski <orion@cora.nwra.com> - 1:1.8.12-7
|
||||
- Rebuild for xapian soname bump
|
||||
- Add patch to build with python rc
|
||||
|
||||
* Mon Dec 12 2016 Than Ngo <than@redhat.com> - 1:1.8.12-6
|
||||
- backport upstream patch to fix
|
||||
Bug 707266 - C++/CLI indexed property not documented
|
||||
Bug 774949 - Unknown reference in manual
|
||||
Bug 775245 - referencing Python files via tagfile broken
|
||||
|
||||
* Thu Dec 08 2016 Than Ngo <than@redhat.com> - 1:1.8.12-5
|
||||
- fixed bz#1402043 - runtime dependency on perl
|
||||
- backport upstream patch to fix Bug 774138 . add HTML classes to "Definition at..." & "Referenced by..." for CSS
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
1a84da877450422c5fc49e525c546cd4 doxywizard.png
|
||||
08e0f7850c4d22cb5188da226b209a96 doxygen-1.8.12.src.tar.gz
|
||||
SHA512 (doxygen-1.8.13.src.tar.gz) = 85da5bd28ad9f33a8e50fa92796817d31e59c024127cb647cb967e4321dd51378feaacdf099d578b7e6020fd646a3c63e99c77420e49e3894fc18ca89ba3e0a2
|
||||
SHA512 (doxywizard.png) = 42a7e5903bf27463d3b072cf043aef071b519b53054bbe647c522d5e499e02f554867ab5e9971b06493769cc17b9d1588462aeade284de1f9d579cf9f99e8851
|
||||
|
Loading…
Reference in New Issue
Block a user