fixed link issue against new clang

This commit is contained in:
Than Ngo 2020-07-08 14:25:56 +02:00
parent 4374fcf0de
commit 551b0a2a0e
2 changed files with 24 additions and 5 deletions

View File

@ -0,0 +1,13 @@
diff -up doxygen-1.8.18/CMakeLists.txt.old doxygen-1.8.18/CMakeLists.txt
diff -up doxygen-1.8.18/src/CMakeLists.txt.old doxygen-1.8.18/src/CMakeLists.txt
--- doxygen-1.8.18/src/CMakeLists.txt.old 2020-07-08 13:37:31.646148957 +0200
+++ doxygen-1.8.18/src/CMakeLists.txt 2020-07-08 13:45:53.470517795 +0200
@@ -308,7 +308,7 @@ if (use_libclang)
add_definitions(${LLVM_DEFINITIONS})
llvm_map_components_to_libnames(llvm_libs support core option)
target_compile_definitions(doxygen PRIVATE ${LLVM_DEFINITIONS})
- set(CLANG_LIBS libclang clangTooling ${llvm_libs})
+ set(CLANG_LIBS libclang clang-cpp -lLLVM-10)
endif()
target_link_libraries(doxygen

View File

@ -11,7 +11,7 @@ Summary: A documentation system for C/C++
Name: doxygen
Epoch: 1
Version: 1.8.18
Release: 3%{?dist}
Release: 4%{?dist}
# No version is specified.
License: GPL+
@ -19,11 +19,13 @@ Url: http://www.doxygen.nl
Source0: http://doxygen.nl/files/%{name}-%{version}.src.tar.gz
# this icon is part of kdesdk
Source1: doxywizard.desktop
%if 0%{?fedora} >= 32
Patch0: doxygen-1.8.18-clang.patch
%endif
# upstream patches
Patch0: doxygen-1.8.17-buffer-overflow.patch
Patch1: doxygen-1.8.18-memory-leaks.patch
Patch3: doxygen-1.8.18-md5-hash-does-not-match-for-two-different-runs.patch
Patch100: doxygen-1.8.17-buffer-overflow.patch
Patch101: doxygen-1.8.18-memory-leaks.patch
Patch103: doxygen-1.8.18-md5-hash-does-not-match-for-two-different-runs.patch
BuildRequires: %{_bindir}/python3
BuildRequires: ImageMagick
@ -105,6 +107,7 @@ BuildRequires: zlib-devel
%endif
%if "x%{?clang_support}" == "xON"
BuildRequires: llvm-devel
BuildRequires: clang-devel
%endif
Requires: perl-interpreter
Requires: graphviz
@ -305,6 +308,9 @@ make tests -C %{BuildDir}
%endif
%changelog
* Wed Jul 08 2020 Than Ngo <than@redhat.com> - 1.8.18-4
- fixed link issue against new clang
* Thu Jun 18 2020 Than Ngo <than@redhat.com> - 1.8.18-3
- fixed bz#1834591, enable clang support in fedora