14 lines
778 B
Diff
14 lines
778 B
Diff
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 42082192..f16726f8 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -744,7 +769,7 @@
|
|
message(STATUS "Not found telldus-core (telldus-core.h), not adding tellstick support")
|
|
endif (TELLDUSCORE_INCLUDE)
|
|
|
|
-target_link_libraries(domoticz ${Boost_LIBRARIES} ${ZLIB_LIBRARIES} ${MINIZIP_LIBRARIES} ${CURL_LIBRARIES} pthread ${MQTT_LIBRARIES} ${LUA_LIBRARIES} ${CMAKE_DL_LIBS} ${TELLDUS_LIBRARIES})
|
|
+target_link_libraries(domoticz ${Boost_LIBRARIES} ${ZLIB_LIBRARIES} ${MINIZIP_LIBRARIES} ${CURL_LIBRARIES} pthread -lpython3.8 -lcrypt -lpthread -ldl -lutil -lm -lm ${MQTT_LIBRARIES} ${LUA_LIBRARIES} ${CMAKE_DL_LIBS} ${TELLDUS_LIBRARIES})
|
|
|
|
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
|
target_link_libraries(domoticz -lresolv)
|