Python 3.8 linking fix

This commit is contained in:
Michael Cronenworth 2019-09-01 12:37:02 -05:00
parent c4a558a93f
commit 3d0a1dec50
2 changed files with 18 additions and 0 deletions

13
domoticz-python38.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42082192..f16726f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -727,7 +727,7 @@
message(STATUS "Not found telldus-core (telldus-core.h), not adding tellstick support")
endif (TELLDUSCORE_INCLUDE)
-target_link_libraries(domoticz ${Boost_LIBRARIES} ${ZLIB_LIBRARIES} ${MINIZIP_LIBRARIES} ${CURL_LIBRARIES} pthread ${LUA_LIBRARIES} ${MQTT_LIBRARIES} ${SQLite_LIBRARIES} ${CMAKE_DL_LIBS} ${TELLDUS_LIBRARIES})
+target_link_libraries(domoticz ${Boost_LIBRARIES} ${ZLIB_LIBRARIES} ${MINIZIP_LIBRARIES} ${CURL_LIBRARIES} pthread -lpython3.8 -lcrypt -lpthread -ldl -lutil -lm -lm ${LUA_LIBRARIES} ${MQTT_LIBRARIES} ${SQLite_LIBRARIES} ${CMAKE_DL_LIBS} ${TELLDUS_LIBRARIES})
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
target_link_libraries(domoticz -lresolv)

View File

@ -18,6 +18,8 @@ Patch2: %{name}-tinyxpath.patch
Patch3: %{name}-openzwave.patch
# Fix python detection (https://github.com/domoticz/domoticz/pull/1749)
Patch4: %{name}-python.patch
# Python 3.8 linking fix
Patch5: %{name}-python38.patch
BuildRequires: boost-devel
BuildRequires: cmake
@ -87,6 +89,9 @@ any mobile device
%patch2 -p1 -b.tinyxpath
%patch3 -p1 -b.openzwave
%patch4 -p1 -b.python
%if 0%{?fedora} >= 32
%patch5 -p1 -b.python38
%endif
rm -f hardware/openzwave/*.h
rm -rf hardware/openzwave/aes
rm -rf hardware/openzwave/command_classes