Update to 4.2.5

This commit is contained in:
Pavla Kratochvilova 2019-04-25 15:21:44 +02:00
parent 5c5ace422c
commit f75f077a94
4 changed files with 20 additions and 41 deletions

1
.gitignore vendored
View File

@ -127,3 +127,4 @@
/dnf-4.1.0.tar.gz
/dnf-4.2.1.tar.gz
/dnf-4.2.2.tar.gz
/dnf-4.2.5.tar.gz

View File

@ -1,34 +0,0 @@
From d78a76e621b5e7a95b074b86ab5b8fb80d0db40c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
Date: Thu, 4 Apr 2019 15:08:59 +0200
Subject: [PATCH] Fix the installation of completion_helper.py
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Change introduced in df19a47d672b09683cc03620a41114cd4239e prevents the
installation of completion_helper.py on Fedora 30.
Bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1695853
Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
---
dnf/cli/CMakeLists.txt | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/dnf/cli/CMakeLists.txt b/dnf/cli/CMakeLists.txt
index 5e335d0c..a32305bc 100644
--- a/dnf/cli/CMakeLists.txt
+++ b/dnf/cli/CMakeLists.txt
@@ -1,4 +1,6 @@
FILE(GLOB cli_SRCS *.py)
INSTALL (FILES ${cli_SRCS} DESTINATION ${PYTHON_INSTALL_DIR}/dnf/cli)
+# completion_helper.py is generated so the glob alone won't see it:
+INSTALL (FILES completion_helper.py DESTINATION ${PYTHON_INSTALL_DIR}/dnf/cli)
-ADD_SUBDIRECTORY (commands)
\ No newline at end of file
+ADD_SUBDIRECTORY (commands)
--
2.21.0

View File

@ -1,5 +1,5 @@
# default dependencies
%global hawkey_version 0.28.0
%global hawkey_version 0.31.0
%global libcomps_version 0.1.8
%global libmodulemd_version 1.4.0
%global rpm_version 4.14.0
@ -79,16 +79,14 @@
It supports RPMs, modules and comps groups & environments.
Name: dnf
Version: 4.2.2
Release: 2%{?dist}
Version: 4.2.5
Release: 1%{?dist}
Summary: %{pkg_summary}
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
URL: https://github.com/rpm-software-management/dnf
Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0001: 0001-Revert-Add-best-as-default-behavior-RhBug16707761671683.patch
# https://github.com/rpm-software-management/dnf/pull/1367
Patch0002: 0001-Fix-the-installation-of-completion_helper.py.patch
BuildArch: noarch
BuildRequires: cmake
BuildRequires: gettext
@ -215,7 +213,7 @@ Conflicts: dnfdaemon < %{conflicts_dnfdaemon_version}
%description -n python2-%{name}
Python 2 interface to DNF.
%endif
# ^ %{with python2}
# ^ %%{with python2}
%if %{with python3}
%package -n python3-%{name}
@ -415,6 +413,7 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
%dir %{confdir}/protected.d
%dir %{confdir}/vars
%dir %{confdir}/aliases.d
%exclude %{confdir}/aliases.d/zypper.conf
%config(noreplace) %{confdir}/%{name}.conf
%config(noreplace) %{confdir}/protected.d/%{name}.conf
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
@ -501,6 +500,19 @@ ln -sr %{buildroot}%{confdir}/vars %{buildroot}%{_sysconfdir}/yum/vars
%endif
%changelog
* Thu Apr 25 2019 Pavla Kratochvilova <pkratoch@redhat.com> - 4.2.5-1
- Update to 4.2.5
- Fix multilib obsoletes (RhBug:1672947)
- Do not remove group package if other packages depend on it
- Remove duplicates from "dnf list" and "dnf info" outputs
- Installroot now requires absolute path
- Allow globs in setopt in repoid part
- Fix formatting of message about free space required
- [doc] Add info of relation update_cache with fill_sack (RhBug:1658694)
- Fix installation failiure when duplicit RPMs are specified (RhBug:1687286)
- Add command abbreviations (RhBug:1634232)
- Allow plugins to terminate dnf (RhBug:1701807)
* Thu Apr 04 15:15:12 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 4.2.2-2
- Add patch fixing the installation of completion_helper.py
- Fix #1695853

View File

@ -1 +1 @@
SHA512 (dnf-4.2.2.tar.gz) = 0892640855a437fbe8218c1272944a11f0ef9f9c98c324a77072ad613bd61de4d9a0d98cf1a59003d99266de3088d54f2aadfa141d295b2df45806b673b22c21
SHA512 (dnf-4.2.5.tar.gz) = 3366a39150111b04b3e1d792dabf21f8dae98d0ee3f5e67580510bb12846a109f45945e5655c708f3440c763b26fa1b27e9efd1347194ace2eac77a0201adf11