Update to 0.6.4-7

This commit is contained in:
Michal Luscon 2015-09-23 16:27:08 +02:00
parent dfbd3a21db
commit 748b4bf32d
2 changed files with 100 additions and 1 deletions

View File

@ -0,0 +1,93 @@
---
dnf/yum/config.py | 2 +-
doc/conf_ref.rst | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/dnf/yum/config.py b/dnf/yum/config.py
index 2d8e1f5..6f1816b 100644
--- a/dnf/yum/config.py
+++ b/dnf/yum/config.py
@@ -772,7 +772,7 @@ class YumConf(BaseConfig):
enablegroups = BoolOption(True)
bandwidth = BytesOption(0)
- minrate = BytesOption(0)
+ minrate = BytesOption(1000)
ip_resolve = CaselessSelectionOption(
allowed=('ipv4', 'ipv6', 'whatever'),
mapper={'4': 'ipv4', '6': 'ipv6'})
diff --git a/doc/conf_ref.rst b/doc/conf_ref.rst
index 865cfe8..3b85cef 100644
--- a/doc/conf_ref.rst
+++ b/doc/conf_ref.rst
@@ -224,7 +224,7 @@ configuration.
``minrate``
storage size
- This sets the low speed threshold in bytes per second. If the server is sending data at the same or slower speed than this value for at least :ref:`timeout option <timeout-label>` seconds, DNF aborts the connection. The default is 0. Valid units are 'k', 'M', 'G'.
+ This sets the low speed threshold in bytes per second. If the server is sending data at the same or slower speed than this value for at least :ref:`timeout option <timeout-label>` seconds, DNF aborts the connection. The default is 1000. Valid units are 'k', 'M', 'G'.
``proxy``
string
--
2.4.3
---
dnf/yum/rpmsack.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/dnf/yum/rpmsack.py b/dnf/yum/rpmsack.py
index 840168f..dcfdced 100644
--- a/dnf/yum/rpmsack.py
+++ b/dnf/yum/rpmsack.py
@@ -292,7 +292,8 @@ class RPMDBAdditionalDataPackage(object):
def __setattr__(self, attr, value):
if not attr.startswith('_'):
- self._write(attr, value)
+ if value is not None:
+ self._write(attr, value)
else:
object.__setattr__(self, attr, value)
--
2.4.3
---
dnf.spec | 6 +++++-
rel-eng/packages/dnf | 2 +-
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/dnf.spec b/dnf.spec
index 00025db..8b4a748 100644
--- a/dnf.spec
+++ b/dnf.spec
@@ -11,7 +11,7 @@
Name: dnf
Version: 0.6.4
-Release: 6%{?snapshot}%{?dist}
+Release: 7%{?snapshot}%{?dist}
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
@@ -206,6 +206,10 @@ exit 0
%systemd_postun_with_restart dnf-automatic.timer
%changelog
+* Wed Sep 23 2015 Michal Luscon <mluscon@redhat.com> 0.6.4-7
+- don't store empty attributes (RhBug:1246928)
+- conf: change minrate threshold to librepo default (RhBug:1212320)
+
* Wed Aug 26 2015 Michal Luscon <mluscon@redhat.com> 0.6.4-6
- test: don't compute hash from absolute local file path (introduced in
10518b6)
diff --git a/rel-eng/packages/dnf b/rel-eng/packages/dnf
index 40ad0fa..85e0f81 100644
--- a/rel-eng/packages/dnf
+++ b/rel-eng/packages/dnf
@@ -1 +1 @@
-0.6.4-6 ./
+0.6.4-7 ./
--
2.4.3

View File

@ -11,7 +11,7 @@
Name: dnf
Version: 0.6.4
Release: 6%{?snapshot}%{?dist}
Release: 7%{?snapshot}%{?dist}
Summary: Package manager forked from Yum, using libsolv as a dependency resolver
# For a breakdown of the licensing, see PACKAGE-LICENSING
License: GPLv2+ and GPLv2 and GPL
@ -27,6 +27,7 @@ Patch1: dnf-0.6.4-2-to-dnf-0.6.4-3.patch
Patch2: dnf-0.6.4-3-to-dnf-0.6.4-4.patch
Patch3: dnf-0.6.4-4-to-dnf-0.6.4-5.patch
Patch4: dnf-0.6.4-5-to-dnf-0.6.4-6.patch
Patch5: dnf-0.6.4-6-to-dnf-0.6.4-7.patch
BuildArch: noarch
BuildRequires: cmake
BuildRequires: pygpgme
@ -110,6 +111,7 @@ Alternative CLI to "dnf upgrade" suitable for automatic, regular execution.
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
rm -rf py3
mkdir ../py3
cp -a . ../py3/
@ -215,6 +217,10 @@ exit 0
%systemd_postun_with_restart dnf-automatic.timer
%changelog
* Wed Sep 23 2015 Michal Luscon <mluscon@redhat.com> 0.6.4-7
- don't store empty attributes (RhBug:1246928)
- conf: change minrate threshold to librepo default (RhBug:1212320)
* Wed Aug 26 2015 Michal Luscon <mluscon@redhat.com> 0.6.4-6
- cleanup old cache in posttrans (Michael Mraka)
- include /var/cache/dnf into rpm (Michael Mraka)