New upstream version 0.2.8 introducing cache_{check,dump,repair,restore}

This commit is contained in:
Heinz Mauelshagen 2013-10-18 18:05:37 +02:00
parent c42cbdeafe
commit d6497f6c59
4 changed files with 315 additions and 5 deletions

View File

@ -0,0 +1,24 @@
--- thin-provisioning-tools-0.2.8/Makefile.in.orig 2013-10-18 17:11:34.320772851 +0200
+++ thin-provisioning-tools-0.2.8/Makefile.in 2013-10-18 17:11:09.938219484 +0200
@@ -299,6 +299,10 @@
install: $(PROGRAMS)
$(INSTALL_DIR) $(BINDIR)
+ $(INSTALL_PROGRAM) cache_check $(BINDIR)
+ $(INSTALL_PROGRAM) cache_dump $(BINDIR)
+ $(INSTALL_PROGRAM) cache_repair $(BINDIR)
+ $(INSTALL_PROGRAM) cache_restore $(BINDIR)
$(INSTALL_PROGRAM) thin_check $(BINDIR)
$(INSTALL_PROGRAM) thin_dump $(BINDIR)
$(INSTALL_PROGRAM) thin_repair $(BINDIR)
@@ -306,6 +310,10 @@
$(INSTALL_PROGRAM) thin_rmap $(BINDIR)
$(INSTALL_PROGRAM) thin_metadata_size $(BINDIR)
$(INSTALL_DIR) $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_check.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_dump.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_repair.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_restore.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_check.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_dump.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_repair.8 $(MANPATH)/man8

View File

@ -0,0 +1,270 @@
diff --git a/man8/cache_check.8 b/man8/cache_check.8
new file mode 100644
index 0000000..5cc7dff
--- /dev/null
+++ b/man8/cache_check.8
@@ -0,0 +1,62 @@
+.TH CACHE_CHECK 8 "Thin Provisioning Tools" "Red Hat, Inc." \" -*- nroff -*-
+.SH NAME
+cache_check \- repair cache metadata on device or file
+
+.SH SYNOPSIS
+.B cache_check
+.RB [ options ]
+.I {device|file}
+
+.SH DESCRIPTION
+.B cache_check
+checks cache metadata created by
+the device-mapper cache target on a
+.I device
+or
+.I file.
+
+.SH OPTIONS
+.IP "\fB\-q, \-\-quiet\fP"
+Suppress output messages, return only exit code.
+
+.IP "\fB\-h, \-\-help\fP"
+Print help and exit.
+
+.IP "\fB\-V, \-\-version\fP"
+Output version information and exit.
+
+.IP "\fB\-\-super\-block\-only\fP"
+Only check the superblock is present.
+
+.IP "\fB\-\-skip-mappings\fP"
+Skip checking of the block mappings which make up the bulk of the
+metadata.
+
+.IP "\fB\-\-skip-hints\fP"
+Skip checking of the policy hint values metadata.
+
+.IP "\fB\-\-skip-discards\fP"
+Skip checking of the discard bits in the metadata.
+
+.SH EXAMPLE
+Analyses and repairs cache metadata on logical volume
+/dev/vg/metadata:
+.sp
+.B cache_check /dev/vg/metadata
+
+The device may not be actively used by the target
+when running.
+
+.SH DIAGNOSTICS
+.B cache_check
+returns an exit code of 0 for success or 1 for error.
+
+.SH SEE ALSO
+.B cache_dump(8)
+.B cache_repair(8)
+.B cache_restore(8)
+
+.SH AUTHOR
+Joe Thornber <ejt@redhat.com>
+.br
+Heinz Mauelshagen <HeinzM@RedHat.com>
diff --git a/man8/cache_dump.8 b/man8/cache_dump.8
new file mode 100644
index 0000000..a0c2924
--- /dev/null
+++ b/man8/cache_dump.8
@@ -0,0 +1,59 @@
+.TH CACHE_DUMP 8 "Thin Provisioning Tools" "Red Hat, Inc." \" -*- nroff -*-
+.SH NAME
+cache_dump \- dump cache metadata from device or file to standard output
+
+.SH SYNOPSIS
+.B cache_dump
+.RB [options]
+.I {device|file}
+
+.SH DESCRIPTION
+.B cache_dump
+dumps binary cache metadata created by
+the device-mapper cache target on a
+.I device
+or
+.I file
+to standard output for
+analysis or postprocessing in XML format.
+XML formated metadata can be fed into cache_restore (see
+.BR cache_restore(8) )
+in order to put it back onto a metadata
+.I device
+(to process by the device-mapper target) or
+.I file.
+
+.IP "\fB\-r, \-\-repair\fP".
+Repair the metadata whilst dumping it.
+
+.IP "\fB\-h, \-\-help\fP".
+Print help and exit.
+
+.IP "\fB\-V, \-\-version\fP".
+Output version information and exit.
+
+.SH EXAMPLES
+Dumps the cache metadata on logical volume /dev/vg/metadata
+to standard output in XML format:
+.sp
+.B cache_dump /dev/vg/metadata
+
+.SH EXAMPLES
+Dumps the cache metadata on logical volume /dev/vg/metadata
+whilst repairing it to standard output in XML format:
+.sp
+.B cache_dump --repair /dev/vg/metadata
+
+.SH DIAGNOSTICS
+.B cache_dump
+returns an exit code of 0 for success or 1 for error.
+
+.SH SEE ALSO
+.B cache_check(8)
+.B cache_repair(8)
+.B cache_restore(8)
+
+.SH AUTHOR
+Joe Thornber <ejt@redhat.com>
+.br
+Heinz Mauelshagen <HeinzM@RedHat.com>
diff --git a/man8/cache_repair.8 b/man8/cache_repair.8
new file mode 100644
index 0000000..ef04a7f
--- /dev/null
+++ b/man8/cache_repair.8
@@ -0,0 +1,61 @@
+.TH CACHE_REPAIR 8 "Thin Provisioning Tools" "Red Hat, Inc." \" -*- nroff -*-
+.SH NAME
+cache_repair \- repair cache binary metadata from device/file to device/file
+
+.SH SYNOPSIS
+.B cache_repair
+.RB [ options ]
+.RB -i
+.I {device|file}
+.RB -o
+.I {device|file}
+
+.SH DESCRIPTION
+.B cache_repair
+reads binary cache metadata created by the
+respective device-mapper target from one
+.I device
+or
+.I file
+, repairs it and writes it to another
+.I device
+or
+.I file.
+If written to a metadata
+.I device
+, the metadata can be processed
+by the device-mapper target.
+
+.IP "\fB\-i, \-\-input\fP \fI{device|file}\fP"
+Input file or device with binary metadata.
+
+.IP "\fB\-o, \-\-output\fP \fI{device|file}\fP"
+Output file or device for repaired binary metadata.
+
+.IP "\fB\-h, \-\-help\fP"
+Print help and exit.
+
+.IP "\fB\-V, \-\-version\fP"
+Output version information and exit.
+
+.SH EXAMPLE
+Reads the binary cache metadata from file
+.B metadata
+, repairs it and writes it to logical volume /dev/vg/metadata
+for further processing by the respective device-mapper target:
+.sp
+.B cache_repair -i metadata -o /dev/vg/metadata
+
+.SH DIAGNOSTICS
+.B cache_repair
+returns an exit code of 0 for success or 1 for error.
+
+.SH SEE ALSO
+.B cache_dump(8)
+.B cache_check(8)
+.B cache_restore(8)
+
+.SH AUTHOR
+Joe Thornber <ejt@redhat.com>
+.br
+Heinz Mauelshagen <HeinzM@RedHat.com>
diff --git a/man8/cache_restore.8 b/man8/cache_restore.8
new file mode 100644
index 0000000..5f9fdca
--- /dev/null
+++ b/man8/cache_restore.8
@@ -0,0 +1,64 @@
+.TH CACHE_RESTORE 8 "Thin Provisioning Tools" "Red Hat, Inc." \" -*- nroff -*-
+.SH NAME
+cache_restore \- restore cache metadata file to device or file
+
+.SH SYNOPSIS
+.B cache_restore
+.RB [ options ]
+.RB -i
+.I {device|file}
+.RB -o
+.I {device|file}
+
+.SH DESCRIPTION
+.B cache_restore
+restores cache metadata created by the respective
+device-mapper target dumped into an XML formatted (see
+.BR cache_dump(8) )
+.I file
+, which optionally can be preprocessed before the restore to another
+.I device
+or
+.I file.
+If restored to a metadata
+.I device
+, the metadata can be processed by the device-mapper target.
+
+.IP "\fB\-i, \-\-input\fP \fI{device|file}\fP"
+Input file or device with metadata.
+
+.IP "\fB\-o, \-\-output\fP \fI{device|file}\fP"
+Output file or device.
+
+.IP "\fB{\-\-debug-override-metadata-version}\fP \fI<integer>\fP"
+ONLY FOR DEBUGGING PURPOSES:
+.br
+override the version stored in the metadata.
+
+.IP "\fB\-h, \-\-help\fP"
+Print help and exit.
+
+.IP "\fB\-V, \-\-version\fP"
+Output version information and exit.
+
+.SH EXAMPLE
+Restores the XML formatted cache metadata on file
+.B metadata
+to logical volume /dev/vg/metadata for further processing by the
+respective device-mapper target:
+.sp
+.B cache_restore -i metadata -o /dev/vg/metadata
+
+.SH DIAGNOSTICS
+.B cache_restore
+returns an exit code of 0 for success or 1 for error.
+
+.SH SEE ALSO
+.B cache_dump(8)
+.B cache_check(8)
+.B cache_repair(8)
+
+.SH AUTHOR
+Joe Thornber <ejt@redhat.com>
+.br
+Heinz Mauelshagen <HeinzM@RedHat.com>

View File

@ -3,23 +3,28 @@
#
Summary: Device-mapper thin provisioning tools
Name: device-mapper-persistent-data
Version: 0.2.7
Version: 0.2.8
Release: 1%{?dist}
License: GPLv3+
Group: System Environment/Base
URL: https://github.com/jthornber/thin-provisioning-tools
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-v%{version}.tar.bz2
# Source1: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}.tar.gz
Patch0: device-mapper-persistent-data-0.2.8-1-missing-man-pages.patch
Patch1: device-mapper-persistent-data-0.2.8-1-missing-installs.patch
BuildRequires: autoconf, expat-devel, libstdc++-devel, boost-devel
Requires: expat
%description
thin-provisioning-tools contains check,dump,restore,repair,rmap and metadata_size
tools to manage device-mapper thin provisioning target metadata devices or
metadata on files.
thin-provisioning-tools contains check,dump,restore,repair,rmap
and metadata_size tools to manage device-mapper thin provisioning
target metadata devices; cache check,dump,restore and repair tools
to manage device-mapper cache metadata devices are included.
%prep
%setup -q -n thin-provisioning-tools-%{version}
%patch0 -p1
%patch1 -p1
echo %{version}-%{release} > VERSION
%build
@ -34,12 +39,20 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%files
%doc COPYING README.md
%{_mandir}/man8/cache_check.8.gz
%{_mandir}/man8/cache_dump.8.gz
%{_mandir}/man8/cache_repair.8.gz
%{_mandir}/man8/cache_restore.8.gz
%{_mandir}/man8/thin_check.8.gz
%{_mandir}/man8/thin_dump.8.gz
%{_mandir}/man8/thin_metadata_size.8.gz
%{_mandir}/man8/thin_repair.8.gz
%{_mandir}/man8/thin_restore.8.gz
%{_mandir}/man8/thin_rmap.8.gz
%{_sbindir}/cache_check
%{_sbindir}/cache_dump
%{_sbindir}/cache_repair
%{_sbindir}/cache_restore
%{_sbindir}/thin_check
%{_sbindir}/thin_dump
%{_sbindir}/thin_metadata_size
@ -48,6 +61,9 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_sbindir}/thin_rmap
%changelog
* Fri Oct 18 2013 Heinz Mauelshagen <heinzm@redhat.com> - 0.2.8-1
- New upstream version 0.2.8 introducing cache_{check,dump,repair,restore}
* Tue Sep 17 2013 Heinz Mauelshagen <heinzm@redhat.com> - 0.2.7-1
- New upstream version 0.2.7

View File

@ -1 +1 @@
7c9573504efa2723ff442c4f9af80172 thin-provisioning-tools-v0.2.7.tar.bz2
c8799aab7032030b78439cd774f3b072 thin-provisioning-tools-v0.2.8.tar.bz2