New upstream release 0.6.2-rc5.

This commit is contained in:
Peter Rajnoha 2016-03-08 09:43:44 +01:00
parent 811b27d1ae
commit c964eb3eb5
5 changed files with 19 additions and 54 deletions

1
.gitignore vendored
View File

@ -11,3 +11,4 @@
/thin-provisioning-tools-0.5.3.tar.gz
/thin-provisioning-tools-0.5.4.tar.gz
/thin-provisioning-tools-0.5.5.tar.gz
/thin-provisioning-tools-0.6.2-rc5.tar.gz

View File

@ -1,11 +0,0 @@
--- a/Makefile.in 2014-11-12 18:46:30.282251378 +0100
+++ b/Makefile.in 2014-11-12 18:46:56.108608255 +0100
@@ -108,7 +108,7 @@
vpath %.cc $(TOP_DIR)
INSTALL_DIR = $(INSTALL) -m 755 -d
-INSTALL_PROGRAM = $(INSTALL) -m 755 -s
+INSTALL_PROGRAM = $(INSTALL) -m 755
INSTALL_DATA = $(INSTALL) -p -m 644
ifeq ("@TESTING@", "yes")

View File

@ -1,36 +0,0 @@
VERSION | 2 +-
caching/cache_check.cc | 7 ++++---
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/VERSION b/VERSION
index cb0c939..7d85683 100644
--- a/VERSION
+++ b/VERSION
@@ -1 +1 @@
-0.5.2
+0.5.4
diff --git a/caching/cache_check.cc b/caching/cache_check.cc
index 005159e..9bd34be 100644
--- a/caching/cache_check.cc
+++ b/caching/cache_check.cc
@@ -220,7 +220,9 @@ namespace {
write_superblock(bm, sb);
}
- error_state metadata_check(block_manager<>::ptr bm, flags const &fs) {
+ error_state metadata_check(string const &path, flags const &fs) {
+ block_manager<>::ptr bm = open_bm(path, block_manager<>::READ_ONLY);
+
nested_output out(cerr, 2);
if (fs.quiet_)
out.disable();
@@ -295,8 +297,7 @@ namespace {
throw runtime_error(msg.str());
}
- block_manager<>::ptr bm = open_bm(path, block_manager<>::READ_ONLY);
- err = metadata_check(bm, fs);
+ err = metadata_check(path, fs);
bool success = false;

View File

@ -1,18 +1,22 @@
#
# Copyright (C) 2011-2015 Red Hat, Inc
# Copyright (C) 2011-2016 Red Hat, Inc
#
%define pre_release_upstream -rc5
%define pre_release rc5
Summary: Device-mapper Persistent Data Tools
Name: device-mapper-persistent-data
Version: 0.5.5
Release: 1%{?dist}
Version: 0.6.2
Release: 0.1.%{pre_release}%{?dist}
License: GPLv3+
Group: System Environment/Base
URL: https://github.com/jthornber/thin-provisioning-tools
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-%{version}.tar.gz
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-%{version}%{pre_release_upstream}.tar.gz
# Source1: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}.tar.gz
Patch0: device-mapper-persistent-data-document-clear-needs-check-flag.patch
Patch1: device-mapper-persistent-data-add-era_restore-and-cache_metadata_size-man-pages.patch
Patch2: device-mapper-persistent-avoid-strip.patch
Patch2: device-mapper-persistent-data-avoid-strip.patch
BuildRequires: autoconf, expat-devel, libaio-devel, libstdc++-devel, boost-devel
Requires: expat
@ -26,7 +30,7 @@ are included and era check, dump, restore and invalidate to manage
snapshot eras
%prep
%setup -q -n thin-provisioning-tools-%{version}
%setup -q -n thin-provisioning-tools-%{version}%{pre_release_upstream}
%patch0 -p1 -b .clear_needs_check_flag
%patch1 -p1 -b .man_pages
%patch2 -p1 -b .avoid_strip
@ -54,6 +58,7 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_mandir}/man8/thin_check.8.gz
%{_mandir}/man8/thin_delta.8.gz
%{_mandir}/man8/thin_dump.8.gz
%{_mandir}/man8/thin_ls.8.gz
%{_mandir}/man8/thin_metadata_size.8.gz
%{_mandir}/man8/thin_restore.8.gz
%{_mandir}/man8/thin_repair.8.gz
@ -72,6 +77,7 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_sbindir}/thin_check
%{_sbindir}/thin_delta
%{_sbindir}/thin_dump
%{_sbindir}/thin_ls
%{_sbindir}/thin_metadata_size
%{_sbindir}/thin_restore
%{_sbindir}/thin_repair
@ -79,6 +85,11 @@ make DESTDIR=%{buildroot} MANDIR=%{_mandir} install
%{_sbindir}/thin_trim
%changelog
* Tue Mar 08 2016 Peter Rajnoha <prajnoha@redhat.com> - 0.6.2-0.1.rc5
- New thin_ls command.
- era_invalidate may be run on live metadata if the --metadata-snap
option is given.
* Thu Aug 13 2015 Peter Rajnoha <prajnoha@redhat.com> - 0.5.5-1
- Support thin_delta's --metadata_snap option without specifying snap location.
- Update man pages to make it clearer that tools shoulnd't be run on live metadata.

View File

@ -1 +1 @@
6aa3d8294e66d967ac7c3d524e9835d2 thin-provisioning-tools-0.5.5.tar.gz
5c35bdb6654208f688e5d236e9b98fb4 thin-provisioning-tools-0.6.2-rc5.tar.gz