add missing files to Makefile.in to install

This commit is contained in:
Heinz Mauelshagen 2013-10-18 17:17:23 +02:00
parent 70cb8d0903
commit 18673315e8
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,24 @@
--- thin-provisioning-tools-0.2.8/Makefile.in.orig 2013-10-18 17:11:34.320772851 +0200
+++ thin-provisioning-tools-0.2.8/Makefile.in 2013-10-18 17:11:09.938219484 +0200
@@ -299,6 +299,10 @@
install: $(PROGRAMS)
$(INSTALL_DIR) $(BINDIR)
+ $(INSTALL_PROGRAM) cache_check $(BINDIR)
+ $(INSTALL_PROGRAM) cache_dump $(BINDIR)
+ $(INSTALL_PROGRAM) cache_repair $(BINDIR)
+ $(INSTALL_PROGRAM) cache_restore $(BINDIR)
$(INSTALL_PROGRAM) thin_check $(BINDIR)
$(INSTALL_PROGRAM) thin_dump $(BINDIR)
$(INSTALL_PROGRAM) thin_repair $(BINDIR)
@@ -306,6 +310,10 @@
$(INSTALL_PROGRAM) thin_rmap $(BINDIR)
$(INSTALL_PROGRAM) thin_metadata_size $(BINDIR)
$(INSTALL_DIR) $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_check.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_dump.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_repair.8 $(MANPATH)/man8
+ $(INSTALL_DATA) man8/cache_restore.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_check.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_dump.8 $(MANPATH)/man8
$(INSTALL_DATA) man8/thin_repair.8 $(MANPATH)/man8

View File

@ -11,6 +11,7 @@ URL: https://github.com/jthornber/thin-provisioning-tools
Source0: https://github.com/jthornber/thin-provisioning-tools/archive/thin-provisioning-tools-v%{version}.tar.bz2
# Source1: https://github.com/jthornber/thin-provisioning-tools/archive/v%{version}.tar.gz
Patch0: device-mapper-persistent-data-0.2.8-1-missing-man-pages.patch
Patch1: device-mapper-persistent-data-0.2.8-1-missing-installs.patch
BuildRequires: autoconf, expat-devel, libstdc++-devel, boost-devel
Requires: expat
@ -27,6 +28,7 @@ to manage device-mapper cache metadata devices are included.
%prep
%setup -q -n thin-provisioning-tools-%{version}
%patch0 -p1
%patch1 -p1
echo %{version}-%{release} > VERSION
%build