New release 5.5.77

This commit is contained in:
Robin Lee 2022-08-21 17:29:06 +08:00
parent b16ad039fa
commit 46279e81c4
6 changed files with 109 additions and 76 deletions

1
.gitignore vendored
View File

@ -13,3 +13,4 @@
/dde-control-center-5.0.0.tar.gz
/dde-control-center-5.3.0.39.tar.gz
/dde-control-center-5.4.70.tar.gz
/dde-control-center-5.5.77.tar.gz

View File

@ -1,33 +0,0 @@
From 3eaa60b2251d4a78ea0620791e061531cc90d95b Mon Sep 17 00:00:00 2001
From: justforlxz <justforlxz@gmail.com>
Date: Tue, 27 Apr 2021 10:08:22 +0800
Subject: [PATCH] fix: hide end user license on other linux
only deepin community version have
Log:
---
.../window/modules/systeminfo/systeminfowidget.cpp | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/src/frame/window/modules/systeminfo/systeminfowidget.cpp b/src/frame/window/modules/systeminfo/systeminfowidget.cpp
index 7b70c611a..5c1e795e4 100644
--- a/src/frame/window/modules/systeminfo/systeminfowidget.cpp
+++ b/src/frame/window/modules/systeminfo/systeminfowidget.cpp
@@ -81,6 +81,16 @@ void SystemInfoWidget::initData()
{"dcc_privacy_policy", tr("Privacy Policy"), QMetaMethod::fromSignal(&SystemInfoWidget::requestShowPrivacyPolicy), nullptr, "privacyPolicy"}
};
+ if (DSysInfo::isCommunityEdition() && DSysInfo::productType() != DSysInfo::ProductType::Deepin) {
+ auto it = std::find_if(m_itemList.begin(), m_itemList.end(), [=] (const ListSubItem &item) {
+ return item.itemIcon == "dcc_protocol";
+ });
+
+ if (it != m_itemList.end()) {
+ m_itemList.erase(it);
+ }
+ }
+
for (auto m : m_itemList) {
DStandardItem *item = new DStandardItem;
item->setIcon(QIcon::fromTheme(m.itemIcon));

94
407.patch Normal file
View File

@ -0,0 +1,94 @@
From 2e2ae848e22037c92da1d4c0522675ac61fa4597 Mon Sep 17 00:00:00 2001
From: rewine <lhongxu@outlook.com>
Date: Wed, 16 Mar 2022 16:38:18 +0800
Subject: [PATCH] feat: add build flag to disable authentication module
Log: authentication module make error in other distribution
Task: https://github.com/linuxdeepin/developer-center/issues/2245
---
src/frame/CMakeLists.txt | 15 ++++++++++++++-
src/frame/window/mainwindow.cpp | 6 ++++++
2 files changed, 20 insertions(+), 1 deletion(-)
diff --git a/src/frame/CMakeLists.txt b/src/frame/CMakeLists.txt
index 5f78f1ec0c..32eb467657 100644
--- a/src/frame/CMakeLists.txt
+++ b/src/frame/CMakeLists.txt
@@ -31,6 +31,8 @@ if (CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
set(CMAKE_INSTALL_PREFIX /usr)
endif ()
+option(DISABLE_AUTHENTICATION "disable authentication module" OFF)
+
set(DEFINED_LIST
DISABLE_OPACITY_ANIMATION
DISABLE_CLOUD_SYNC
@@ -536,6 +538,10 @@ set(SRCS
${NOTIFICATION_FILES}
)
+if (DEFINED DISABLE_AUTHENTICATION)
+ list(REMOVE_ITEM SRCS ${AUTHENTICATION_FILES})
+endif()
+
set(QRC
frame.qrc
modules/wacom/wacom.qrc
@@ -560,6 +566,10 @@ set(QRC
window/modules/update/dccv20update.qrc
)
+if (DEFINED DISABLE_AUTHENTICATION)
+ list(REMOVE_ITEM QRC modules/authentication/authentication.qrc)
+endif()
+
# Find the library
find_package(PkgConfig REQUIRED)
find_package(DtkWidget REQUIRED)
@@ -604,7 +614,10 @@ file(GLOB DCONFIG_FILES "../../configs/org.deepin.dde.control-center*.json")
dconfig_meta_files(APPID dde-control-center BASE ../../configs FILES ${DCONFIG_FILES})
set(DEEPIN_PW_CHECK libdeepin_pw_check.so)
-set(SHMN_VIDEO libdareader.so)
+
+if (NOT DEFINED DISABLE_AUTHENTICATION)
+ set(SHMN_VIDEO libdareader.so)
+endif()
function(add_build_macro macro)
string(TOUPPER ${macro} macro)
diff --git a/src/frame/window/mainwindow.cpp b/src/frame/window/mainwindow.cpp
index bc902844f9..097f826ca7 100644
--- a/src/frame/window/mainwindow.cpp
+++ b/src/frame/window/mainwindow.cpp
@@ -18,7 +18,9 @@
* You should have received a copy of the GNU General Public License
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#ifndef DISABLE_AUTHENTICATION
#include "modules/authentication/loginoptionsmodule.h"
+#endif
#include "modules/accounts/accountsmodule.h"
#include "modules/bluetooth/bluetoothmodule.h"
#include "modules/commoninfo/commoninfomodule.h"
@@ -312,7 +314,9 @@ void MainWindow::initAllModule(const QString &m)
return;
m_bInit = true;
+#ifndef DISABLE_AUTHENTICATION
using namespace authentication;
+#endif
using namespace sync;
using namespace datetime;
using namespace defapp;
@@ -332,7 +336,9 @@ void MainWindow::initAllModule(const QString &m)
using namespace notification;
m_modules = {
+ #ifndef DISABLE_AUTHENTICATION
{ new LoginOptionsModule(this), tr("Biometric Authentication")},
+ #endif
{ new AccountsModule(this), tr("Accounts")},
{ new DisplayModule(this), tr("Display")},
{ new TouchscreenModule(this), tr("Touch Screen")},

View File

@ -1,29 +0,0 @@
From 15a3b5101853ee0b1b62e5e7dde217cbf9a454bf Mon Sep 17 00:00:00 2001
From: wangwei <wangwei@uniontech.com>
Date: Fri, 10 Apr 2020 22:55:46 +0800
Subject: [PATCH] =?UTF-8?q?feat(commoninfo):=20=E7=A4=BE=E5=8C=BA=E7=89=88?=
=?UTF-8?q?=E6=B2=A1=E6=9C=89=E2=80=9C=E7=94=A8=E6=88=B7=E4=BD=93=E9=AA=8C?=
=?UTF-8?q?=E8=AE=A1=E5=88=92=E2=80=9D=E9=A1=B9?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Feat(19420) 社区版去掉用户体验计划
---
src/frame/window/modules/commoninfo/commoninfowidget.cpp | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/frame/window/modules/commoninfo/commoninfowidget.cpp b/src/frame/window/modules/commoninfo/commoninfowidget.cpp
index 47c1424e8..8c6ff52d3 100644
--- a/src/frame/window/modules/commoninfo/commoninfowidget.cpp
+++ b/src/frame/window/modules/commoninfo/commoninfowidget.cpp
@@ -108,9 +108,6 @@ void CommonInfoWidget::initData()
m_itemList.append({"dcc_developer_mode", tr("Developer Mode"),
QMetaMethod::fromSignal(&CommonInfoWidget::requestShowDeveloperModeWidget), nullptr, "developerMode"});
}
- //~ contents_path /commoninfo/User Experience Program
- m_itemList.append({"dcc_ue_plan", tr("User Experience Program"),
- QMetaMethod::fromSignal(&CommonInfoWidget::requestShowUEPlanWidget), nullptr, "userExperienceProgram"});
#if 0
m_itemList.append({"", tr("Tablet Mode"),

View File

@ -7,18 +7,16 @@ Name: deepin-control-center
%global dde_prefix dde
Name: %{repo}
%endif
Version: 5.4.70
Version: 5.5.77
Release: %autorelease
Summary: New control center for Linux Deepin
License: GPLv3
URL: https://github.com/linuxdeepin/%{repo}
Source0: %{url}/archive/%{version}/%{repo}-%{version}.tar.gz
Patch0: https://raw.githubusercontent.com/archlinux/svntogit-community/packages/deepin-control-center/trunk/deepin-control-center-systeminfo-deepin-icon.patch
Patch0: https://raw.githubusercontent.com/archlinux/svntogit-community/60ac39ad6f703cb47cbbb24cc4c882609bad25b7/trunk/deepin-control-center-systeminfo-deepin-icon.patch
Patch1: https://raw.githubusercontent.com/archlinux/svntogit-community/packages/deepin-control-center/trunk/deepin-control-center-no-user-experience.patch
Patch2: https://github.com/linuxdeepin/dde-control-center/pull/387.patch
Patch1: https://patch-diff.githubusercontent.com/raw/linuxdeepin/dde-control-center/pull/407.patch
BuildRequires: gcc-c++
BuildRequires: desktop-file-utils
@ -41,8 +39,13 @@ BuildRequires: pkgconfig(Qt5Svg)
BuildRequires: pkgconfig(Qt5Sql)
BuildRequires: pkgconfig(Qt5Xml)
BuildRequires: pkgconfig(Qt5X11Extras)
BuildRequires: pkgconfig(wayland-client)
BuildRequires: pkgconfig(KF5WaylandClient)
BuildRequires: cmake(PolkitQt5-1)
BuildRequires: cmake(Qt5WaylandClient)
BuildRequires: qt5-qtbase-private-devel
# for libQt5XkbCommonSupport.a
BuildRequires: qt5-qtbase-static
BuildRequires: pkgconfig(xcb-ewmh)
BuildRequires: pkgconfig(xext)
BuildRequires: kf5-networkmanager-qt-devel
@ -75,9 +78,8 @@ rm src/frame/window/icons/icons/dcc_nav_systeminfo_{42,84}px.svg
%patch0 -p1
%patch1 -p1
%patch2 -p1
sed -i -E '/add_compile_definitions/d' CMakeLists.txt
sed -i -E '/add_compile_definitions/d; 's:lib/:%{_lib}/: CMakeLists.txt
sed -i '/%{repo}/ s|/usr/lib|%{_libdir}|' src/frame/modules/update/updatework.cpp \
src/frame/window/mainwindow.cpp \
@ -86,14 +88,10 @@ sed -i '/%{repo}/ s|/usr/lib|%{_libdir}|' src/frame/modules/update/updatework.cp
sed -i '/TARGETS/s|lib|%{_lib}|' src/frame/CMakeLists.txt
# remove after -DDISABLE_SYS_UPDATE=YES working properly
# sync with Arch
# remove after they obey -DDISABLE_SYS_UPDATE properly
sed -i '/new UpdateModule/d' src/frame/window/mainwindow.cpp
# SystemInfo frame segfaults on Fedora
sed -i '/new SystemInfoModule/d' src/frame/window/mainwindow.cpp
sed -i '/#include <QPointer>/i #include <QDBusMetaType>' src/frame/window/modules/network/connectioneditpage.h
%build
export PATH=%{_qt5_bindir}:$PATH
%cmake -DDCC_DISABLE_GRUB=YES \
@ -116,12 +114,14 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/%{repo}.desktop
%{_bindir}/%{repo}
%{_libdir}/%{repo}
%{_libdir}/libdccwidgets.so
%{_libdir}/dde-grand-search-daemon/
%{_datadir}/applications/%{repo}.desktop
%{_datadir}/dbus-1/services/*.service
%{_datadir}/polkit-1/actions/com.deepin.*.policy
%{_datadir}/%{repo}/
%{_datadir}/dict/MainEnglishDictionary_ProbWL.txt
%{_datadir}/glib-2.0/schemas/*
%{_datadir}/dsg/
%files devel
%{_includedir}/%{repo}

View File

@ -1 +1 @@
SHA512 (dde-control-center-5.4.70.tar.gz) = 95e10dbc450ef20224d36634e27535f3175a6ea3b802ad8089e2352d3a0ef9b3e337cc5a6981afeb1e4a60ace1e3b9c838ada1a2fe7f39e6f12a23fa34e62271
SHA512 (dde-control-center-5.5.77.tar.gz) = f1be8efcb3ba3293612ebf191e424f6ac3e90c0d3708ba3079a25de794bdde2e8a49679ac0bfba6aab9e9208944ae4e525a7455e48017eacf997ad2f604bb41b