Add -bash-patsub-replacement patch to fix FTBFS.

This fixes the build with bash 5.2 (bz 2133760).
Add -toml patch and drop python3-toml BR.
This commit is contained in:
Jerry James 2022-10-11 14:54:00 -06:00
parent 11d315c19e
commit f7c24c6ad7
3 changed files with 71 additions and 2 deletions

View File

@ -0,0 +1,30 @@
--- src/expr/mkexpr.orig 2020-06-19 10:59:27.000000000 -0600
+++ src/expr/mkexpr 2022-10-11 14:28:31.120453409 -0600
@@ -16,6 +16,7 @@
#
copyright=2010-2014
+shopt -u patsub_replacement
filename=`basename "$1" | sed 's,_template,,'`
--- src/expr/mkkind.orig 2020-06-19 10:59:27.000000000 -0600
+++ src/expr/mkkind 2022-10-11 14:34:17.008996126 -0600
@@ -15,6 +15,7 @@
#
copyright=2010-2014
+shopt -u patsub_replacement
filename=`basename "$1" | sed 's,_template,,'`
--- src/expr/mkmetakind.orig 2020-06-19 10:59:27.000000000 -0600
+++ src/expr/mkmetakind 2022-10-11 14:34:32.248020036 -0600
@@ -18,6 +18,7 @@
#
copyright=2010-2014
+shopt -u patsub_replacement
cat <<EOF
/********************* */

32
cvc4-toml.patch Normal file
View File

@ -0,0 +1,32 @@
--- src/options/CMakeLists.txt.orig 2020-06-19 10:59:27.000000000 -0600
+++ src/options/CMakeLists.txt 2022-10-11 09:51:23.145795341 -0600
@@ -1,7 +1,7 @@
# Check if the toml Python module is installed.
execute_process(
COMMAND
- ${PYTHON_EXECUTABLE} -c "import toml"
+ ${PYTHON_EXECUTABLE} -c "import tomllib"
RESULT_VARIABLE
RET_TOML
ERROR_QUIET
--- src/options/mkoptions.py.orig 2020-06-19 10:59:27.000000000 -0600
+++ src/options/mkoptions.py 2022-10-11 09:54:27.753086129 -0600
@@ -46,7 +46,7 @@ import os
import re
import sys
import textwrap
-import toml
+import tomllib
### Allowed attributes for module/option/alias
@@ -1309,7 +1309,8 @@ def mkoptions_main():
# Parse files, check attributes and create module/option objects
modules = []
for filename in filenames:
- module = parse_module(filename, toml.load(filename))
+ with open(filename, "rb") as f:
+ module = parse_module(filename, tomllib.load(f))
# Check if long options are valid and unique. First populate
# g_long_cache with option.long and --no- alternatives if

View File

@ -3,7 +3,7 @@
Name: cvc4
Version: 1.8
Release: 12%{?dist}
Release: 13%{?dist}
Summary: Automatic theorem prover for SMT problems
%global jar_version %{version}.0
@ -27,6 +27,10 @@ Patch2: %{name}-dup-decl.patch
# speeds. But it has aged, and has less features than ld.bfd. Let's
# use ld.bfd so that package notes work without workarounds.
Patch3: %{name}-do-not-use-gold.diff
# Use tomllib instead of the deprecated toml package
Patch4: %{name}-toml.patch
# Turn off the bash patsub_replacement option, which breaks templating
Patch5: %{name}-bash-patsub-replacement.patch
# ANTLR 3 is not available on i686.
# See https://fedoraproject.org/wiki/Changes/Drop_i686_JDKs
@ -55,7 +59,6 @@ BuildRequires: perl-interpreter
BuildRequires: pkgconfig(readline)
BuildRequires: python3-devel
BuildRequires: %{py3_dist cython}
BuildRequires: %{py3_dist toml}
BuildRequires: swig
BuildRequires: symfpu-devel
@ -250,6 +253,10 @@ export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
%{python3_sitearch}/pycvc4*
%changelog
* Tue Oct 11 2022 Jerry James <loganjerry@gmail.com> - 1.8-13
- Add -bash-patsub-replacement patch to fix build with bash 5.2 (bz 2133760)
- Add -toml patch and drop python3-toml BR
* Mon Aug 15 2022 Jerry James <loganjerry@gmail.com> - 1.8-12
- Convert License tag to SPDX