fix infinite loop while loading a private key (#453612)

This commit is contained in:
Kamil Dudka 2009-05-11 08:31:22 +00:00
parent 4c03311ffd
commit fb4aeead7b
4 changed files with 39 additions and 25 deletions

15
curl-7.19.4-debug.patch Normal file
View File

@ -0,0 +1,15 @@
diff -ruNp curl-7.19.4.orig/configure.ac curl-7.19.4/configure.ac
--- curl-7.19.4.orig/configure.ac 2009-02-13 15:25:15.000000000 +0100
+++ curl-7.19.4/configure.ac 2009-04-22 11:56:32.171305420 +0200
@@ -241,7 +241,10 @@ dnl ************************************
CURL_CHECK_COMPILER
CURL_SET_COMPILER_BASIC_OPTS
-CURL_SET_COMPILER_DEBUG_OPTS
+
+dnl do not perturb CFLAGS given by the build system
+dnl CURL_SET_COMPILER_DEBUG_OPTS
+
CURL_SET_COMPILER_OPTIMIZE_OPTS
CURL_SET_COMPILER_WARNING_OPTS

View File

@ -1,22 +0,0 @@
diff -urNp curl-7.19.4.orig/configure curl-7.19.4/configure
--- curl-7.19.4.orig/configure 2009-04-21 10:59:47.000000000 +0530
+++ curl-7.19.4/configure 2009-04-21 11:19:13.000000000 +0530
@@ -16,6 +16,9 @@
## M4sh Initialization. ##
## --------------------- ##
+fedora_CPPFLAGS="$CPPFLAGS"
+fedora_CFLAGS="$CFLAGS"
+
# Be more Bourne compatible
DUALCASE=1; export DUALCASE # for MKS sh
if test -n "${ZSH_VERSION+set}" && (emulate sh) >/dev/null 2>&1; then
@@ -46881,6 +46884,8 @@ fi
+CFLAGS="$CFLAGS $fedora_CFLAGS"
+CPPFLAGS="$CPPFLAGS $fedora_CPPFLAGS"
squeeze CFLAGS
squeeze CPPFLAGS

12
curl-7.19.4-infloop.patch Normal file
View File

@ -0,0 +1,12 @@
diff -ruNp curl-7.19.4.orig/lib/nss.c curl-7.19.4/lib/nss.c
--- curl-7.19.4.orig/lib/nss.c 2009-05-11 10:21:19.136924000 +0200
+++ curl-7.19.4/lib/nss.c 2009-05-11 10:22:31.190315791 +0200
@@ -591,7 +591,7 @@ static char * nss_get_password(PK11SlotI
parg = (pphrase_arg_t *) arg;
(void)slot; /* unused */
- if(retry > 2)
+ if(retry)
return NULL;
if(parg->data->set.str[STRING_KEY_PASSWD])
return (char *)PORT_Strdup((char *)parg->data->set.str[STRING_KEY_PASSWD]);

View File

@ -1,7 +1,7 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 7.19.4
Release: 7%{?dist}
Release: 8%{?dist}
License: MIT
Group: Applications/Internet
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
@ -11,10 +11,12 @@ Patch3: curl-7.17.1-badsocket.patch
Patch4: curl-7.19.4-tool-leak.patch
Patch5: curl-7.19.4-enable-aes.patch
Patch6: curl-7.19.4-nss-leak.patch
Patch7: curl-7.19.4-flags.patch
Patch7: curl-7.19.4-debug.patch
Patch8: curl-7.19.4-infloop.patch
Provides: webclient
URL: http://curl.haxx.se/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: autoconf
BuildRequires: pkgconfig, libidn-devel, zlib-devel, libssh2-devel
BuildRequires: nss-devel >= 3.11.7-7, openldap-devel, krb5-devel
@ -56,7 +58,8 @@ use cURL's capabilities internally.
%patch4 -p1 -b .toolleak
%patch5 -p1 -b .enableaes
%patch6 -p1 -b .nssleak
%patch7 -p1 -b .flags
%patch7 -p1 -b .debug
%patch8 -p1 -b .infloop
# Convert docs to UTF-8
for f in CHANGES README; do
@ -65,6 +68,7 @@ for f in CHANGES README; do
done
%build
autoconf
export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
%configure --without-ssl --with-nss=%{_prefix} --enable-ipv6 \
--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
@ -148,6 +152,11 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/libcurl.m4
%changelog
* Mon May 11 2009 Kamil Dudka <kdudka@redhat.com> 7.19.4-8
- fix configure.ac to not discard -g in CFLAGS (#496778)
- fix infinite loop while loading a private key, thanks to Michael Cronenworth
(#453612)
* Tue Apr 21 2009 Debarshi Ray <rishi@fedoraproject.org> 7.19.4-7
- Fixed configure to respect the environment's CFLAGS and CPPFLAGS settings.