- update to curl 7.17.1
- include patch to enable SSL usage in NSS when a socket is opened nonblocking, thanks to Rob Crittenden (rcritten@redhat.com)
This commit is contained in:
parent
05cfb6ee48
commit
c9238ef4e7
@ -6,3 +6,4 @@ curl-7.16.2.tar.bz2
|
|||||||
curl-7.16.3.tar.bz2
|
curl-7.16.3.tar.bz2
|
||||||
curl-7.16.4.tar.bz2
|
curl-7.16.4.tar.bz2
|
||||||
curl-7.17.0.tar.bz2
|
curl-7.17.0.tar.bz2
|
||||||
|
curl-7.17.1.tar.bz2
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
--- curl-7.16.4/lib/ftp.c.ftp 2007-07-02 00:01:19.000000000 +0200
|
|
||||||
+++ curl-7.16.4/lib/ftp.c 2007-08-10 13:24:34.000000000 +0200
|
|
||||||
@@ -2372,7 +2372,7 @@ static CURLcode ftp_state_user_resp(stru
|
|
||||||
(void)instate; /* no use for this yet */
|
|
||||||
|
|
||||||
/* some need password anyway, and others just return 2xx ignored */
|
|
||||||
- if((ftpcode == 331 || ftpcode/100 == 2) && (ftpc->state == FTP_USER)) {
|
|
||||||
+ if((ftpcode == 331) && (ftpc->state == FTP_USER)) {
|
|
||||||
/* 331 Password required for ...
|
|
||||||
(the server requires to send the user's password too) */
|
|
||||||
NBFTPSENDF(conn, "PASS %s", ftp->passwd?ftp->passwd:"");
|
|
10
curl-7.17.1-sslgen.patch
Normal file
10
curl-7.17.1-sslgen.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- curl-7.17.1/lib/sslgen.c.orig 2007-11-16 22:48:48.000000000 -0500
|
||||||
|
+++ curl-7.17.1/lib/sslgen.c 2007-11-16 22:49:19.000000000 -0500
|
||||||
|
@@ -243,6 +243,7 @@
|
||||||
|
#else
|
||||||
|
#ifdef USE_NSS
|
||||||
|
*done = TRUE; /* fallback to BLOCKING */
|
||||||
|
+ conn->ssl[sockindex].use = TRUE;
|
||||||
|
return Curl_nss_connect(conn, sockindex);
|
||||||
|
#else
|
||||||
|
#ifdef USE_QSOSSL
|
21
curl.spec
21
curl.spec
@ -3,16 +3,15 @@
|
|||||||
|
|
||||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||||
Name: curl
|
Name: curl
|
||||||
Version: 7.16.4
|
Version: 7.17.1
|
||||||
Release: 10%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
|
||||||
Patch1: curl-7.15.3-multilib.patch
|
Patch1: curl-7.15.3-multilib.patch
|
||||||
Patch2: curl-7.16.0-privlibs.patch
|
Patch2: curl-7.16.0-privlibs.patch
|
||||||
Patch3: curl-7.16.4-ftp.patch
|
Patch3: curl-7.16.4-curl-config.patch
|
||||||
Patch4: curl-7.16.4-nsspem.patch
|
Patch4: curl-7.17.1-sslgen.patch
|
||||||
Patch5: curl-7.16.4-curl-config.patch
|
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
URL: http://curl.haxx.se/
|
URL: http://curl.haxx.se/
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -52,9 +51,8 @@ use cURL's capabilities internally.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .multilib
|
%patch1 -p1 -b .multilib
|
||||||
%patch2 -p1 -b .privlibs
|
%patch2 -p1 -b .privlibs
|
||||||
%patch3 -p1 -b .ftp
|
%patch3 -p1 -b .curl-config
|
||||||
%patch4 -p1 -b .nsspem
|
%patch4 -p1 -b .sslgen
|
||||||
%patch5 -p1 -b .curl-config
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if pkg-config nss ; then
|
if pkg-config nss ; then
|
||||||
@ -69,7 +67,7 @@ fi
|
|||||||
--disable-static
|
--disable-static
|
||||||
sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
|
sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \
|
||||||
Makefile libcurl.pc
|
Makefile libcurl.pc
|
||||||
make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
|
make CFLAGS="$RPM_OPT_FLAGS -DHAVE_PK11_CREATEGENERICOBJECT" %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
@ -116,6 +114,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/libcurl.m4
|
%{_datadir}/aclocal/libcurl.m4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 17 2007 Jindrich Novy <jnovy@redhat.com> 7.17.1-1
|
||||||
|
- update to curl 7.17.1
|
||||||
|
- include patch to enable SSL usage in NSS when a socket is opened
|
||||||
|
nonblocking, thanks to Rob Crittenden (rcritten@redhat.com)
|
||||||
|
|
||||||
* Wed Oct 24 2007 Jindrich Novy <jnovy@redhat.com> 7.16.4-10
|
* Wed Oct 24 2007 Jindrich Novy <jnovy@redhat.com> 7.16.4-10
|
||||||
- correctly provide/obsolete curl-devel (#130251)
|
- correctly provide/obsolete curl-devel (#130251)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user