new upstream release - 7.32.0
This commit is contained in:
parent
786f95d7bd
commit
c12a28f9b8
@ -1,26 +0,0 @@
|
||||
From 02964ed630c0fc74b47d0c94735d328661388d69 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Sat, 22 Jun 2013 22:12:49 +0200
|
||||
Subject: [PATCH] test1230: avoid using hard-wired port number
|
||||
|
||||
... to prevent failure when a non-default -b option is given
|
||||
---
|
||||
tests/data/test1230 | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/tests/data/test1230 b/tests/data/test1230
|
||||
index ab56b4f..a071850 100644
|
||||
--- a/tests/data/test1230
|
||||
+++ b/tests/data/test1230
|
||||
@@ -71,7 +71,7 @@ Host: [1234:1234:1234::4ce]:%HTTPPORT
|
||||
Proxy-Connection: Keep-Alive
|
||||
|
||||
GET /wanted/page/1230 HTTP/1.1
|
||||
-Host: [1234:1234:1234::4ce]:8990
|
||||
+Host: [1234:1234:1234::4ce]:%HTTPPORT
|
||||
Accept: */*
|
||||
|
||||
</protocol>
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,37 +0,0 @@
|
||||
From 8d1d6c18015de5db2b2a1f499b6d341f86505810 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Sun, 30 Jun 2013 19:51:16 +0200
|
||||
Subject: [PATCH] url: restore the functionality of 'curl -u :'
|
||||
|
||||
This commit fixes a regression introduced in
|
||||
fddb7b44a79d78e05043e1c97e069308b6b85f79.
|
||||
|
||||
Reported by: Markus Moeller
|
||||
Bug: http://curl.haxx.se/mail/archive-2013-06/0052.html
|
||||
|
||||
[upstream commit abca89aaa0fb208cfaf4ead6692014c4e553388a]
|
||||
---
|
||||
lib/url.c | 7 +++++++
|
||||
1 files changed, 7 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/lib/url.c b/lib/url.c
|
||||
index 7ba4969..4231d37 100644
|
||||
--- a/lib/url.c
|
||||
+++ b/lib/url.c
|
||||
@@ -317,6 +317,13 @@ static CURLcode setstropt_userpwd(char *option, char **userp, char **passwdp,
|
||||
if(!result) {
|
||||
/* Store the username part of option if required */
|
||||
if(userp) {
|
||||
+ if(!user && option && option[0] == ':') {
|
||||
+ /* Allocate an empty string instead of returning NULL as user name */
|
||||
+ user = strdup("");
|
||||
+ if(!user)
|
||||
+ result = CURLE_OUT_OF_MEMORY;
|
||||
+ }
|
||||
+
|
||||
Curl_safefree(*userp);
|
||||
*userp = user;
|
||||
}
|
||||
--
|
||||
1.7.1
|
||||
|
@ -1,129 +0,0 @@
|
||||
From dff4fdaf76ed8ad9d11991e3ad4106a162e8a371 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 9 Jul 2013 14:59:01 +0200
|
||||
Subject: [PATCH 1/4] curl.1: document the --time-cond option in the man page
|
||||
|
||||
[upstream commit 3a0e931fc715a80004958794a96b12cf90503f99]
|
||||
---
|
||||
docs/curl.1 | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/docs/curl.1 b/docs/curl.1
|
||||
index 3da4354..a130740 100644
|
||||
--- a/docs/curl.1
|
||||
+++ b/docs/curl.1
|
||||
@@ -1413,6 +1413,9 @@ default 512 bytes will be used.
|
||||
If this option is used several times, the last one will be used.
|
||||
|
||||
(Added in 7.20.0)
|
||||
+.IP " -z, --time-cond TIME"
|
||||
+Transfer based on a time condition. TIME may to be preceded by -, +, or =.
|
||||
+See the corresponding sections 14.24, 14.28, and 14.29 of RFC 2068.
|
||||
.IP "--tlsauthtype <authtype>"
|
||||
Set TLS authentication type. Currently, the only supported option is "SRP",
|
||||
for TLS-SRP (RFC 5054). If \fI--tlsuser\fP and \fI--tlspassword\fP are
|
||||
--
|
||||
1.7.1
|
||||
|
||||
|
||||
From c3536d01f24f8e1fe886f4f74301e4fc7f7c26ae Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 9 Jul 2013 14:59:01 +0200
|
||||
Subject: [PATCH 2/4] curl.1: document the --post303 option in the man page
|
||||
|
||||
[upstream commit 39e85d99feede7cc573902e8ab6b3dd759022d9c]
|
||||
---
|
||||
docs/curl.1 | 7 +++++++
|
||||
1 files changed, 7 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/docs/curl.1 b/docs/curl.1
|
||||
index a130740..f944092 100644
|
||||
--- a/docs/curl.1
|
||||
+++ b/docs/curl.1
|
||||
@@ -1043,6 +1043,13 @@ ubiquitous in web browsers, so curl does the conversion by default to maintain
|
||||
consistency. However, a server may require a POST to remain a POST after such
|
||||
a redirection. This option is meaningful only when using \fI-L, --location\fP
|
||||
(Added in 7.19.1)
|
||||
+.IP "--post303"
|
||||
+(HTTP) Tells curl to respect RFC 2616/10.3.2 and not convert POST requests
|
||||
+into GET requests when following a 303 redirection. The non-RFC behaviour is
|
||||
+ubiquitous in web browsers, so curl does the conversion by default to maintain
|
||||
+consistency. However, a server may require a POST to remain a POST after such
|
||||
+a redirection. This option is meaningful only when using \fI-L, --location\fP
|
||||
+(Added in 7.26.0)
|
||||
.IP "--proto <protocols>"
|
||||
Tells curl to use the listed protocols for its initial retrieval. Protocols
|
||||
are evaluated left to right, are comma separated, and are each a protocol
|
||||
--
|
||||
1.7.1
|
||||
|
||||
|
||||
From c7e06409c9d02cedd74a0881aee55c4c95ed7efa Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 9 Jul 2013 14:59:01 +0200
|
||||
Subject: [PATCH 3/4] curl.1: document the --sasl-ir option in the man page
|
||||
|
||||
[upstream commit 20ff820ef2d59fb68d50665ab64fb9d6da323751]
|
||||
---
|
||||
docs/curl.1 | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/docs/curl.1 b/docs/curl.1
|
||||
index f944092..20f87f1 100644
|
||||
--- a/docs/curl.1
|
||||
+++ b/docs/curl.1
|
||||
@@ -1287,6 +1287,9 @@ If this option is used several times, the last one will be used.
|
||||
Silent or quiet mode. Don't show progress meter or error messages. Makes Curl
|
||||
mute. It will still output the data you ask for, potentially even to the
|
||||
terminal/stdout unless you redirect it.
|
||||
+.IP "--sasl-ir"
|
||||
+Enable initial response in SASL authentication.
|
||||
+(Added in 7.31.0)
|
||||
.IP "-S, --show-error"
|
||||
When used with \fI-s\fP it makes curl show an error message if it fails.
|
||||
.IP "--ssl"
|
||||
--
|
||||
1.7.1
|
||||
|
||||
|
||||
From 42b23be7ac8601b07bbd2d6a4736fefa9fa8fd6c Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 9 Jul 2013 15:45:36 +0200
|
||||
Subject: [PATCH 4/4] Revert "curl.1: document the --time-cond option in the man page"
|
||||
|
||||
This reverts commit 3a0e931fc715a80004958794a96b12cf90503f99 because
|
||||
the documentation of --time-cond was duplicated by mistake.
|
||||
|
||||
Reported by: Dave Reisner
|
||||
|
||||
[upstream commit 45339625bc85b29225a2035a57eceda43206dd1e]
|
||||
---
|
||||
docs/curl.1 | 5 +----
|
||||
1 files changed, 1 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/docs/curl.1 b/docs/curl.1
|
||||
index 20f87f1..6d71152 100644
|
||||
--- a/docs/curl.1
|
||||
+++ b/docs/curl.1
|
||||
@@ -1423,9 +1423,6 @@ default 512 bytes will be used.
|
||||
If this option is used several times, the last one will be used.
|
||||
|
||||
(Added in 7.20.0)
|
||||
-.IP " -z, --time-cond TIME"
|
||||
-Transfer based on a time condition. TIME may to be preceded by -, +, or =.
|
||||
-See the corresponding sections 14.24, 14.28, and 14.29 of RFC 2068.
|
||||
.IP "--tlsauthtype <authtype>"
|
||||
Set TLS authentication type. Currently, the only supported option is "SRP",
|
||||
for TLS-SRP (RFC 5054). If \fI--tlsuser\fP and \fI--tlspassword\fP are
|
||||
@@ -1708,7 +1705,7 @@ speed-time seconds it gets aborted. speed-time is set with \fI-y\fP and is 30
|
||||
if not set.
|
||||
|
||||
If this option is used several times, the last one will be used.
|
||||
-.IP "-z/--time-cond <date expression>|<file>"
|
||||
+.IP "-z, --time-cond <date expression>|<file>"
|
||||
(HTTP/FTP) Request a file that has been modified later than the given time and
|
||||
date, or one that has been modified before that time. The <date expression>
|
||||
can be all sorts of date strings or if it doesn't match any internal ones, it
|
||||
--
|
||||
1.7.1
|
||||
|
@ -40,12 +40,12 @@ index 150004d..95d0759 100644
|
||||
;;
|
||||
|
||||
--static-libs)
|
||||
- if test "X@ENABLE_STATIC@" != "Xno" ; then
|
||||
- echo @libdir@/libcurl.@libext@ @LDFLAGS@ @LIBCURL_LIBS@
|
||||
- else
|
||||
- echo "curl was built with static libraries disabled" >&2
|
||||
- exit 1
|
||||
- fi
|
||||
- if test "X@ENABLE_STATIC@" != "Xno" ; then
|
||||
- echo @libdir@/libcurl.@libext@ @LDFLAGS@ @LIBCURL_LIBS@
|
||||
- else
|
||||
- echo "curl was built with static libraries disabled" >&2
|
||||
- exit 1
|
||||
- fi
|
||||
;;
|
||||
|
||||
--configure)
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index 8f079a3..53b4774 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -16020,18 +16020,11 @@ $as_echo "yes" >&6; }
|
||||
@@ -16030,18 +16030,11 @@ $as_echo "yes" >&6; }
|
||||
gccvhi=`echo $gccver | cut -d . -f1`
|
||||
gccvlo=`echo $gccver | cut -d . -f2`
|
||||
compiler_num=`(expr $gccvhi "*" 100 + $gccvlo) 2>/dev/null`
|
@ -12,7 +12,7 @@ diff --git a/configure b/configure
|
||||
index a466175..cb63075 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -15485,13 +15485,9 @@ fi
|
||||
@@ -15495,13 +15495,9 @@ fi
|
||||
|
||||
|
||||
|
@ -6,23 +6,9 @@ Subject: [PATCH] Fix character encoding of docs
|
||||
..., which are of mixed encoding originally so a simple iconv can't
|
||||
fix them.
|
||||
---
|
||||
CHANGES | 2 +-
|
||||
README | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
README | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/CHANGES b/CHANGES
|
||||
index 4568408..5fc1652 100644
|
||||
--- a/CHANGES
|
||||
+++ b/CHANGES
|
||||
@@ -5325,7 +5325,7 @@ Daniel Stenberg (12 Nov 2012)
|
||||
|
||||
- [Gabriel Sjoberg brought this change]
|
||||
|
||||
- Digst: Add microseconds into nounce calculation
|
||||
+ Digest: Add microseconds into nounce calculation
|
||||
|
||||
When using only 1 second precision, curl doesn't create new cnonce
|
||||
values quickly enough for all uses.
|
||||
diff --git a/README b/README
|
||||
index 2ffacc3..cfd6760 100644
|
||||
--- a/README
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.12 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlHFb/oACgkQeOEcayedXJFVRACfZw0PkPESVwBmLofyVsmzvawi
|
||||
hDoAniqfcgXqIiLt8KPz0MkA6uXcol5E
|
||||
=gOQA
|
||||
-----END PGP SIGNATURE-----
|
7
curl-7.32.0.tar.lzma.asc
Normal file
7
curl-7.32.0.tar.lzma.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.14 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlIIDT4ACgkQeOEcayedXJFOBwCfSGwELnEOcuFSS7Witjk2EFwM
|
||||
gdcAoPi/rwCi3U6B73B5p+/jR360V2e6
|
||||
=VRTg
|
||||
-----END PGP SIGNATURE-----
|
29
curl.spec
29
curl.spec
@ -1,29 +1,20 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.31.0
|
||||
Release: 5%{?dist}
|
||||
Version: 7.32.0
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
Source2: curlbuild.h
|
||||
|
||||
# test1230: avoid using hard-wired port number
|
||||
Patch1: 0001-curl-7.31.0-02964ed6.patch
|
||||
|
||||
# restore the functionality of 'curl -u :'
|
||||
Patch2: 0002-curl-7.31.0-abca89aa.patch
|
||||
|
||||
# mention all option listed in 'curl --help' in curl.1 man page
|
||||
Patch3: 0003-curl-7.31.0-3a0e931f.patch
|
||||
|
||||
# patch making libcurl multilib ready
|
||||
Patch101: 0101-curl-7.31.0-multilib.patch
|
||||
Patch101: 0101-curl-7.32.0-multilib.patch
|
||||
|
||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||
Patch102: 0102-curl-7.31.0-debug.patch
|
||||
Patch102: 0102-curl-7.32.0-debug.patch
|
||||
|
||||
# make the curl tool link SSL libraries also used by src/tool_metalink.c
|
||||
Patch103: 0103-curl-7.31.0-metalink.patch
|
||||
Patch103: 0103-curl-7.32.0-metalink.patch
|
||||
|
||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||
@ -36,7 +27,7 @@ Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
||||
|
||||
# Fix character encoding of docs, which are of mixed encoding originally so
|
||||
# a simple iconv can't fix them
|
||||
Patch108: 0108-curl-7.31.0-utf8.patch
|
||||
Patch108: 0108-curl-7.32.0-utf8.patch
|
||||
|
||||
Provides: webclient
|
||||
URL: http://curl.haxx.se/
|
||||
@ -113,9 +104,6 @@ documentation of the library, too.
|
||||
%setup -q
|
||||
|
||||
# upstream patches
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
@ -237,13 +225,16 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Mon Aug 12 2013 Kamil Dudka <kdudka@redhat.com> 7.32.0-1
|
||||
- new upstream release
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 7.31.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Jul 09 2013 Kamil Dudka <kdudka@redaht.com> 7.31.0-4
|
||||
- mention all option listed in 'curl --help' in curl.1 man page
|
||||
|
||||
* Tue Jul 01 2013 Kamil Dudka <kdudka@redhat.com> 7.31.0-3
|
||||
* Tue Jul 02 2013 Kamil Dudka <kdudka@redhat.com> 7.31.0-3
|
||||
- restore the functionality of 'curl -u :'
|
||||
|
||||
* Wed Jun 26 2013 Kamil Dudka <kdudka@redhat.com> 7.31.0-2
|
||||
|
Loading…
Reference in New Issue
Block a user