fix configure.ac to not discard -g in CFLAGS (#496778)

This commit is contained in:
Kamil Dudka 2009-04-27 07:29:34 +00:00
parent c66a47c84c
commit b624f210b5
2 changed files with 23 additions and 1 deletions

15
curl-7.19.4-debug.patch Normal file
View File

@ -0,0 +1,15 @@
diff -ruNp curl-7.19.4.orig/configure.ac curl-7.19.4/configure.ac
--- curl-7.19.4.orig/configure.ac 2009-02-13 15:25:15.000000000 +0100
+++ curl-7.19.4/configure.ac 2009-04-22 11:56:32.171305420 +0200
@@ -241,7 +241,10 @@ dnl ************************************
CURL_CHECK_COMPILER
CURL_SET_COMPILER_BASIC_OPTS
-CURL_SET_COMPILER_DEBUG_OPTS
+
+dnl do not perturb CFLAGS given by the build system
+dnl CURL_SET_COMPILER_DEBUG_OPTS
+
CURL_SET_COMPILER_OPTIMIZE_OPTS
CURL_SET_COMPILER_WARNING_OPTS

View File

@ -1,16 +1,18 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 7.19.4
Release: 3%{?dist}
Release: 4%{?dist}
License: MIT
Group: Applications/Internet
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
Patch1: curl-7.15.3-multilib.patch
Patch2: curl-7.16.0-privlibs.patch
Patch3: curl-7.17.1-badsocket.patch
Patch4: curl-7.19.4-debug.patch
Provides: webclient
URL: http://curl.haxx.se/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: autoconf
BuildRequires: pkgconfig, libidn-devel, zlib-devel, libssh2-devel
BuildRequires: nss-devel >= 3.11.7-7, openldap-devel, krb5-devel
@ -49,6 +51,7 @@ use cURL's capabilities internally.
%patch1 -p1 -b .multilib
%patch2 -p1 -b .privlibs
%patch3 -p1 -b .badsocket
%patch4 -p1 -b .debug
# Convert docs to UTF-8
for f in CHANGES README; do
@ -57,6 +60,7 @@ for f in CHANGES README; do
done
%build
autoconf
export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT"
%configure --without-ssl --with-nss=%{_prefix} --enable-ipv6 \
--with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
@ -140,6 +144,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/libcurl.m4
%changelog
* Mon Apr 27 2009 Kamil Dudka <kdudka@redhat.com> 7.19.4-4
- fix configure.ac to not discard -g in CFLAGS, thanks to Debarshi Ray (#496778)
* Mon Mar 16 2009 Kamil Dudka <kdudka@redhat.com> 7.19.4-3
- make libcurl-devel multilib-ready (bug #488922)