new upstream release - 7.69.1

This commit is contained in:
Kamil Dudka 2020-03-11 10:21:27 +01:00
parent fbcad9a3a0
commit ac5c236f18
6 changed files with 18 additions and 77 deletions

View File

@ -1,58 +0,0 @@
From 2c706c44b98998fa619ddc63b2c14955b0f50692 Mon Sep 17 00:00:00 2001
From: Daniel Stenberg <daniel@haxx.se>
Date: Thu, 5 Mar 2020 23:45:36 +0100
Subject: [PATCH] Revert "pause: force-drain the transfer on unpause"
This reverts commit fa0216b294af4c7113a9040ca65eefc7fc18ac1c (from #5000)
Clearly that didn't solve the problem correctly.
Reported-by: Christopher Reid
Reopens #4966
Fixes #5044
Upstream-commit: 8aa04e9a24932b830bc5eaf6838dea5a3329341e
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
---
lib/easy.c | 1 -
lib/transfer.c | 5 ++---
2 files changed, 2 insertions(+), 4 deletions(-)
diff --git a/lib/easy.c b/lib/easy.c
index 1a69127..4546210 100644
--- a/lib/easy.c
+++ b/lib/easy.c
@@ -1033,7 +1033,6 @@ CURLcode curl_easy_pause(struct Curl_easy *data, int action)
to have this handle checked soon */
if((newstate & (KEEP_RECV_PAUSE|KEEP_SEND_PAUSE)) !=
(KEEP_RECV_PAUSE|KEEP_SEND_PAUSE)) {
- data->state.drain++;
Curl_expire(data, 0, EXPIRE_RUN_NOW); /* get this handle going again */
if(data->multi)
Curl_update_timer(data->multi);
diff --git a/lib/transfer.c b/lib/transfer.c
index 8270761..ead8b36 100644
--- a/lib/transfer.c
+++ b/lib/transfer.c
@@ -5,7 +5,7 @@
* | (__| |_| | _ <| |___
* \___|\___/|_| \_\_____|
*
- * Copyright (C) 1998 - 2020, Daniel Stenberg, <daniel@haxx.se>, et al.
+ * Copyright (C) 1998 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
*
* This software is licensed as described in the file COPYING, which
* you should have received as part of this distribution. The terms
@@ -1217,8 +1217,7 @@ CURLcode Curl_readwrite(struct connectdata *conn,
else
fd_write = CURL_SOCKET_BAD;
- if(data->state.drain) {
- data->state.drain--;
+ if(conn->data->state.drain) {
select_res |= CURL_CSELECT_IN;
DEBUGF(infof(data, "Curl_readwrite: forcibly told to drain data\n"));
}
--
2.21.1

View File

@ -26,7 +26,7 @@ diff --git a/tests/libtest/Makefile.inc b/tests/libtest/Makefile.inc
index 080421b..ea3b806 100644
--- a/tests/libtest/Makefile.inc
+++ b/tests/libtest/Makefile.inc
@@ -534,6 +534,7 @@ lib1559_SOURCES = lib1559.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
@@ -562,6 +562,7 @@ lib1559_SOURCES = lib1559.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)
lib1559_LDADD = $(TESTUTIL_LIBS)
lib1560_SOURCES = lib1560.c $(SUPPORTFILES) $(TESTUTIL) $(WARNLESS)

View File

@ -1,11 +0,0 @@
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAl5fTaIACgkQXMkI/bce
EsIyaAf8DEjmWf+UpZDBjyirl6PuNfxpgZGm8Qw5eWBKD1rdQuMjZ3xJLauAR34G
fYvsj8cYotUaIPHw4jWcvn6m/M5KFII6XWANcasn7edbg47BcXS6xadNkUnqcJnF
0U9YbghGXaj0CwaNjqP4Gv23oG2nuYyWhUzI4wD8cRcO3oE/5Wksfwhwq5DrnpuQ
CLlgP8o9qMgfrds87WK4Gb+AFHW4jkCAT2wnJBvtEfK97pG1E9y7S8l5oZ7H8hTe
Vm3UgM8Stk13yPCCN3nOaTdPKk5nA6co7VWW5TbjJPQ+6mT+eD6SY/+k5yJ+A11X
zaXOa3fXEJiRX3nfAR47iThh2Pj8wA==
=baDZ
-----END PGP SIGNATURE-----

11
curl-7.69.1.tar.xz.asc Normal file
View File

@ -0,0 +1,11 @@
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEJ+3q8i86vOtQ25oSXMkI/bceEsIFAl5oh44ACgkQXMkI/bce
EsL/5QgAlK2oYZTG3OQziHD8RtvjcRZyVfSPgH+UCEe12o+pqrWncWG5kVbFPjoX
USq8EEmRLaTdPPVY+lLZjrll0LgAHa5fyOYV5IFeKHHlRtGUsurMx+IW7NXg1kWn
lZXV/xzcogVeaqTZtJS1QQeyBxV55BEzwbO7WI7U3dQHKspE2724IqaGwHAj7BaL
K3hmHpBHuuGNpP5wsmnA0GXVLYSfqTJhc2itcupG8ZveNeEjCXPoRxGq/aewqUCH
UoT0tLu/LJ/D4FW1zGYdQXkli4MHKzTP9l2Tp/6ounEc+WpEirIRJLWRE8Wn/bmH
JjmSkls5sMCsmLl5DNoSUEw4Jco0oQ==
=+Rw4
-----END PGP SIGNATURE-----

View File

@ -1,13 +1,10 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 7.69.0
Release: 2%{?dist}
Version: 7.69.1
Release: 1%{?dist}
License: MIT
Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
# make Flatpak work again (#1810989)
Patch1: 0001-curl-7.69.0-flatpak.patch
# patch making libcurl multilib ready
Patch101: 0101-curl-7.32.0-multilib.patch
@ -174,7 +171,6 @@ be installed.
%setup -q
# upstream patches
%patch1 -p1
# Fedora patches
%patch101 -p1
@ -350,6 +346,9 @@ rm -f ${RPM_BUILD_ROOT}%{_libdir}/libcurl.la
%{_libdir}/libcurl.so.4.[0-9].[0-9].minimal
%changelog
* Wed Mar 11 2020 Kamil Dudka <kdudka@redhat.com> - 7.69.1-1
- new upstream release
* Mon Mar 09 2020 Kamil Dudka <kdudka@redhat.com> - 7.69.0-2
- make Flatpak work again (#1810989)

View File

@ -1 +1 @@
SHA512 (curl-7.69.0.tar.xz) = 8c151201b09c51cc1437c2f6345036fce88ea5402cd1fd62b76c093e294b87d0c1f61e1dcf6f799f508d8dcfe381589a3815001a8c8bbc085aed0fdca6f2536d
SHA512 (curl-7.69.1.tar.xz) = dcb917ce9a6f34b30adae10e2e635d7a8c67781d69789cc5617ab2b49e898394ecfeee546453b14ab168d4b3b52baf974b2ec07e7a4b199addbc1ba57274d8fa