- fix incorrect SSL recv/send timeout handling
This commit is contained in:
parent
4be898643b
commit
6cf469621f
26
curl-7.19.7-ssl-timeout.patch
Normal file
26
curl-7.19.7-ssl-timeout.patch
Normal file
@ -0,0 +1,26 @@
|
||||
diff --git a/lib/nss.c b/lib/nss.c
|
||||
index 51e62ee..c7c7e5f 100644
|
||||
--- a/lib/nss.c
|
||||
+++ b/lib/nss.c
|
||||
@@ -1353,8 +1353,8 @@ int Curl_nss_send(struct connectdata *conn, /* connection data */
|
||||
err = PR_GetError();
|
||||
|
||||
if(err == PR_IO_TIMEOUT_ERROR) {
|
||||
- failf(data, "SSL connection timeout");
|
||||
- return CURLE_OPERATION_TIMEDOUT;
|
||||
+ failf(data, "SSL connection send timeout");
|
||||
+ return -1;
|
||||
}
|
||||
|
||||
failf(conn->data, "SSL write: error %d", err);
|
||||
@@ -1394,8 +1394,8 @@ ssize_t Curl_nss_recv(struct connectdata * conn, /* connection data */
|
||||
return -1; /* basically EWOULDBLOCK */
|
||||
}
|
||||
if(err == PR_IO_TIMEOUT_ERROR) {
|
||||
- failf(data, "SSL connection timeout");
|
||||
- return CURLE_OPERATION_TIMEDOUT;
|
||||
+ failf(data, "SSL connection receive timeout");
|
||||
+ return -1;
|
||||
}
|
||||
failf(conn->data, "SSL read: errno %d", err);
|
||||
return -1;
|
11
curl.spec
11
curl.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.19.7
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
@ -9,6 +9,7 @@ Source2: curlbuild.h
|
||||
Patch1: curl-7.19.7-modelfree.patch
|
||||
Patch2: curl-7.19.7-ssl-retry.patch
|
||||
Patch3: curl-7.19.7-nss-warning.patch
|
||||
Patch4: curl-7.19.7-ssl-timeout.patch
|
||||
Patch101: curl-7.15.3-multilib.patch
|
||||
Patch102: curl-7.16.0-privlibs.patch
|
||||
Patch103: curl-7.19.4-debug.patch
|
||||
@ -82,6 +83,9 @@ use cURL's capabilities internally.
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
# other patches
|
||||
%patch4 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
@ -183,6 +187,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Wed Dec 30 2009 Kamil Dudka <kdudka@redhat.com> 7.19.7-6
|
||||
- fix incorrect SSL recv/send timeout handling, patch contributed
|
||||
by Kevin Baughman
|
||||
- http://permalink.gmane.org/gmane.comp.web.curl.library/26302
|
||||
|
||||
* Wed Dec 09 2009 Kamil Dudka <kdudka@redhat.com> 7.19.7-5
|
||||
- use different port numbers for 32bit and 64bit builds
|
||||
- replace hard wired port numbers in the test suite
|
||||
|
Loading…
Reference in New Issue
Block a user