do not limit the speed of SCP upload on a fast connection
This commit is contained in:
parent
d26889345a
commit
4ae7271a09
42
0105-curl-7.32.0-scp-upload.patch
Normal file
42
0105-curl-7.32.0-scp-upload.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From 2e973be50f75d0a85dcb995f7823f00b1fc85c2f Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Mon, 7 Oct 2013 16:07:50 +0200
|
||||
Subject: [PATCH] ssh: improve the logic for detecting blocking direction
|
||||
|
||||
This fixes a regression introduced by commit 0feeab78 limiting the speed
|
||||
of SCP upload to 16384 B/s on a fast connection (such as localhost).
|
||||
|
||||
http://thread.gmane.org/gmane.comp.web.curl.library/40551/focus=40561
|
||||
---
|
||||
lib/ssh.c | 8 +++++---
|
||||
1 files changed, 5 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/lib/ssh.c b/lib/ssh.c
|
||||
index 422357b..93c65c3 100644
|
||||
--- a/lib/ssh.c
|
||||
+++ b/lib/ssh.c
|
||||
@@ -2287,6 +2287,10 @@ static CURLcode ssh_statemach_act(struct connectdata *conn, bool *block)
|
||||
sshc->actualcode = result;
|
||||
}
|
||||
else {
|
||||
+ /* store this original bitmask setup to use later on if we can't
|
||||
+ figure out a "real" bitmask */
|
||||
+ sshc->orig_waitfor = data->req.keepon;
|
||||
+
|
||||
/* we want to use the _sending_ function even when the socket turns
|
||||
out readable as the underlying libssh2 scp send function will deal
|
||||
with both accordingly */
|
||||
@@ -2603,9 +2607,7 @@ static void ssh_block2waitfor(struct connectdata *conn, bool block)
|
||||
{
|
||||
struct ssh_conn *sshc = &conn->proto.sshc;
|
||||
int dir;
|
||||
- if(!block)
|
||||
- conn->waitfor = 0;
|
||||
- else if((dir = libssh2_session_block_directions(sshc->ssh_session))) {
|
||||
+ if(block && (dir = libssh2_session_block_directions(sshc->ssh_session))) {
|
||||
/* translate the libssh2 define bits into our own bit defines */
|
||||
conn->waitfor = ((dir&LIBSSH2_SESSION_BLOCK_INBOUND)?KEEP_RECV:0) |
|
||||
((dir&LIBSSH2_SESSION_BLOCK_OUTBOUND)?KEEP_SEND:0);
|
||||
--
|
||||
1.7.1
|
||||
|
11
curl.spec
11
curl.spec
@ -1,7 +1,7 @@
|
||||
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
|
||||
Name: curl
|
||||
Version: 7.32.0
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: MIT
|
||||
Group: Applications/Internet
|
||||
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
|
||||
@ -28,6 +28,9 @@ Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||
# disable valgrind for certain test-cases (libssh2 problem)
|
||||
Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
|
||||
|
||||
# http://thread.gmane.org/gmane.comp.web.curl.library/40551/focus=40561
|
||||
Patch105: 0105-curl-7.32.0-scp-upload.patch
|
||||
|
||||
# work around valgrind bug (#678518)
|
||||
Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
|
||||
|
||||
@ -113,6 +116,9 @@ documentation of the library, too.
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
# patches not yet upstream
|
||||
%patch105 -p1
|
||||
|
||||
# Fedora patches
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
@ -230,6 +236,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/aclocal/libcurl.m4
|
||||
|
||||
%changelog
|
||||
* Fri Oct 11 2013 Kamil Dudka <kdudka@redhat.com> 7.32.0-3
|
||||
- do not limit the speed of SCP upload on a fast connection
|
||||
|
||||
* Mon Sep 09 2013 Kamil Dudka <kdudka@redhat.com> 7.32.0-2
|
||||
- avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user