- update to curl 7.18.1 (fixes #397911)

- add ABI docs for libcurl
- remove --static-libs from curl-config
- drop curl-config patch, obsoleted by @SSL_ENABLED@ autoconf substitution
    (#432667)
This commit is contained in:
Jindrich Novy 2008-03-31 07:47:59 +00:00
parent 6684d1ac14
commit 43a8fac1dd
5 changed files with 32 additions and 55 deletions

View File

@ -1 +1 @@
curl-7.18.0.tar.bz2 curl-7.18.1.tar.bz2

View File

@ -1,7 +1,15 @@
diff -up curl-7.18.0/curl-config.in.multilib curl-7.18.0/curl-config.in diff -up curl-7.18.0/curl-config.in.multilib curl-7.18.0/curl-config.in
--- curl-7.18.0/curl-config.in.multilib 2008-01-10 23:14:02.000000000 +0100 --- curl-7.18.0/curl-config.in.multilib 2008-01-10 23:14:02.000000000 +0100
+++ curl-7.18.0/curl-config.in 2008-01-28 21:37:50.000000000 +0100 +++ curl-7.18.0/curl-config.in 2008-02-16 06:48:14.000000000 +0100
@@ -72,7 +72,7 @@ @@ -45,7 +45,6 @@
--libs library linking information
--prefix curl install prefix
--protocols newline separated list of enabled protocols
- --static-libs static libcurl library linking information
--version output version information
--vernum output the version information as a number (hexadecimal)
EOF
@@ -72,7 +71,7 @@
;; ;;
--cc) --cc)
@ -10,7 +18,7 @@ diff -up curl-7.18.0/curl-config.in.multilib curl-7.18.0/curl-config.in
;; ;;
--prefix) --prefix)
@@ -189,16 +189,7 @@ @@ -189,20 +188,7 @@
;; ;;
--libs) --libs)
@ -24,7 +32,11 @@ diff -up curl-7.18.0/curl-config.in.multilib curl-7.18.0/curl-config.in
- else - else
- echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@ - echo ${CURLLIBDIR}-lcurl @LDFLAGS@ @LIBS@
- fi - fi
- ;;
-
- --static-libs)
- echo @libdir@/libcurl.@libext@ @LDFLAGS@ @LIBCURL_LIBS@ @LIBS@
+ pkg-config libcurl --libs + pkg-config libcurl --libs
;; ;;
--static-libs) *)

View File

@ -1,40 +0,0 @@
diff -up curl-7.18.0/curl-config.in.curl-config curl-7.18.0/curl-config.in
--- curl-7.18.0/curl-config.in.curl-config 2008-01-28 21:39:08.000000000 +0100
+++ curl-7.18.0/curl-config.in 2008-01-28 21:46:36.000000000 +0100
@@ -57,6 +57,8 @@
usage 1
fi
+USE_SSL="@USE_SSLEAY@@USE_GNUTLS@@USE_NSS@"
+
while test $# -gt 0; do
case "$1" in
# this deals with options in the style
@@ -81,9 +83,9 @@
--feature|--features)
if test "@USE_SSLEAY@" = "1"; then
- echo "SSL"
NTLM=1 # OpenSSL implies NTLM
- elif test -n "@SSL_ENABLED@"; then
+ fi
+ if test -n "$USE_SSL"; then
echo "SSL"
fi
if test "@KRB4_ENABLED@" = "1"; then
@@ -113,13 +115,13 @@
--protocols)
if test "@CURL_DISABLE_HTTP@" != "1"; then
echo "HTTP"
- if test "@SSL_ENABLED@" = "1"; then
+ if test "$USE_SSL" = "1"; then
echo "HTTPS"
fi
fi
if test "@CURL_DISABLE_FTP@" != "1"; then
echo "FTP"
- if test "@SSL_ENABLED@" = "1"; then
+ if test "$USE_SSL" = "1"; then
echo "FTPS"
fi
fi

View File

@ -1,21 +1,20 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others) Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl Name: curl
Version: 7.18.0 Version: 7.18.0
Release: 2%{?dist} Release: 1%{?dist}
License: MIT License: MIT
Group: Applications/Internet Group: Applications/Internet
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2 Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
Patch1: curl-7.15.3-multilib.patch Patch1: curl-7.15.3-multilib.patch
Patch2: curl-7.16.0-privlibs.patch Patch2: curl-7.16.0-privlibs.patch
Patch3: curl-7.16.4-curl-config.patch Patch3: curl-7.17.1-badsocket.patch
Patch4: curl-7.17.1-badsocket.patch
Provides: webclient Provides: webclient
URL: http://curl.haxx.se/ URL: http://curl.haxx.se/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libtool, pkgconfig, libidn-devel, zlib-devel BuildRequires: libtool, pkgconfig, libidn-devel, zlib-devel
BuildRequires: nss-devel >= 3.11.7-7, openldap-devel, krb5-devel BuildRequires: nss-devel >= 3.11.7-7, openldap-devel, krb5-devel
%description %description
cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS, cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,
DICT, TELNET and TFTP servers, using any of the supported protocols. DICT, TELNET and TFTP servers, using any of the supported protocols.
cURL is designed to work without user interaction or any kind of cURL is designed to work without user interaction or any kind of
@ -45,11 +44,10 @@ package includes files needed for developing applications which can
use cURL's capabilities internally. use cURL's capabilities internally.
%prep %prep
%setup -q %setup -q
%patch1 -p1 -b .multilib %patch1 -p1 -b .multilib
%patch2 -p1 -b .privlibs %patch2 -p1 -b .privlibs
%patch3 -p1 -b .curl-config %patch3 -p1 -b .badsocket
%patch4 -p1 -b .badsocket
%build %build
export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT -D_GNU_SOURCE=1" export CPPFLAGS="$(pkg-config --cflags nss) -DHAVE_PK11_CREATEGENERICOBJECT -D_GNU_SOURCE=1"
@ -96,7 +94,7 @@ rm -rf $RPM_BUILD_ROOT
%files -n libcurl-devel %files -n libcurl-devel
%defattr(-,root,root) %defattr(-,root,root)
%doc docs/examples/*.c docs/examples/Makefile.example docs/INTERNALS %doc docs/examples/*.c docs/examples/Makefile.example docs/INTERNALS
%doc docs/CONTRIBUTE %doc docs/CONTRIBUTE docs/libcurl/ABI
%{_bindir}/curl-config* %{_bindir}/curl-config*
%{_includedir}/curl %{_includedir}/curl
%{_libdir}/*.so %{_libdir}/*.so
@ -106,6 +104,13 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/libcurl.m4 %{_datadir}/aclocal/libcurl.m4
%changelog %changelog
* Mon Mar 31 2008 Jindrich Novy <jnovy@redhat.com> 7.18.1-1
- update to curl 7.18.1 (fixes #397911)
- add ABI docs for libcurl
- remove --static-libs from curl-config
- drop curl-config patch, obsoleted by @SSL_ENABLED@ autoconf
substitution (#432667)
* Fri Feb 15 2008 Jindrich Novy <jnovy@redhat.com> 7.18.0-2 * Fri Feb 15 2008 Jindrich Novy <jnovy@redhat.com> 7.18.0-2
- define _GNU_SOURCE so that NI_MAXHOST gets defined from glibc - define _GNU_SOURCE so that NI_MAXHOST gets defined from glibc

View File

@ -1 +1 @@
3e50dd887d6a354be312d874e1d3426c curl-7.18.0.tar.bz2 805834fc1136ff7600d2179bc0386c5a curl-7.18.1.tar.bz2