fix infinite loop while loading a private key (#453612)

This commit is contained in:
Kamil Dudka 2009-05-11 08:42:34 +00:00
parent 60030aadea
commit 18bd567435
2 changed files with 19 additions and 1 deletions

12
curl-7.19.4-infloop.patch Normal file
View File

@ -0,0 +1,12 @@
diff -ruNp curl-7.19.4.orig/lib/nss.c curl-7.19.4/lib/nss.c
--- curl-7.19.4.orig/lib/nss.c 2009-05-11 10:21:19.136924000 +0200
+++ curl-7.19.4/lib/nss.c 2009-05-11 10:22:31.190315791 +0200
@@ -591,7 +591,7 @@ static char * nss_get_password(PK11SlotI
parg = (pphrase_arg_t *) arg;
(void)slot; /* unused */
- if(retry > 2)
+ if(retry)
return NULL;
if(parg->data->set.str[STRING_KEY_PASSWD])
return (char *)PORT_Strdup((char *)parg->data->set.str[STRING_KEY_PASSWD]);

View File

@ -1,7 +1,7 @@
Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
Name: curl
Version: 7.19.4
Release: 4%{?dist}
Release: 5%{?dist}
License: MIT
Group: Applications/Internet
Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
@ -9,6 +9,7 @@ Patch1: curl-7.15.3-multilib.patch
Patch2: curl-7.16.0-privlibs.patch
Patch3: curl-7.17.1-badsocket.patch
Patch4: curl-7.19.4-debug.patch
Patch5: curl-7.19.4-infloop.patch
Provides: webclient
URL: http://curl.haxx.se/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -52,6 +53,7 @@ use cURL's capabilities internally.
%patch2 -p1 -b .privlibs
%patch3 -p1 -b .badsocket
%patch4 -p1 -b .debug
%patch5 -p1 -b .infloop
# Convert docs to UTF-8
for f in CHANGES README; do
@ -144,6 +146,10 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/aclocal/libcurl.m4
%changelog
* Mon May 11 2009 Kamil Dudka <kdudka@redhat.com> 7.19.4-5
- fix infinite loop while loading a private key, thanks to Michael Cronenworth
(#453612)
* Mon Apr 27 2009 Kamil Dudka <kdudka@redhat.com> 7.19.4-4
- fix configure.ac to not discard -g in CFLAGS, thanks to Debarshi Ray (#496778)