make the curl tool link SSL libraries also used by src/tool_metalink.c
This commit is contained in:
parent
82daaf7e98
commit
05df56af61
63
0103-curl-7.31.0-metalink.patch
Normal file
63
0103-curl-7.31.0-metalink.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
From 5a4feefe61733d7b650d6f6e1995a6d1555530d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Kamil Dudka <kdudka@redhat.com>
|
||||||
|
Date: Wed, 26 Jun 2013 18:00:43 +0200
|
||||||
|
Subject: [PATCH] make the curl tool link SSL libraries also used by src/tool_metalink.c
|
||||||
|
|
||||||
|
---
|
||||||
|
configure | 10 +++-------
|
||||||
|
configure.ac | 18 +++++++++++-------
|
||||||
|
2 files changed, 14 insertions(+), 14 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/configure b/configure
|
||||||
|
index a466175..cb63075 100755
|
||||||
|
--- a/configure
|
||||||
|
+++ b/configure
|
||||||
|
@@ -14571,13 +14571,9 @@ fi
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
|
-# Determine whether all dependent libraries must be specified when linking
|
||||||
|
-if test "X$enable_shared" = "Xyes" -a "X$link_all_deplibs" = "Xno"
|
||||||
|
-then
|
||||||
|
- REQUIRE_LIB_DEPS=no
|
||||||
|
-else
|
||||||
|
- REQUIRE_LIB_DEPS=yes
|
||||||
|
-fi
|
||||||
|
+REQUIRE_LIB_DEPS=yes
|
||||||
|
+
|
||||||
|
+
|
||||||
|
|
||||||
|
if test x$REQUIRE_LIB_DEPS = xyes; then
|
||||||
|
USE_EXPLICIT_LIB_DEPS_TRUE=
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 49309e6..90c56b5 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -243,13 +243,17 @@ fi
|
||||||
|
AC_SUBST([CPPFLAG_CURL_STATICLIB])
|
||||||
|
|
||||||
|
|
||||||
|
-# Determine whether all dependent libraries must be specified when linking
|
||||||
|
-if test "X$enable_shared" = "Xyes" -a "X$link_all_deplibs" = "Xno"
|
||||||
|
-then
|
||||||
|
- REQUIRE_LIB_DEPS=no
|
||||||
|
-else
|
||||||
|
- REQUIRE_LIB_DEPS=yes
|
||||||
|
-fi
|
||||||
|
+dnl make the curl tool link SSL libraries also used by src/tool_metalink.c
|
||||||
|
+REQUIRE_LIB_DEPS=yes
|
||||||
|
+
|
||||||
|
+dnl # Determine whether all dependent libraries must be specified when linking
|
||||||
|
+dnl if test "X$enable_shared" = "Xyes" -a "X$link_all_deplibs" = "Xno"
|
||||||
|
+dnl then
|
||||||
|
+dnl REQUIRE_LIB_DEPS=no
|
||||||
|
+dnl else
|
||||||
|
+dnl REQUIRE_LIB_DEPS=yes
|
||||||
|
+dnl fi
|
||||||
|
+
|
||||||
|
AC_SUBST(REQUIRE_LIB_DEPS)
|
||||||
|
AM_CONDITIONAL(USE_EXPLICIT_LIB_DEPS, test x$REQUIRE_LIB_DEPS = xyes)
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.1
|
||||||
|
|
@ -16,6 +16,9 @@ Patch101: 0101-curl-7.31.0-multilib.patch
|
|||||||
# prevent configure script from discarding -g in CFLAGS (#496778)
|
# prevent configure script from discarding -g in CFLAGS (#496778)
|
||||||
Patch102: 0102-curl-7.31.0-debug.patch
|
Patch102: 0102-curl-7.31.0-debug.patch
|
||||||
|
|
||||||
|
# make the curl tool link SSL libraries also used by src/tool_metalink.c
|
||||||
|
Patch103: 0103-curl-7.31.0-metalink.patch
|
||||||
|
|
||||||
# use localhost6 instead of ip6-localhost in the curl test-suite
|
# use localhost6 instead of ip6-localhost in the curl test-suite
|
||||||
Patch104: 0104-curl-7.19.7-localhost6.patch
|
Patch104: 0104-curl-7.19.7-localhost6.patch
|
||||||
|
|
||||||
@ -109,6 +112,7 @@ documentation of the library, too.
|
|||||||
# Fedora patches
|
# Fedora patches
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
|
%patch103 -p1
|
||||||
%patch104 -p1
|
%patch104 -p1
|
||||||
%patch106 -p1
|
%patch106 -p1
|
||||||
%patch107 -p1
|
%patch107 -p1
|
||||||
|
Loading…
Reference in New Issue
Block a user