cups/cups-1.1.16-system-auth.patch
2006-03-17 12:10:57 +00:00

27 lines
1021 B
Diff

--- cups-1.2svn-r5238/conf/Makefile.system-auth 2006-03-07 09:34:20.000000000 +0000
+++ cups-1.2svn-r5238/conf/Makefile 2006-03-07 09:45:41.000000000 +0000
@@ -79,10 +79,14 @@
done
-if test x$(PAMDIR) != x; then \
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(PAMDIR); \
- if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
+ if test -f /etc/pam.d/system-auth; then \
+ $(INSTALL_DATA) cups.system-auth $(BUILDROOT)$(PAMDIR)/cups ; \
else \
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
+ if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
+ else \
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
+ fi ; \
fi ; \
fi
--- /dev/null 2006-03-07 09:12:30.964372750 +0000
+++ cups-1.2svn-r5238/conf/cups.system-auth 2006-03-07 09:43:12.000000000 +0000
@@ -0,0 +1,3 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth