6a7d7ab6fb
- Removed postscript.ppd.gz (bug #533371). - Renumbered patches and sources.
40 lines
1.6 KiB
Diff
40 lines
1.6 KiB
Diff
diff -up /dev/null cups-1.4.2/conf/cups.password-auth
|
|
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
|
|
+++ cups-1.4.2/conf/cups.password-auth 2009-11-10 11:15:42.750666738 +0000
|
|
@@ -0,0 +1,4 @@
|
|
+#%PAM-1.0
|
|
+# Use password-auth common PAM configuration for the daemon
|
|
+auth include password-auth
|
|
+account include password-auth
|
|
diff -up cups-1.4.2/conf/cups.system-auth cups-1.4.2/conf/cups
|
|
diff -up /dev/null cups-1.4.2/conf/cups.system-auth
|
|
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
|
|
+++ cups-1.4.2/conf/cups.system-auth 2009-11-10 11:15:42.750666738 +0000
|
|
@@ -0,0 +1,3 @@
|
|
+#%PAM-1.0
|
|
+auth include system-auth
|
|
+account include system-auth
|
|
diff -up cups-1.4.2/conf/Makefile.system-auth cups-1.4.2/conf/Makefile
|
|
--- cups-1.4.2/conf/Makefile.system-auth 2009-09-22 22:53:31.000000000 +0100
|
|
+++ cups-1.4.2/conf/Makefile 2009-11-10 11:18:44.188791989 +0000
|
|
@@ -90,10 +90,16 @@ install-data:
|
|
done
|
|
-if test x$(PAMDIR) != x; then \
|
|
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(PAMDIR); \
|
|
- if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
|
|
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
|
|
+ if test -f /etc/pam.d/password-auth; then \
|
|
+ $(INSTALL_DATA) cups.password-auth $(BUILDROOT)$(PAMDIR)/cups; \
|
|
+ elif test -f /etc/pam.d/system-auth; then \
|
|
+ $(INSTALL_DATA) cups.system-auth $(BUILDROOT)$(PAMDIR)/cups; \
|
|
else \
|
|
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
|
|
+ if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
|
|
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
|
|
+ else \
|
|
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
|
|
+ fi ; \
|
|
fi ; \
|
|
fi
|
|
|