- 1.2.11.

This commit is contained in:
Tim Waugh 2007-06-13 16:43:07 +00:00
parent f76166e252
commit eb99a8db4f
8 changed files with 91 additions and 140 deletions

View File

@ -20,3 +20,4 @@ cups-1.2.7-source.tar.bz2
cups-1.2.8-source.tar.bz2
cups-1.2.9-source.tar.bz2
cups-1.2.10-source.tar.bz2
cups-1.2.11-source.tar.bz2

View File

@ -1,6 +1,6 @@
--- cups-1.2.9/Makefile.noinit 2007-03-12 20:49:13.000000000 +0000
+++ cups-1.2.9/Makefile 2007-03-16 10:43:41.000000000 +0000
@@ -99,39 +99,6 @@
--- cups-1.2.11/Makefile.noinit 2007-05-07 20:10:54.000000000 +0100
+++ cups-1.2.11/Makefile 2007-06-13 16:44:37.000000000 +0100
@@ -100,48 +100,6 @@
echo Installing cups-config script...
$(INSTALL_DIR) -m 755 $(BINDIR)
$(INSTALL_SCRIPT) cups-config $(BINDIR)/cups-config
@ -26,12 +26,21 @@
- echo Installing StartupItems files...; \
- $(INSTALL_SCRIPT) init/PrintingServices $(BUILDROOT)$(INITDDIR)/PrintingServices; \
- $(INSTALL_DATA) init/StartupParameters.plist $(BUILDROOT)$(INITDDIR)/StartupParameters.plist; \
- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
- $(INSTALL_DIR) $(BUILDROOT)$(INITDDIR)/Resources/English.lproj; \
- $(INSTALL_DATA) init/Localizable.strings $(BUILDROOT)$(INITDDIR)/Resources/English.lproj/Localizable.strings; \
- elif test "$(INITDDIR)" = "/System/Library/LaunchDaemons"; then \
- echo Installing LaunchDaemons configuration files...; \
- $(INSTALL_DATA) init/org.cups.cupsd.plist $(BUILDROOT)$(DEFAULT_LAUNCHD_CONF); \
- $(INSTALL_DATA) init/org.cups.cups-lpd.plist $(BUILDROOT)/System/Library/LaunchDaemons; \
- case `uname -r` in \
- 8.*) \
- $(INSTALL_DIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices; \
- $(INSTALL_SCRIPT) init/PrintingServices.launchd $(BUILDROOT)/System/Library/StartupItems/PrintingServices/PrintingServices; \
- $(INSTALL_DATA) init/StartupParameters.plist $(BUILDROOT)/System/Library/StartupItems/PrintingServices/StartupParameters.plist; \
- $(INSTALL_DIR) $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj; \
- $(INSTALL_DATA) init/Localizable.strings $(BUILDROOT)/System/Library/StartupItems/PrintingServices/Resources/English.lproj/Localizable.strings; \
- ;; \
- esac \
- else \
- echo Installing RC script...; \
- $(INSTALL_SCRIPT) init/cups.sh $(BUILDROOT)$(INITDDIR)/cups; \

View File

@ -1,15 +1,16 @@
--- cups-1.2.8/backend/usb-unix.c.direct-usb 2007-02-05 20:25:50.000000000 +0000
+++ cups-1.2.8/backend/usb-unix.c 2007-02-14 17:44:40.000000000 +0000
@@ -87,6 +87,8 @@
use_bc = strcasecmp(hostname, "Canon") &&
strcasecmp(hostname, "Konica Minolta") &&
--- cups-1.2.11/backend/usb-unix.c.direct-usb 2007-05-04 15:03:02.000000000 +0100
+++ cups-1.2.11/backend/usb-unix.c 2007-06-13 16:46:56.000000000 +0100
@@ -101,6 +101,9 @@
strcasecmp(hostname, "Minolta");
#endif /* __FreeBSD__ || __NetBSD__ || __OpenBSD__ || __DragonFly__ */
+ if (use_bc && !strncmp(uri, "usb:/dev/", 9))
+ use_bc = 0;
+
if ((device_fd = open_device(uri, &use_bc)) == -1)
{
@@ -304,12 +306,7 @@
if (getenv("CLASS") != NULL)
@@ -317,12 +320,7 @@
if (!strncmp(uri, "usb:/dev/", 9))
#ifdef __linux
{

View File

@ -1,60 +1,5 @@
--- cups-1.2.5/config-scripts/cups-common.m4.eggcups 2006-10-20 16:11:40.000000000 +0100
+++ cups-1.2.5/config-scripts/cups-common.m4 2006-11-03 09:55:31.000000000 +0000
@@ -191,6 +191,7 @@
dnl Extra platform-specific libraries...
BACKLIBS=""
CUPSDLIBS=""
+DBUSLIBS=""
DBUSDIR=""
AC_ARG_ENABLE(dbus, [ --enable-dbus enable DBUS support, default=auto])
@@ -234,7 +235,8 @@
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_DBUS)
CFLAGS="$CFLAGS `$PKGCONFIG --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
- CUPSDLIBS="`$PKGCONFIG --libs dbus-1`"
+ DBUSLIBS="`$PKGCONFIG --libs dbus-1`"
+ CUPSDLIBS="$DBUSLIBS"
DBUSDIR="/etc/dbus-1/system.d"
AC_CHECK_LIB(dbus-1,
dbus_message_iter_init_append,
@@ -256,6 +258,7 @@
AC_SUBST(BACKLIBS)
AC_SUBST(CUPSDLIBS)
+AC_SUBST(DBUSLIBS)
AC_SUBST(DBUSDIR)
dnl New default port definition for IPP...
--- cups-1.2.5/scheduler/subscriptions.c.eggcups 2006-09-29 03:26:29.000000000 +0100
+++ cups-1.2.5/scheduler/subscriptions.c 2006-11-03 09:59:16.000000000 +0000
@@ -1321,13 +1321,13 @@
what = "PrinterAdded";
else if (event & CUPSD_EVENT_PRINTER_DELETED)
what = "PrinterRemoved";
- else if (event & CUPSD_EVENT_PRINTER_CHANGED)
- what = "QueueChanged";
else if (event & CUPSD_EVENT_JOB_CREATED)
what = "JobQueuedLocal";
else if ((event & CUPSD_EVENT_JOB_STATE) && job &&
job->state_value == IPP_JOB_PROCESSING)
what = "JobStartedLocal";
+ else if (event & (CUPSD_EVENT_PRINTER_CHANGED|CUPSD_EVENT_JOB_STATE_CHANGED|CUPSD_EVENT_PRINTER_STATE_CHANGED))
+ what = "QueueChanged";
else
return;
@@ -1363,7 +1363,7 @@
dbus_message_append_iter_init(message, &iter);
if (dest)
dbus_message_iter_append_string(&iter, &(dest->name));
- if (job)
+ if (job && strcmp (what, "QueueChanged") != 0)
{
dbus_message_iter_append_uint32(&iter, &(job->id));
dbus_message_iter_append_string(&iter, &(job->username));
--- cups-1.2.5/backend/ipp.c.eggcups 2006-09-13 19:22:34.000000000 +0100
+++ cups-1.2.5/backend/ipp.c 2006-11-03 10:02:04.000000000 +0000
--- cups-1.2.11/backend/ipp.c.eggcups 2007-04-30 18:18:21.000000000 +0100
+++ cups-1.2.11/backend/ipp.c 2007-06-13 16:47:06.000000000 +0100
@@ -54,6 +54,70 @@
#include <signal.h>
#include <sys/wait.h>
@ -126,7 +71,7 @@
/*
* Globals...
@@ -936,6 +1000,15 @@
@@ -955,6 +1019,15 @@
fprintf(stderr, "NOTICE: Print file accepted - job ID %d.\n", job_id);
}
@ -142,8 +87,8 @@
ippDelete(response);
if (job_cancelled)
--- cups-1.2.5/backend/Makefile.eggcups 2006-05-26 20:51:59.000000000 +0100
+++ cups-1.2.5/backend/Makefile 2006-11-03 09:55:31.000000000 +0000
--- cups-1.2.11/backend/Makefile.eggcups 2006-10-23 01:26:52.000000000 +0100
+++ cups-1.2.11/backend/Makefile 2007-06-13 16:47:06.000000000 +0100
@@ -134,7 +134,7 @@
ipp: ipp.o ../cups/$(LIBCUPS)
@ -153,8 +98,63 @@
$(RM) http
$(LN) ipp http
--- cups-1.2.5/Makedefs.in.eggcups 2006-11-03 09:55:31.000000000 +0000
+++ cups-1.2.5/Makedefs.in 2006-11-03 09:55:31.000000000 +0000
--- cups-1.2.11/config-scripts/cups-common.m4.eggcups 2007-05-08 22:11:23.000000000 +0100
+++ cups-1.2.11/config-scripts/cups-common.m4 2007-06-13 16:47:06.000000000 +0100
@@ -188,6 +188,7 @@
dnl Extra platform-specific libraries...
BACKLIBS=""
CUPSDLIBS=""
+DBUSLIBS=""
DBUSDIR=""
AC_ARG_ENABLE(dbus, [ --enable-dbus enable DBUS support, default=auto])
@@ -231,7 +232,8 @@
AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_DBUS)
CFLAGS="$CFLAGS `$PKGCONFIG --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
- CUPSDLIBS="`$PKGCONFIG --libs dbus-1`"
+ DBUSLIBS="`$PKGCONFIG --libs dbus-1`"
+ CUPSDLIBS="$DBUSLIBS"
DBUSDIR="/etc/dbus-1/system.d"
AC_CHECK_LIB(dbus-1,
dbus_message_iter_init_append,
@@ -253,6 +255,7 @@
AC_SUBST(BACKLIBS)
AC_SUBST(CUPSDLIBS)
+AC_SUBST(DBUSLIBS)
AC_SUBST(DBUSDIR)
dnl New default port definition for IPP...
--- cups-1.2.11/scheduler/subscriptions.c.eggcups 2007-04-10 19:24:19.000000000 +0100
+++ cups-1.2.11/scheduler/subscriptions.c 2007-06-13 16:48:10.000000000 +0100
@@ -1321,13 +1321,13 @@
what = "PrinterAdded";
else if (event & CUPSD_EVENT_PRINTER_DELETED)
what = "PrinterRemoved";
- else if (event & CUPSD_EVENT_PRINTER_CHANGED)
- what = "QueueChanged";
else if (event & CUPSD_EVENT_JOB_CREATED)
what = "JobQueuedLocal";
else if ((event & CUPSD_EVENT_JOB_STATE) && job &&
job->state_value == IPP_JOB_PROCESSING)
what = "JobStartedLocal";
+ else if (event & (CUPSD_EVENT_PRINTER_CHANGED|CUPSD_EVENT_JOB_STATE_CHANGED|CUPSD_EVENT_PRINTER_STATE_CHANGED))
+ what = "QueueChanged";
else
return;
@@ -1363,7 +1363,7 @@
dbus_message_append_iter_init(message, &iter);
if (dest)
dbus_message_iter_append_string(&iter, dest->name);
- if (job)
+ if (job && strcmp (what, "QueueChanged") != 0)
{
dbus_message_iter_append_uint32(&iter, job->id);
dbus_message_iter_append_string(&iter, job->username);
--- cups-1.2.11/Makedefs.in.eggcups 2007-06-13 16:47:06.000000000 +0100
+++ cups-1.2.11/Makedefs.in 2007-06-13 16:47:06.000000000 +0100
@@ -124,6 +124,7 @@
@LARGEFILE@ @PTHREAD_FLAGS@ $(OPTIONS)
COMMONLIBS = @LIBS@

View File

@ -1,10 +0,0 @@
--- cups-1.2.10/scheduler/job.c.printer-state-reasons 2007-04-02 13:42:22.000000000 +0100
+++ cups-1.2.10/scheduler/job.c 2007-04-02 13:42:35.000000000 +0100
@@ -215,7 +215,6 @@
printer->state_message[0] = '\0';
- cupsdSetPrinterReasons(printer, "");
cupsdSetPrinterState(printer, IPP_PRINTER_IDLE, 0);
cupsdAddEvent(CUPSD_EVENT_JOB_COMPLETED, printer, job,

View File

@ -1,50 +0,0 @@
--- cups-1.2.10/pdftops/PSOutputDev.cxx.str2348 2007-02-05 20:25:50.000000000 +0000
+++ cups-1.2.10/pdftops/PSOutputDev.cxx 2007-05-09 13:20:13.000000000 +0100
@@ -1159,7 +1159,14 @@
}
// Tell CUPS pstops filter not to do its own rotation...
- writePSFmt("%%cupsRotation: %d\n", pageRotate);
+ int cups_rotate = 0;
+ int width = (int)ceil(mediaBox->x2 - mediaBox->x1);
+ int height = (int)ceil(mediaBox->y2 - mediaBox->y1);
+ int imgWidth = (int)ceil(cropBox->x2 - cropBox->x1);
+
+ if (width > height && width > imgWidth) cups_rotate = 90;
+
+ writePSFmt("%%cupsRotation: %d\n", cups_rotate);
writePSFmt("%%Producer: xpdf/pdftops %s\n", xpdfVersion);
xref->getDocInfo(&info);
@@ -2511,17 +2518,19 @@
landscape = gFalse;
} else {
rotate = (360 - state->getRotate()) % 360;
+
+ fprintf(stderr, "DEBUG: Page rotate=%d, width=%d, height=%d, imgWidth=%d, imgHeight=%d\n",
+ state->getRotate(), width, height, imgWidth, imgHeight);
+
if (rotate == 0 || rotate == 180) {
- if ((width > height && imgWidth < imgHeight) ||
- (height > width && imgHeight < imgWidth)) {
+ if (width > height && width > imgWidth) {
rotate += 90;
landscape = gTrue;
} else {
landscape = gFalse;
}
} else { // rotate == 90 || rotate == 270
- if ((width > height && imgWidth < imgHeight) ||
- (height > width && imgHeight < imgWidth)) {
+ if (height > width && height > imgWidth) {
rotate = 270 - rotate;
landscape = gTrue;
} else {
@@ -2529,6 +2538,7 @@
}
}
}
+
writePSFmt("%%%%PageOrientation: %s\n",
landscape ? "Landscape" : "Portrait");
writePS("pdfStartPage\n");

View File

@ -5,8 +5,8 @@
Summary: Common Unix Printing System
Name: cups
Version: 1.2.10
Release: 10%{?dist}
Version: 1.2.11
Release: 1%{?dist}
License: GPL
Group: System Environment/Daemons
Source: ftp://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
@ -44,10 +44,8 @@ Patch19: cups-eggcups.patch
Patch20: cups-getpass.patch
Patch21: cups-driverd-timeout.patch
Patch22: cups-af_unix-auth.patch
Patch23: cups-str2323.patch
Patch24: cups-str2109.patch
Patch25: cups-usb-paperout.patch
Patch26: cups-str2348.patch
Patch100: cups-lspp.patch
Epoch: 1
Url: http://www.cups.org/
@ -154,10 +152,8 @@ lpd emulation.
%patch20 -p1 -b .getpass
%patch21 -p1 -b .driverd-timeout
%patch22 -p1 -b .af_unix-auth
%patch23 -p1 -b .str2323
%patch24 -p1 -b .str2109
%patch25 -p1 -b .usb-paperout
%patch26 -p1 -b .str2348
%if %lspp
%patch100 -p1 -b .lspp
@ -380,6 +376,7 @@ rm -rf $RPM_BUILD_ROOT
%{_docdir}/cups-%{version}/ja
%{_docdir}/cups-%{version}/pl
%{_docdir}/cups-%{version}/sv
%{_docdir}/cups-%{version}/zh_TW
%{_docdir}/cups-%{version}/*.css
%{_docdir}/cups-%{version}/admin
%{_docdir}/cups-%{version}/classes
@ -444,6 +441,9 @@ rm -rf $RPM_BUILD_ROOT
%{cups_serverbin}/daemon/cups-lpd
%changelog
* Wed Jun 13 2007 Tim Waugh <twaugh@redhat.com> 1:1.2.11-1
- 1.2.11.
* Tue Jun 12 2007 Tim Waugh <twaugh@redhat.com>
- Make the initscript use start priority 56 (bug #213828).
- Better paper-out detection patch (bug #241589).

View File

@ -1,2 +1,2 @@
b0bb017098e8e76b8a25e666c41ce540 postscript.ppd.gz
aad696a480b618e61bc7dab11623d3ac cups-1.2.10-source.tar.bz2
2742f1eec38abb04472b86627da8e493 cups-1.2.11-source.tar.bz2