Merge branch 'f22' into f23
This commit is contained in:
commit
d3aa890d88
1
.gitignore
vendored
1
.gitignore
vendored
@ -67,3 +67,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-2.0.1-source.tar.bz2
|
/cups-2.0.1-source.tar.bz2
|
||||||
/cups-2.0.2-source.tar.bz2
|
/cups-2.0.2-source.tar.bz2
|
||||||
/cups-2.0.3-source.tar.bz2
|
/cups-2.0.3-source.tar.bz2
|
||||||
|
/cups-2.0.4-source.tar.bz2
|
||||||
|
Binary file not shown.
BIN
cups-2.0.4-source.tar.bz2.sig
Normal file
BIN
cups-2.0.4-source.tar.bz2.sig
Normal file
Binary file not shown.
@ -1,26 +0,0 @@
|
|||||||
diff -up cups-2.0.3/scheduler/client.c.str4538 cups-2.0.3/scheduler/client.c
|
|
||||||
--- cups-2.0.3/scheduler/client.c.str4538 2015-06-25 08:35:22.196788744 +0100
|
|
||||||
+++ cups-2.0.3/scheduler/client.c 2015-06-25 08:35:38.079786648 +0100
|
|
||||||
@@ -2294,6 +2294,9 @@ cupsdSendError(cupsd_client_t *con, /* I
|
|
||||||
http_status_t code, /* I - Error code */
|
|
||||||
int auth_type)/* I - Authentication type */
|
|
||||||
{
|
|
||||||
+ char location[HTTP_MAX_VALUE]; /* Location field */
|
|
||||||
+
|
|
||||||
+
|
|
||||||
cupsdLogClient(con, CUPSD_LOG_DEBUG2, "cupsdSendError code=%d, auth_type=%d",
|
|
||||||
code, auth_type);
|
|
||||||
|
|
||||||
@@ -2326,8 +2329,12 @@ cupsdSendError(cupsd_client_t *con, /* I
|
|
||||||
* never disable it in that case.
|
|
||||||
*/
|
|
||||||
|
|
||||||
+ strlcpy(location, httpGetField(con->http, HTTP_FIELD_LOCATION), sizeof(location));
|
|
||||||
+
|
|
||||||
httpClearFields(con->http);
|
|
||||||
|
|
||||||
+ httpSetField(con->http, HTTP_FIELD_LOCATION, location);
|
|
||||||
+
|
|
||||||
if (code >= HTTP_STATUS_BAD_REQUEST && con->type != CUPSD_AUTH_NEGOTIATE)
|
|
||||||
httpSetKeepAlive(con->http, HTTP_KEEPALIVE_OFF);
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -up cups-2.0.3/scheduler/job.c.str4646 cups-2.0.3/scheduler/job.c
|
|
||||||
--- cups-2.0.3/scheduler/job.c.str4646 2015-06-25 08:57:18.780913432 +0100
|
|
||||||
+++ cups-2.0.3/scheduler/job.c 2015-06-25 08:57:29.669132254 +0100
|
|
||||||
@@ -392,7 +392,9 @@ cupsdCheckJobs(void)
|
|
||||||
* Start the job...
|
|
||||||
*/
|
|
||||||
|
|
||||||
+ cupsArraySave(ActiveJobs);
|
|
||||||
start_job(job, printer);
|
|
||||||
+ cupsArrayRestore(ActiveJobs);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
13
cups.spec
13
cups.spec
@ -10,8 +10,8 @@
|
|||||||
Summary: CUPS printing system
|
Summary: CUPS printing system
|
||||||
Name: cups
|
Name: cups
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.0.3
|
Version: 2.0.4
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Url: http://www.cups.org/
|
Url: http://www.cups.org/
|
||||||
Source0: http://www.cups.org/software/%{version}/cups-%{version}-source.tar.bz2
|
Source0: http://www.cups.org/software/%{version}/cups-%{version}-source.tar.bz2
|
||||||
@ -26,7 +26,6 @@ Source8: macros.cups
|
|||||||
Patch1: cups-no-gzip-man.patch
|
Patch1: cups-no-gzip-man.patch
|
||||||
Patch2: cups-system-auth.patch
|
Patch2: cups-system-auth.patch
|
||||||
Patch3: cups-multilib.patch
|
Patch3: cups-multilib.patch
|
||||||
Patch4: cups-str4538.patch
|
|
||||||
Patch5: cups-banners.patch
|
Patch5: cups-banners.patch
|
||||||
Patch6: cups-serverbin-compat.patch
|
Patch6: cups-serverbin-compat.patch
|
||||||
Patch7: cups-no-export-ssllibs.patch
|
Patch7: cups-no-export-ssllibs.patch
|
||||||
@ -48,7 +47,6 @@ Patch22: cups-hp-deviceid-oid.patch
|
|||||||
Patch23: cups-dnssd-deviceid.patch
|
Patch23: cups-dnssd-deviceid.patch
|
||||||
Patch24: cups-ricoh-deviceid-oid.patch
|
Patch24: cups-ricoh-deviceid-oid.patch
|
||||||
Patch25: cups-systemd-socket.patch
|
Patch25: cups-systemd-socket.patch
|
||||||
Patch26: cups-str4646.patch
|
|
||||||
Patch27: cups-avahi-address.patch
|
Patch27: cups-avahi-address.patch
|
||||||
Patch28: cups-enum-all.patch
|
Patch28: cups-enum-all.patch
|
||||||
Patch29: cups-dymo-deviceid.patch
|
Patch29: cups-dymo-deviceid.patch
|
||||||
@ -190,8 +188,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch2 -p1 -b .system-auth
|
%patch2 -p1 -b .system-auth
|
||||||
# Prevent multilib conflict in cups-config script.
|
# Prevent multilib conflict in cups-config script.
|
||||||
%patch3 -p1 -b .multilib
|
%patch3 -p1 -b .multilib
|
||||||
# Fix redirection from CGI scripts (bug #1232030, STR #4538).
|
|
||||||
%patch4 -p1 -b .str4538
|
|
||||||
# Ignore rpm save/new files in the banners directory.
|
# Ignore rpm save/new files in the banners directory.
|
||||||
%patch5 -p1 -b .banners
|
%patch5 -p1 -b .banners
|
||||||
# Use compatibility fallback path for ServerBin.
|
# Use compatibility fallback path for ServerBin.
|
||||||
@ -234,8 +230,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch24 -p1 -b .ricoh-deviceid-oid
|
%patch24 -p1 -b .ricoh-deviceid-oid
|
||||||
# Make cups.service Type=notify (bug #1088918).
|
# Make cups.service Type=notify (bug #1088918).
|
||||||
%patch25 -p1 -b .systemd-socket
|
%patch25 -p1 -b .systemd-socket
|
||||||
# Fix slow resume of jobs after restart (STR #4646).
|
|
||||||
%patch26 -p1 -b .str4646
|
|
||||||
# Use IP address when resolving DNSSD URIs (bug #948288).
|
# Use IP address when resolving DNSSD URIs (bug #948288).
|
||||||
%patch27 -p1 -b .avahi-address
|
%patch27 -p1 -b .avahi-address
|
||||||
# Return from cupsEnumDests() once all records have been returned.
|
# Return from cupsEnumDests() once all records have been returned.
|
||||||
@ -618,6 +612,9 @@ rm -f %{cups_serverbin}/backend/smb
|
|||||||
%{_mandir}/man5/ipptoolfile.5.gz
|
%{_mandir}/man5/ipptoolfile.5.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 10 2015 Jiri Popelka <jpopelka@redhat.com> - 1:2.0.4-1
|
||||||
|
- 2.0.4
|
||||||
|
|
||||||
* Tue Jul 28 2015 Jiri Popelka <jpopelka@redhat.com> - 1:2.0.3-5
|
* Tue Jul 28 2015 Jiri Popelka <jpopelka@redhat.com> - 1:2.0.3-5
|
||||||
- BuildRequires: gnutls-devel -> pkgconfig(gnutls)
|
- BuildRequires: gnutls-devel -> pkgconfig(gnutls)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user