rebase to 2.2.2

This commit is contained in:
Zdenek Dohnal 2017-01-19 12:02:44 +01:00
parent b1c96a522c
commit a5a6beb630
8 changed files with 98 additions and 190 deletions

1
.gitignore vendored
View File

@ -79,3 +79,4 @@ cups-1.4.4-source.tar.bz2
/cups-2.2rc1-source.tar.gz
/cups-2.2.0-source.tar.gz
/cups-2.2.1-source.tar.gz
/cups-2.2.2-source.tar.gz

Binary file not shown.

Binary file not shown.

View File

@ -1,92 +0,0 @@
diff -up cups-2.2.1/CHANGES.txt.iso88591 cups-2.2.1/CHANGES.txt
--- cups-2.2.1/CHANGES.txt.iso88591 2016-11-11 13:59:27.597903504 +0100
+++ cups-2.2.1/CHANGES.txt 2016-11-11 14:08:29.149806797 +0100
@@ -1,6 +1,13 @@
-CHANGES.txt - 2.2.1 - 2016-10-03
+CHANGES.txt - 2.2.2 - 2016-10-13
+
--------------------------------
+CHANGES IN CUPS V2.2.2
+
+ - The cups-lpd program did not catch all legacy usage of ISO-8859-1
+ (Issue #4899)
+
+
CHANGES IN CUPS V2.2.1
- Added "CreateSelfSignedCerts" directive for cups-files.conf to
diff -up cups-2.2.1/doc/help/man-backend.html.iso88591 cups-2.2.1/doc/help/man-backend.html
--- cups-2.2.1/doc/help/man-backend.html.iso88591 2016-11-11 14:00:00.589652892 +0100
+++ cups-2.2.1/doc/help/man-backend.html 2016-11-11 14:10:54.663706372 +0100
@@ -61,7 +61,7 @@ function may be used to retrieve the cor
<p>Backends are responsible for reading side-channel requests using the
<b>cupsSideChannelRead</b>()
function and responding with the
-<b>cupsSideChannelWrite()</b>
+<b>cupsSideChannelWrite</b>()
function. The
<b>CUPS_SC_FD</b>
constant defines the file descriptor that should be monitored for incoming requests.
@@ -147,7 +147,7 @@ CUPS backends can expect the following e
<h2 class="title"><a name="FILES">Files</a></h2>
<i>/etc/cups/cups-files.conf</i>
<h2 class="title"><a name="NOTES">Notes</a></h2>
-CUPS backends are not generally design to be run directly by the user. Aside from the device URI issue (
+CUPS backends are not generally designed to be run directly by the user. Aside from the device URI issue (
<i>argv[0]</i>
and
<b>DEVICE_URI</b>
diff -up cups-2.2.1/scheduler/cups-lpd.c.iso88591 cups-2.2.1/scheduler/cups-lpd.c
--- cups-2.2.1/scheduler/cups-lpd.c.iso88591 2016-11-11 14:00:37.140376293 +0100
+++ cups-2.2.1/scheduler/cups-lpd.c 2016-11-11 14:15:09.836776667 +0100
@@ -1650,16 +1650,24 @@ smart_strlcpy(char *dst, /* I - O
*dstptr++ = 0xc0 | (*srcptr >> 6);
*dstptr++ = 0x80 | (*srcptr++ & 0x3f);
}
- else if ((*srcptr & 0xe0) == 0xc0)
+ else if ((*srcptr & 0xe0) == 0xc0 && (srcptr[1] & 0xc0) == 0x80)
{
+ /*
+ * 2-byte UTF-8 sequence...
+ */
+
if (dstptr > (dstend - 2))
break;
*dstptr++ = *srcptr++;
*dstptr++ = *srcptr++;
}
- else if ((*srcptr & 0xf0) == 0xe0)
+ else if ((*srcptr & 0xf0) == 0xe0 && (srcptr[1] & 0xc0) == 0x80 && (srcptr[2] & 0xc0) == 0x80)
{
+ /*
+ * 3-byte UTF-8 sequence...
+ */
+
if (dstptr > (dstend - 3))
break;
@@ -1667,8 +1675,12 @@ smart_strlcpy(char *dst, /* I - O
*dstptr++ = *srcptr++;
*dstptr++ = *srcptr++;
}
- else if ((*srcptr & 0xf8) == 0xf0)
+ else if ((*srcptr & 0xf8) == 0xf0 && (srcptr[1] & 0xc0) == 0x80 && (srcptr[2] & 0xc0) == 0x80 && (srcptr[3] & 0xc0) == 0x80)
{
+ /*
+ * 4-byte UTF-8 sequence...
+ */
+
if (dstptr > (dstend - 4))
break;
@@ -1680,7 +1692,7 @@ smart_strlcpy(char *dst, /* I - O
else
{
/*
- * Orphan UTF-8 sequence, this must be an ISO-8859-1 string...
+ * Bad UTF-8 sequence, this must be an ISO-8859-1 string...
*/
saw_8859 = 1;

View File

@ -1,7 +1,7 @@
diff -up cups-2.2b2/config.h.in.lspp cups-2.2b2/config.h.in
--- cups-2.2b2/config.h.in.lspp 2016-06-27 17:39:48.075973879 +0200
+++ cups-2.2b2/config.h.in 2016-06-27 17:47:31.376356684 +0200
@@ -737,4 +737,11 @@ static __inline int _cups_abs(int i) { r
diff -up cups-2.2.2/config.h.in.lspp cups-2.2.2/config.h.in
--- cups-2.2.2/config.h.in.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/config.h.in 2017-01-19 11:34:39.235988617 +0100
@@ -730,4 +730,11 @@ static __inline int _cups_abs(int i) { r
# endif /* __GNUC__ || __STDC_VERSION__ */
#endif /* !HAVE_ABS && !abs */
@ -13,9 +13,9 @@ diff -up cups-2.2b2/config.h.in.lspp cups-2.2b2/config.h.in
+
+
#endif /* !_CUPS_CONFIG_H_ */
diff -up cups-2.2b2/config-scripts/cups-lspp.m4.lspp cups-2.2b2/config-scripts/cups-lspp.m4
--- cups-2.2b2/config-scripts/cups-lspp.m4.lspp 2016-06-27 17:39:48.076973871 +0200
+++ cups-2.2b2/config-scripts/cups-lspp.m4 2016-06-27 17:39:48.076973871 +0200
diff -up cups-2.2.2/config-scripts/cups-lspp.m4.lspp cups-2.2.2/config-scripts/cups-lspp.m4
--- cups-2.2.2/config-scripts/cups-lspp.m4.lspp 2017-01-19 11:34:39.235988617 +0100
+++ cups-2.2.2/config-scripts/cups-lspp.m4 2017-01-19 11:34:39.235988617 +0100
@@ -0,0 +1,36 @@
+dnl
+dnl LSPP code for the Common UNIX Printing System (CUPS).
@ -53,9 +53,9 @@ diff -up cups-2.2b2/config-scripts/cups-lspp.m4.lspp cups-2.2b2/config-scripts/c
+ ;;
+ esac
+fi
diff -up cups-2.2b2/configure.ac.lspp cups-2.2b2/configure.ac
--- cups-2.2b2/configure.ac.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/configure.ac 2016-06-27 17:39:48.076973871 +0200
diff -up cups-2.2.2/configure.ac.lspp cups-2.2.2/configure.ac
--- cups-2.2.2/configure.ac.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/configure.ac 2017-01-19 11:34:39.235988617 +0100
@@ -38,6 +38,8 @@ sinclude(config-scripts/cups-startup.m4)
sinclude(config-scripts/cups-defaults.m4)
sinclude(config-scripts/cups-scripting.m4)
@ -65,9 +65,9 @@ diff -up cups-2.2b2/configure.ac.lspp cups-2.2b2/configure.ac
INSTALL_LANGUAGES=""
UNINSTALL_LANGUAGES=""
LANGFILES=""
diff -up cups-2.2b2/filter/common.c.lspp cups-2.2b2/filter/common.c
--- cups-2.2b2/filter/common.c.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/filter/common.c 2016-06-27 17:39:48.076973871 +0200
diff -up cups-2.2.2/filter/common.c.lspp cups-2.2.2/filter/common.c
--- cups-2.2.2/filter/common.c.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/filter/common.c 2017-01-19 11:34:39.235988617 +0100
@@ -17,6 +17,12 @@
* Include necessary headers...
*/
@ -236,9 +236,9 @@ diff -up cups-2.2b2/filter/common.c.lspp cups-2.2b2/filter/common.c
/*
diff -up cups-2.2b2/filter/pstops.c.lspp cups-2.2b2/filter/pstops.c
--- cups-2.2b2/filter/pstops.c.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/filter/pstops.c 2016-06-27 17:39:48.077973863 +0200
diff -up cups-2.2.2/filter/pstops.c.lspp cups-2.2.2/filter/pstops.c
--- cups-2.2.2/filter/pstops.c.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/filter/pstops.c 2017-01-19 11:34:39.236988608 +0100
@@ -3176,6 +3176,18 @@ write_label_prolog(pstops_doc_t *doc, /*
{
const char *classification; /* CLASSIFICATION environment variable */
@ -394,9 +394,9 @@ diff -up cups-2.2b2/filter/pstops.c.lspp cups-2.2b2/filter/pstops.c
/*
diff -up cups-2.2b2/Makedefs.in.lspp cups-2.2b2/Makedefs.in
--- cups-2.2b2/Makedefs.in.lspp 2016-06-27 17:39:48.045974117 +0200
+++ cups-2.2b2/Makedefs.in 2016-06-27 17:39:48.077973863 +0200
diff -up cups-2.2.2/Makedefs.in.lspp cups-2.2.2/Makedefs.in
--- cups-2.2.2/Makedefs.in.lspp 2017-01-19 11:34:39.206988873 +0100
+++ cups-2.2.2/Makedefs.in 2017-01-19 11:34:39.236988608 +0100
@@ -143,7 +143,7 @@ LDFLAGS = -L../cgi-bin -L../cups -L../f
@LDFLAGS@ @RELROFLAGS@ @PIEFLAGS@ $(OPTIM)
LINKCUPS = @LINKCUPS@ $(LIBGSSAPI) $(DNSSDLIBS) $(LIBZ)
@ -406,9 +406,9 @@ diff -up cups-2.2b2/Makedefs.in.lspp cups-2.2b2/Makedefs.in
ONDEMANDFLAGS = @ONDEMANDFLAGS@
ONDEMANDLIBS = @ONDEMANDLIBS@
OPTIM = @OPTIM@
diff -up cups-2.2b2/scheduler/client.c.lspp cups-2.2b2/scheduler/client.c
--- cups-2.2b2/scheduler/client.c.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/scheduler/client.c 2016-06-27 17:39:48.077973863 +0200
diff -up cups-2.2.2/scheduler/client.c.lspp cups-2.2.2/scheduler/client.c
--- cups-2.2.2/scheduler/client.c.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/scheduler/client.c 2017-01-19 11:34:39.281988212 +0100
@@ -22,12 +22,20 @@
#define _HTTP_NO_PRIVATE
#include "cupsd.h"
@ -628,9 +628,9 @@ diff -up cups-2.2b2/scheduler/client.c.lspp cups-2.2b2/scheduler/client.c
/*
* 'pipe_command()' - Pipe the output of a command to the remote client.
diff -up cups-2.2b2/scheduler/client.h.lspp cups-2.2b2/scheduler/client.h
--- cups-2.2b2/scheduler/client.h.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/scheduler/client.h 2016-06-27 17:39:48.077973863 +0200
diff -up cups-2.2.2/scheduler/client.h.lspp cups-2.2.2/scheduler/client.h
--- cups-2.2.2/scheduler/client.h.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/scheduler/client.h 2017-01-19 11:34:39.281988212 +0100
@@ -16,6 +16,13 @@
#endif /* HAVE_AUTHORIZATION_H */
@ -666,9 +666,9 @@ diff -up cups-2.2b2/scheduler/client.h.lspp cups-2.2b2/scheduler/client.h
#ifdef HAVE_SSL
extern int cupsdEndTLS(cupsd_client_t *con);
diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
--- cups-2.2b2/scheduler/conf.c.lspp 2016-06-27 17:39:48.072973903 +0200
+++ cups-2.2b2/scheduler/conf.c 2016-06-27 17:39:48.078973855 +0200
diff -up cups-2.2.2/scheduler/conf.c.lspp cups-2.2.2/scheduler/conf.c
--- cups-2.2.2/scheduler/conf.c.lspp 2017-01-19 11:34:39.232988644 +0100
+++ cups-2.2.2/scheduler/conf.c 2017-01-19 11:34:39.282988203 +0100
@@ -40,6 +40,9 @@
# define INADDR_NONE 0xffffffff
#endif /* !INADDR_NONE */
@ -690,7 +690,7 @@ diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
{ "WebInterface", &WebInterface, CUPSD_VARTYPE_BOOLEAN }
};
static const cupsd_var_t cupsfiles_vars[] =
@@ -577,6 +584,9 @@ cupsdReadConfiguration(void)
@@ -544,6 +551,9 @@ cupsdReadConfiguration(void)
const char *tmpdir; /* TMPDIR environment variable */
struct stat tmpinfo; /* Temporary directory info */
cupsd_policy_t *p; /* Policy */
@ -700,7 +700,7 @@ diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
/*
@@ -931,6 +941,25 @@ cupsdReadConfiguration(void)
@@ -866,6 +876,25 @@ cupsdReadConfiguration(void)
RunUser = getuid();
@ -726,7 +726,7 @@ diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
cupsdLogMessage(CUPSD_LOG_INFO, "Remote access is %s.",
RemotePort ? "enabled" : "disabled");
@@ -1350,7 +1379,19 @@ cupsdReadConfiguration(void)
@@ -1276,7 +1305,19 @@ cupsdReadConfiguration(void)
cupsdClearString(&Classification);
if (Classification)
@ -746,7 +746,7 @@ diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
/*
* Check the MaxClients setting, and then allocate memory for it...
@@ -3827,6 +3868,18 @@ read_location(cups_file_t *fp, /* I - C
@@ -3753,6 +3794,18 @@ read_location(cups_file_t *fp, /* I - C
return ((FatalErrors & CUPSD_FATAL_CONFIG) ? 0 : linenum);
}
@ -765,10 +765,10 @@ diff -up cups-2.2b2/scheduler/conf.c.lspp cups-2.2b2/scheduler/conf.c
/*
* 'read_policy()' - Read a <Policy name> definition.
diff -up cups-2.2b2/scheduler/conf.h.lspp cups-2.2b2/scheduler/conf.h
--- cups-2.2b2/scheduler/conf.h.lspp 2016-06-27 17:39:48.078973855 +0200
+++ cups-2.2b2/scheduler/conf.h 2016-06-27 17:44:46.370632333 +0200
@@ -248,6 +248,13 @@ VAR char *ServerKeychain VALUE(NULL);
diff -up cups-2.2.2/scheduler/conf.h.lspp cups-2.2.2/scheduler/conf.h
--- cups-2.2.2/scheduler/conf.h.lspp 2017-01-19 11:34:39.175989146 +0100
+++ cups-2.2.2/scheduler/conf.h 2017-01-19 11:34:39.283988194 +0100
@@ -250,6 +250,13 @@ VAR char *ServerKeychain VALUE(NULL);
/* Keychain holding cert + key */
#endif /* HAVE_SSL */
@ -782,7 +782,7 @@ diff -up cups-2.2b2/scheduler/conf.h.lspp cups-2.2b2/scheduler/conf.h
#ifdef HAVE_ONDEMAND
VAR int IdleExitTimeout VALUE(60);
/* Time after which an idle cupsd will exit */
@@ -266,6 +273,9 @@ VAR int HaveServerCreds VALUE(0);
@@ -268,6 +275,9 @@ VAR int HaveServerCreds VALUE(0);
VAR gss_cred_id_t ServerCreds; /* Server's GSS credentials */
#endif /* HAVE_GSSAPI */
@ -792,9 +792,9 @@ diff -up cups-2.2b2/scheduler/conf.h.lspp cups-2.2b2/scheduler/conf.h
/*
* Prototypes...
diff -up cups-2.2b2/scheduler/cupsd.h.lspp cups-2.2b2/scheduler/cupsd.h
--- cups-2.2b2/scheduler/cupsd.h.lspp 2016-06-27 17:39:48.064973966 +0200
+++ cups-2.2b2/scheduler/cupsd.h 2016-06-27 17:39:48.078973855 +0200
diff -up cups-2.2.2/scheduler/cupsd.h.lspp cups-2.2.2/scheduler/cupsd.h
--- cups-2.2.2/scheduler/cupsd.h.lspp 2017-01-19 11:34:39.224988714 +0100
+++ cups-2.2.2/scheduler/cupsd.h 2017-01-19 11:34:39.283988194 +0100
@@ -11,6 +11,8 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/
@ -826,11 +826,11 @@ diff -up cups-2.2b2/scheduler/cupsd.h.lspp cups-2.2b2/scheduler/cupsd.h
/*
* Some OS's don't have hstrerror(), most notably Solaris...
*/
diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
--- cups-2.2b2/scheduler/ipp.c.lspp 2016-06-27 17:39:48.028974252 +0200
+++ cups-2.2b2/scheduler/ipp.c 2016-06-27 17:39:48.080973839 +0200
diff -up cups-2.2.2/scheduler/ipp.c.lspp cups-2.2.2/scheduler/ipp.c
--- cups-2.2.2/scheduler/ipp.c.lspp 2017-01-19 11:34:39.190989014 +0100
+++ cups-2.2.2/scheduler/ipp.c 2017-01-19 11:49:37.704922404 +0100
@@ -14,6 +14,9 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
* missing or damaged, see the license at "http://www.cups.org/".
*/
+/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@ -864,7 +864,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
static int check_quotas(cupsd_client_t *con, cupsd_printer_t *p);
static void close_job(cupsd_client_t *con, ipp_attribute_t *uri);
static void copy_attrs(ipp_t *to, ipp_t *from, cups_array_t *ra,
@@ -1248,6 +1262,21 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1265,6 +1279,21 @@ add_job(cupsd_client_t *con, /* I - Cl
"time-at-creation",
"time-at-processing"
};
@ -886,7 +886,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
cupsdLogMessage(CUPSD_LOG_DEBUG2, "add_job(%p[%d], %p(%s), %p(%s/%s))",
@@ -1559,6 +1588,106 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1576,6 +1605,106 @@ add_job(cupsd_client_t *con, /* I - Cl
return (NULL);
}
@ -993,7 +993,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
if ((job = cupsdAddJob(priority, printer->name)) == NULL)
{
send_ipp_status(con, IPP_INTERNAL_ERROR,
@@ -1567,6 +1696,32 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1584,6 +1713,32 @@ add_job(cupsd_client_t *con, /* I - Cl
return (NULL);
}
@ -1026,7 +1026,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
job->dtype = printer->type & (CUPS_PRINTER_CLASS | CUPS_PRINTER_REMOTE);
job->attrs = con->request;
job->dirty = 1;
@@ -1756,6 +1911,29 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1773,6 +1928,29 @@ add_job(cupsd_client_t *con, /* I - Cl
ippSetString(job->attrs, &attr, 0, printer->job_sheets[0]);
ippSetString(job->attrs, &attr, 1, printer->job_sheets[1]);
}
@ -1056,7 +1056,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
job->job_sheets = attr;
@@ -1786,6 +1964,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1803,6 +1981,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-sheets=\"%s,none\", "
"job-originating-user-name=\"%s\"",
Classification, job->username);
@ -1066,7 +1066,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
}
else if (attr->num_values == 2 &&
strcmp(attr->values[0].string.text,
@@ -1804,6 +1985,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1821,6 +2002,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-originating-user-name=\"%s\"",
attr->values[0].string.text,
attr->values[1].string.text, job->username);
@ -1076,7 +1076,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
}
else if (strcmp(attr->values[0].string.text, Classification) &&
strcmp(attr->values[0].string.text, "none") &&
@@ -1824,6 +2008,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1841,6 +2025,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-originating-user-name=\"%s\"",
attr->values[0].string.text,
attr->values[1].string.text, job->username);
@ -1086,7 +1086,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
}
}
else if (strcmp(attr->values[0].string.text, Classification) &&
@@ -1864,8 +2051,52 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1881,8 +2068,52 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-sheets=\"%s\", "
"job-originating-user-name=\"%s\"",
Classification, job->username);
@ -1139,7 +1139,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
/*
* See if we need to add the starting sheet...
@@ -3619,6 +3850,128 @@ check_rss_recipient(
@@ -3659,6 +3890,128 @@ check_rss_recipient(
}
@ -1268,7 +1268,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
/*
* 'check_quotas()' - Check quotas for a printer and user.
*/
@@ -4075,6 +4428,15 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4115,6 +4468,15 @@ copy_banner(cupsd_client_t *con, /* I -
char attrname[255], /* Name of attribute */
*s; /* Pointer into name */
ipp_attribute_t *attr; /* Attribute */
@ -1284,7 +1284,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
cupsdLogMessage(CUPSD_LOG_DEBUG2,
@@ -4110,6 +4472,85 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4150,6 +4512,85 @@ copy_banner(cupsd_client_t *con, /* I -
fchmod(cupsFileNumber(out), 0640);
fchown(cupsFileNumber(out), RunUser, Group);
@ -1370,7 +1370,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
/*
* Try the localized banner file under the subdirectory...
@@ -4204,6 +4645,24 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4244,6 +4685,24 @@ copy_banner(cupsd_client_t *con, /* I -
else
s = attrname;
@ -1395,7 +1395,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
if (!strcmp(s, "printer-name"))
{
cupsFilePuts(out, job->dest);
@@ -6389,6 +6848,22 @@ get_job_attrs(cupsd_client_t *con, /* I
@@ -6429,6 +6888,22 @@ get_job_attrs(cupsd_client_t *con, /* I
exclude = cupsdGetPrivateAttrs(policy, con, printer, job->username);
@ -1418,7 +1418,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
/*
* Copy attributes...
*/
@@ -6786,6 +7261,11 @@ get_jobs(cupsd_client_t *con, /* I - C
@@ -6826,6 +7301,11 @@ get_jobs(cupsd_client_t *con, /* I - C
if (username[0] && _cups_strcasecmp(username, job->username))
continue;
@ -1430,7 +1430,7 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
if (count > 0)
ippAddSeparator(con->response);
@@ -11415,6 +11895,11 @@ validate_user(cupsd_job_t *job, /* I
@@ -11457,6 +11937,11 @@ validate_user(cupsd_job_t *job, /* I
strlcpy(username, get_username(con), userlen);
@ -1442,11 +1442,11 @@ diff -up cups-2.2b2/scheduler/ipp.c.lspp cups-2.2b2/scheduler/ipp.c
/*
* Check the username against the owner...
*/
diff -up cups-2.2b2/scheduler/job.c.lspp cups-2.2b2/scheduler/job.c
--- cups-2.2b2/scheduler/job.c.lspp 2016-06-27 17:39:48.041974149 +0200
+++ cups-2.2b2/scheduler/job.c 2016-06-27 17:39:48.081973831 +0200
diff -up cups-2.2.2/scheduler/job.c.lspp cups-2.2.2/scheduler/job.c
--- cups-2.2.2/scheduler/job.c.lspp 2017-01-19 11:34:39.202988908 +0100
+++ cups-2.2.2/scheduler/job.c 2017-01-19 11:51:43.774763010 +0100
@@ -11,6 +11,9 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
* missing or damaged, see the license at "http://www.cups.org/".
*/
+/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@ -1670,7 +1670,7 @@ diff -up cups-2.2b2/scheduler/job.c.lspp cups-2.2b2/scheduler/job.c
job->attrs->state = IPP_IDLE;
if (ippWriteIO(fp, (ipp_iocb_t)cupsFileWrite, 1, NULL,
@@ -3919,6 +4095,19 @@ get_options(cupsd_job_t *job, /* I - Jo
@@ -3926,6 +4102,19 @@ get_options(cupsd_job_t *job, /* I - Jo
banner_page)
continue;
@ -1690,7 +1690,7 @@ diff -up cups-2.2b2/scheduler/job.c.lspp cups-2.2b2/scheduler/job.c
/*
* Otherwise add them to the list...
*/
@@ -4680,6 +4869,18 @@ start_job(cupsd_job_t *job, /* I -
@@ -4687,6 +4876,18 @@ start_job(cupsd_job_t *job, /* I -
cupsd_printer_t *printer) /* I - Printer to print job */
{
const char *filename; /* Support filename */
@ -1709,7 +1709,7 @@ diff -up cups-2.2b2/scheduler/job.c.lspp cups-2.2b2/scheduler/job.c
ipp_attribute_t *cancel_after = ippFindAttribute(job->attrs,
"job-cancel-after",
IPP_TAG_INTEGER);
@@ -4856,6 +5057,113 @@ start_job(cupsd_job_t *job, /* I -
@@ -4863,6 +5064,113 @@ start_job(cupsd_job_t *job, /* I -
fcntl(job->side_pipes[1], F_SETFD,
fcntl(job->side_pipes[1], F_GETFD) | FD_CLOEXEC);
@ -1823,11 +1823,11 @@ diff -up cups-2.2b2/scheduler/job.c.lspp cups-2.2b2/scheduler/job.c
/*
* Now start the first file in the job...
*/
diff -up cups-2.2b2/scheduler/job.h.lspp cups-2.2b2/scheduler/job.h
--- cups-2.2b2/scheduler/job.h.lspp 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/scheduler/job.h 2016-06-27 17:39:48.081973831 +0200
diff -up cups-2.2.2/scheduler/job.h.lspp cups-2.2.2/scheduler/job.h
--- cups-2.2.2/scheduler/job.h.lspp 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/scheduler/job.h 2017-01-19 11:52:53.997134426 +0100
@@ -11,6 +11,13 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
* missing or damaged, see the license at "http://www.cups.org/".
*/
+/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
@ -1851,9 +1851,9 @@ diff -up cups-2.2b2/scheduler/job.h.lspp cups-2.2b2/scheduler/job.h
};
typedef struct cupsd_joblog_s /**** Job log message ****/
diff -up cups-2.2b2/scheduler/main.c.lspp cups-2.2b2/scheduler/main.c
--- cups-2.2b2/scheduler/main.c.lspp 2016-06-27 17:39:48.064973966 +0200
+++ cups-2.2b2/scheduler/main.c 2016-06-27 17:39:48.081973831 +0200
diff -up cups-2.2.2/scheduler/main.c.lspp cups-2.2.2/scheduler/main.c
--- cups-2.2.2/scheduler/main.c.lspp 2017-01-19 11:34:39.225988705 +0100
+++ cups-2.2.2/scheduler/main.c 2017-01-19 11:34:39.286988168 +0100
@@ -56,6 +56,9 @@
# include <sys/param.h>
#endif /* HAVE_SYS_PARAM_H */
@ -1874,7 +1874,7 @@ diff -up cups-2.2b2/scheduler/main.c.lspp cups-2.2b2/scheduler/main.c
#ifdef __APPLE__
int use_sysman = 1; /* Use system management functions? */
#else
@@ -505,6 +511,25 @@ main(int argc, /* I - Number of comm
@@ -508,6 +514,25 @@ main(int argc, /* I - Number of comm
exit(errno);
}
@ -1900,7 +1900,7 @@ diff -up cups-2.2b2/scheduler/main.c.lspp cups-2.2b2/scheduler/main.c
/*
* Set the timezone info...
*/
@@ -1205,6 +1230,11 @@ main(int argc, /* I - Number of comm
@@ -1201,6 +1226,11 @@ main(int argc, /* I - Number of comm
cupsdStopSelect();
@ -1912,11 +1912,11 @@ diff -up cups-2.2b2/scheduler/main.c.lspp cups-2.2b2/scheduler/main.c
return (!stop_scheduler);
}
diff -up cups-2.2b2/scheduler/printers.c.lspp cups-2.2b2/scheduler/printers.c
--- cups-2.2b2/scheduler/printers.c.lspp 2016-06-27 17:39:48.013974372 +0200
+++ cups-2.2b2/scheduler/printers.c 2016-06-27 17:39:48.082973823 +0200
diff -up cups-2.2.2/scheduler/printers.c.lspp cups-2.2.2/scheduler/printers.c
--- cups-2.2.2/scheduler/printers.c.lspp 2017-01-19 11:34:39.177989128 +0100
+++ cups-2.2.2/scheduler/printers.c 2017-01-19 11:53:39.614723905 +0100
@@ -11,6 +11,8 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
* missing or damaged, see the license at "http://www.cups.org/".
*/
+/* (c) Copyright 2005-2006 Hewlett-Packard Development Company, L.P. */

View File

@ -1,6 +1,6 @@
diff -up cups-2.2b2/scheduler/main.c.systemd-socket cups-2.2b2/scheduler/main.c
--- cups-2.2b2/scheduler/main.c.systemd-socket 2016-06-27 15:12:24.930881404 +0200
+++ cups-2.2b2/scheduler/main.c 2016-06-27 15:19:38.118234985 +0200
diff -up cups-2.2.2/scheduler/main.c.systemd-socket cups-2.2.2/scheduler/main.c
--- cups-2.2.2/scheduler/main.c.systemd-socket 2017-01-19 11:12:42.004520240 +0100
+++ cups-2.2.2/scheduler/main.c 2017-01-19 11:12:42.029520021 +0100
@@ -690,8 +690,15 @@ main(int argc, /* I - Number of comm
#if defined(HAVE_ONDEMAND)
@ -18,11 +18,11 @@ diff -up cups-2.2b2/scheduler/main.c.systemd-socket cups-2.2b2/scheduler/main.c
#endif /* HAVE_ONDEMAND */
if (fg)
cupsdAddEvent(CUPSD_EVENT_SERVER_STARTED, NULL, NULL, "Scheduler started in foreground.");
diff -up cups-2.2b2/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.2b2/scheduler/org.cups.cupsd.path.in
--- cups-2.2b2/scheduler/org.cups.cupsd.path.in.systemd-socket 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/scheduler/org.cups.cupsd.path.in 2016-06-27 15:12:24.930881404 +0200
@@ -2,7 +2,7 @@
Description=CUPS Scheduler
diff -up cups-2.2.2/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.2.2/scheduler/org.cups.cupsd.path.in
--- cups-2.2.2/scheduler/org.cups.cupsd.path.in.systemd-socket 2017-01-19 11:12:42.029520021 +0100
+++ cups-2.2.2/scheduler/org.cups.cupsd.path.in 2017-01-19 11:19:34.468933097 +0100
@@ -3,7 +3,7 @@ Description=CUPS Scheduler
PartOf=org.cups.cupsd.service
[Path]
-PathExists=@CUPS_CACHEDIR@/org.cups.cupsd
@ -30,9 +30,9 @@ diff -up cups-2.2b2/scheduler/org.cups.cupsd.path.in.systemd-socket cups-2.2b2/s
[Install]
WantedBy=multi-user.target
diff -up cups-2.2b2/scheduler/org.cups.cupsd.service.in.systemd-socket cups-2.2b2/scheduler/org.cups.cupsd.service.in
--- cups-2.2b2/scheduler/org.cups.cupsd.service.in.systemd-socket 2016-06-24 17:43:35.000000000 +0200
+++ cups-2.2b2/scheduler/org.cups.cupsd.service.in 2016-06-27 15:12:24.930881404 +0200
diff -up cups-2.2.2/scheduler/org.cups.cupsd.service.in.systemd-socket cups-2.2.2/scheduler/org.cups.cupsd.service.in
--- cups-2.2.2/scheduler/org.cups.cupsd.service.in.systemd-socket 2017-01-17 20:27:22.000000000 +0100
+++ cups-2.2.2/scheduler/org.cups.cupsd.service.in 2017-01-19 11:12:42.029520021 +0100
@@ -1,10 +1,11 @@
[Unit]
Description=CUPS Scheduler

View File

@ -7,15 +7,15 @@
# but we use lib for compatibility with 3rd party drivers (at upstream request).
%global cups_serverbin %{_exec_prefix}/lib/cups
%global prever rc1
#%%global prever rc1
#%%global VERSION %%{version}%%{prever}
%global VERSION %{version}
Summary: CUPS printing system
Name: cups
Epoch: 1
Version: 2.2.1
Release: 4%{?dist}
Version: 2.2.2
Release: 1%{?dist}
License: GPLv2
Url: http://www.cups.org/
Source0: https://github.com/apple/cups/releases/download/v%{VERSION}/cups-%{VERSION}-source.tar.gz
@ -62,7 +62,6 @@ Patch34: cups-avahi-no-threaded.patch
Patch35: cups-ipp-multifile.patch
Patch36: cups-web-devices-timeout.patch
Patch37: cups-synconclose.patch
Patch38: cups-iso88591.patch
Patch100: cups-lspp.patch
@ -256,9 +255,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
%patch36 -p1 -b .web-devices-timeout
# Set the default for SyncOnClose to Yes.
%patch37 -p1 -b .synconclose
# Unable to print from Windows (7) on a Cups-Server(2.2.1-1) with german umlauts in the filename (bug #1386751)
%patch38 -p1 -b .iso88591
%if %{lspp}
# LSPP support.
@ -624,6 +620,9 @@ rm -f %{cups_serverbin}/backend/smb
%{_mandir}/man5/ipptoolfile.5.gz
%changelog
* Thu Jan 19 2017 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.2.2-1
- rebase to 2.2.2
* Wed Jan 11 2017 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.2.1-4
- bug 1405669 - adding group wheel to SystemGroup

View File

@ -1 +1 @@
a94da2a1e9dbdccb4f3836a38a431931 cups-2.2.1-source.tar.gz
SHA512 (cups-2.2.2-source.tar.gz) = c78156eddfbae5b5ac9963082763f2a8e0e297cc93fce9e12707ba3606164dc674f127819db972b00699587628ec35002da206691fed2e03578912c613150eac