This commit is contained in:
Jiri Popelka 2015-06-09 17:56:57 +02:00
parent 746dd9cf56
commit 78f67073ef
7 changed files with 94 additions and 118 deletions

1
.gitignore vendored
View File

@ -66,3 +66,4 @@ cups-1.4.4-source.tar.bz2
/cups-2.0.0-source.tar.bz2
/cups-2.0.1-source.tar.bz2
/cups-2.0.2-source.tar.bz2
/cups-2.0.3-source.tar.bz2

Binary file not shown.

Binary file not shown.

View File

@ -1,34 +0,0 @@
diff -up cups-2.0.2/scheduler/client.c.busy-loop cups-2.0.2/scheduler/client.c
--- cups-2.0.2/scheduler/client.c.busy-loop 2014-08-28 16:37:22.000000000 +0100
+++ cups-2.0.2/scheduler/client.c 2015-03-16 17:24:32.506232983 +0000
@@ -585,6 +585,17 @@ cupsdReadClient(cupsd_client_t *con) /*
* connection and we need to shut it down...
*/
+ if (!httpGetReady(con->http) && recv(httpGetFd(con->http), buf, 1, MSG_PEEK) < 1)
+ {
+ /*
+ * Connection closed...
+ */
+
+ cupsdLogClient(con, CUPSD_LOG_DEBUG, "Closing on EOF.");
+ cupsdCloseClient(con);
+ return;
+ }
+
cupsdLogClient(con, CUPSD_LOG_DEBUG, "Closing on unexpected HTTP read state %s.",
httpStateString(httpGetState(con->http)));
cupsdCloseClient(con);
@@ -1979,12 +1990,6 @@ cupsdReadClient(cupsd_client_t *con) /*
if (httpGetState(con->http) == HTTP_STATE_POST_SEND)
{
- /*
- * Don't listen for activity until we decide to do something with this...
- */
-
- cupsdAddSelect(httpGetFd(con->http), NULL, NULL, con);
-
if (con->file >= 0)
{
fstat(con->file, &filestats);

View File

@ -1,7 +1,7 @@
diff -up cups-2.0.1/config.h.in.lspp cups-2.0.1/config.h.in
--- cups-2.0.1/config.h.in.lspp 2014-08-30 03:51:22.000000000 +0200
+++ cups-2.0.1/config.h.in 2014-11-15 15:22:47.838306259 +0100
@@ -709,6 +709,13 @@ static __inline int _cups_abs(int i) { r
diff -up cups-2.0.3/config.h.in.lspp cups-2.0.3/config.h.in
--- cups-2.0.3/config.h.in.lspp 2014-12-09 21:50:51.000000000 +0100
+++ cups-2.0.3/config.h.in 2015-06-09 17:38:42.803451529 +0200
@@ -716,6 +716,13 @@ static __inline int _cups_abs(int i) { r
# endif /* __GNUC__ || __STDC_VERSION__ */
#endif /* !HAVE_ABS && !abs */
@ -15,9 +15,9 @@ diff -up cups-2.0.1/config.h.in.lspp cups-2.0.1/config.h.in
#endif /* !_CUPS_CONFIG_H_ */
/*
diff -up cups-2.0.1/config-scripts/cups-lspp.m4.lspp cups-2.0.1/config-scripts/cups-lspp.m4
--- cups-2.0.1/config-scripts/cups-lspp.m4.lspp 2014-11-15 15:22:47.838306259 +0100
+++ cups-2.0.1/config-scripts/cups-lspp.m4 2014-11-15 15:22:47.838306259 +0100
diff -up cups-2.0.3/config-scripts/cups-lspp.m4.lspp cups-2.0.3/config-scripts/cups-lspp.m4
--- cups-2.0.3/config-scripts/cups-lspp.m4.lspp 2015-06-09 17:38:42.803451529 +0200
+++ cups-2.0.3/config-scripts/cups-lspp.m4 2015-06-09 17:38:42.803451529 +0200
@@ -0,0 +1,36 @@
+dnl
+dnl LSPP code for the Common UNIX Printing System (CUPS).
@ -55,9 +55,9 @@ diff -up cups-2.0.1/config-scripts/cups-lspp.m4.lspp cups-2.0.1/config-scripts/c
+ ;;
+ esac
+fi
diff -up cups-2.0.1/configure.ac.lspp cups-2.0.1/configure.ac
--- cups-2.0.1/configure.ac.lspp 2014-10-21 13:55:01.000000000 +0200
+++ cups-2.0.1/configure.ac 2014-11-15 15:22:47.838306259 +0100
diff -up cups-2.0.3/configure.ac.lspp cups-2.0.3/configure.ac
--- cups-2.0.3/configure.ac.lspp 2014-10-21 13:55:01.000000000 +0200
+++ cups-2.0.3/configure.ac 2015-06-09 17:38:42.803451529 +0200
@@ -36,6 +36,8 @@ sinclude(config-scripts/cups-startup.m4)
sinclude(config-scripts/cups-defaults.m4)
sinclude(config-scripts/cups-scripting.m4)
@ -67,9 +67,9 @@ diff -up cups-2.0.1/configure.ac.lspp cups-2.0.1/configure.ac
INSTALL_LANGUAGES=""
UNINSTALL_LANGUAGES=""
LANGFILES=""
diff -up cups-2.0.1/filter/common.c.lspp cups-2.0.1/filter/common.c
--- cups-2.0.1/filter/common.c.lspp 2014-02-06 19:33:34.000000000 +0100
+++ cups-2.0.1/filter/common.c 2014-11-15 15:22:47.838306259 +0100
diff -up cups-2.0.3/filter/common.c.lspp cups-2.0.3/filter/common.c
--- cups-2.0.3/filter/common.c.lspp 2014-02-06 19:33:34.000000000 +0100
+++ cups-2.0.3/filter/common.c 2015-06-09 17:38:42.804451526 +0200
@@ -19,6 +19,12 @@
* Include necessary headers...
*/
@ -238,10 +238,10 @@ diff -up cups-2.0.1/filter/common.c.lspp cups-2.0.1/filter/common.c
/*
diff -up cups-2.0.1/filter/pstops.c.lspp cups-2.0.1/filter/pstops.c
--- cups-2.0.1/filter/pstops.c.lspp 2014-02-06 19:33:34.000000000 +0100
+++ cups-2.0.1/filter/pstops.c 2014-11-15 15:22:47.839306246 +0100
@@ -3173,6 +3173,18 @@ write_label_prolog(pstops_doc_t *doc, /*
diff -up cups-2.0.3/filter/pstops.c.lspp cups-2.0.3/filter/pstops.c
--- cups-2.0.3/filter/pstops.c.lspp 2015-05-22 19:27:37.000000000 +0200
+++ cups-2.0.3/filter/pstops.c 2015-06-09 17:38:42.804451526 +0200
@@ -3178,6 +3178,18 @@ write_label_prolog(pstops_doc_t *doc, /*
{
const char *classification; /* CLASSIFICATION environment variable */
const char *ptr; /* Temporary string pointer */
@ -260,7 +260,7 @@ diff -up cups-2.0.1/filter/pstops.c.lspp cups-2.0.1/filter/pstops.c
/*
@@ -3195,6 +3207,124 @@ write_label_prolog(pstops_doc_t *doc, /*
@@ -3200,6 +3212,124 @@ write_label_prolog(pstops_doc_t *doc, /*
return;
}
@ -385,7 +385,7 @@ diff -up cups-2.0.1/filter/pstops.c.lspp cups-2.0.1/filter/pstops.c
/*
* Set the classification + page label string...
*/
@@ -3273,7 +3403,10 @@ write_label_prolog(pstops_doc_t *doc, /*
@@ -3278,7 +3408,10 @@ write_label_prolog(pstops_doc_t *doc, /*
doc_printf(doc, " %.0f moveto ESPpl show\n", top - 14.0);
doc_puts(doc, "pop\n");
doc_puts(doc, "}bind put\n");
@ -396,9 +396,9 @@ diff -up cups-2.0.1/filter/pstops.c.lspp cups-2.0.1/filter/pstops.c
/*
diff -up cups-2.0.1/Makedefs.in.lspp cups-2.0.1/Makedefs.in
--- cups-2.0.1/Makedefs.in.lspp 2014-11-15 15:22:47.766307192 +0100
+++ cups-2.0.1/Makedefs.in 2014-11-15 15:22:47.840306233 +0100
diff -up cups-2.0.3/Makedefs.in.lspp cups-2.0.3/Makedefs.in
--- cups-2.0.3/Makedefs.in.lspp 2015-06-09 17:38:42.762451666 +0200
+++ cups-2.0.3/Makedefs.in 2015-06-09 17:38:42.804451526 +0200
@@ -145,7 +145,7 @@ LDFLAGS = -L../cgi-bin -L../cups -L../f
@LDFLAGS@ @RELROFLAGS@ @PIEFLAGS@ $(OPTIM)
LINKCUPS = @LINKCUPS@ $(LIBGSSAPI) $(DNSSDLIBS) $(LIBZ)
@ -408,9 +408,9 @@ diff -up cups-2.0.1/Makedefs.in.lspp cups-2.0.1/Makedefs.in
ONDEMANDFLAGS = @ONDEMANDFLAGS@
ONDEMANDLIBS = @ONDEMANDLIBS@
OPTIM = @OPTIM@
diff -up cups-2.0.1/scheduler/client.c.lspp cups-2.0.1/scheduler/client.c
--- cups-2.0.1/scheduler/client.c.lspp 2014-08-28 17:37:22.000000000 +0200
+++ cups-2.0.1/scheduler/client.c 2014-11-15 15:22:47.842306207 +0100
diff -up cups-2.0.3/scheduler/client.c.lspp cups-2.0.3/scheduler/client.c
--- cups-2.0.3/scheduler/client.c.lspp 2015-06-08 20:33:44.000000000 +0200
+++ cups-2.0.3/scheduler/client.c 2015-06-09 17:38:42.806451519 +0200
@@ -24,12 +24,20 @@
#define _HTTP_NO_PRIVATE
#include "cupsd.h"
@ -492,7 +492,7 @@ diff -up cups-2.0.1/scheduler/client.c.lspp cups-2.0.1/scheduler/client.c
#ifdef AF_LOCAL
if (httpAddrFamily(httpGetAddress(con->http)) == AF_LOCAL)
{
@@ -555,6 +616,13 @@ cupsdReadClient(cupsd_client_t *con) /*
@@ -560,6 +621,13 @@ cupsdReadClient(cupsd_client_t *con) /*
mime_type_t *type; /* MIME type of file */
cupsd_printer_t *p; /* Printer */
static unsigned request_id = 0; /* Request ID for temp files */
@ -506,7 +506,7 @@ diff -up cups-2.0.1/scheduler/client.c.lspp cups-2.0.1/scheduler/client.c
status = HTTP_STATUS_CONTINUE;
@@ -1923,6 +1991,73 @@ cupsdReadClient(cupsd_client_t *con) /*
@@ -1939,6 +2007,73 @@ cupsdReadClient(cupsd_client_t *con) /*
fcntl(con->file, F_SETFD, fcntl(con->file, F_GETFD) | FD_CLOEXEC);
}
@ -580,7 +580,7 @@ diff -up cups-2.0.1/scheduler/client.c.lspp cups-2.0.1/scheduler/client.c
if (httpGetState(con->http) != HTTP_STATE_POST_SEND)
{
if (!httpWait(con->http, 0))
@@ -3423,6 +3558,49 @@ is_path_absolute(const char *path) /* I
@@ -3433,6 +3568,49 @@ is_path_absolute(const char *path) /* I
return (1);
}
@ -630,9 +630,9 @@ diff -up cups-2.0.1/scheduler/client.c.lspp cups-2.0.1/scheduler/client.c
/*
* 'pipe_command()' - Pipe the output of a command to the remote client.
diff -up cups-2.0.1/scheduler/client.h.lspp cups-2.0.1/scheduler/client.h
--- cups-2.0.1/scheduler/client.h.lspp 2014-03-21 17:42:53.000000000 +0100
+++ cups-2.0.1/scheduler/client.h 2014-11-15 15:22:47.842306207 +0100
diff -up cups-2.0.3/scheduler/client.h.lspp cups-2.0.3/scheduler/client.h
--- cups-2.0.3/scheduler/client.h.lspp 2014-03-21 17:42:53.000000000 +0100
+++ cups-2.0.3/scheduler/client.h 2015-06-09 17:38:42.806451519 +0200
@@ -18,6 +18,13 @@
#endif /* HAVE_AUTHORIZATION_H */
@ -668,9 +668,9 @@ diff -up cups-2.0.1/scheduler/client.h.lspp cups-2.0.1/scheduler/client.h
#ifdef HAVE_SSL
extern int cupsdEndTLS(cupsd_client_t *con);
diff -up cups-2.0.1/scheduler/conf.c.lspp cups-2.0.1/scheduler/conf.c
--- cups-2.0.1/scheduler/conf.c.lspp 2014-11-15 15:22:47.832306336 +0100
+++ cups-2.0.1/scheduler/conf.c 2014-11-15 15:22:47.844306181 +0100
diff -up cups-2.0.3/scheduler/conf.c.lspp cups-2.0.3/scheduler/conf.c
--- cups-2.0.3/scheduler/conf.c.lspp 2015-06-09 17:38:42.802451532 +0200
+++ cups-2.0.3/scheduler/conf.c 2015-06-09 17:38:42.807451516 +0200
@@ -36,6 +36,9 @@
# define INADDR_NONE 0xffffffff
#endif /* !INADDR_NONE */
@ -748,7 +748,7 @@ diff -up cups-2.0.1/scheduler/conf.c.lspp cups-2.0.1/scheduler/conf.c
/*
* Check the MaxClients setting, and then allocate memory for it...
@@ -3700,6 +3741,18 @@ read_location(cups_file_t *fp, /* I - C
@@ -3702,6 +3743,18 @@ read_location(cups_file_t *fp, /* I - C
return ((FatalErrors & CUPSD_FATAL_CONFIG) ? 0 : linenum);
}
@ -767,9 +767,9 @@ diff -up cups-2.0.1/scheduler/conf.c.lspp cups-2.0.1/scheduler/conf.c
/*
* 'read_policy()' - Read a <Policy name> definition.
diff -up cups-2.0.1/scheduler/conf.h.lspp cups-2.0.1/scheduler/conf.h
--- cups-2.0.1/scheduler/conf.h.lspp 2014-11-15 15:22:47.825306427 +0100
+++ cups-2.0.1/scheduler/conf.h 2014-11-15 15:22:47.845306168 +0100
diff -up cups-2.0.3/scheduler/conf.h.lspp cups-2.0.3/scheduler/conf.h
--- cups-2.0.3/scheduler/conf.h.lspp 2015-06-09 17:38:42.799451542 +0200
+++ cups-2.0.3/scheduler/conf.h 2015-06-09 17:38:42.807451516 +0200
@@ -248,6 +248,13 @@ VAR char *ServerKeychain VALUE(NULL);
/* Keychain holding cert + key */
#endif /* HAVE_SSL */
@ -794,9 +794,9 @@ diff -up cups-2.0.1/scheduler/conf.h.lspp cups-2.0.1/scheduler/conf.h
/*
* Prototypes...
diff -up cups-2.0.1/scheduler/cupsd.h.lspp cups-2.0.1/scheduler/cupsd.h
--- cups-2.0.1/scheduler/cupsd.h.lspp 2014-11-15 15:22:47.805306686 +0100
+++ cups-2.0.1/scheduler/cupsd.h 2014-11-15 15:22:47.846306155 +0100
diff -up cups-2.0.3/scheduler/cupsd.h.lspp cups-2.0.3/scheduler/cupsd.h
--- cups-2.0.3/scheduler/cupsd.h.lspp 2015-06-09 17:38:42.791451569 +0200
+++ cups-2.0.3/scheduler/cupsd.h 2015-06-09 17:38:42.807451516 +0200
@@ -13,6 +13,8 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/
@ -828,9 +828,9 @@ diff -up cups-2.0.1/scheduler/cupsd.h.lspp cups-2.0.1/scheduler/cupsd.h
/*
* Some OS's don't have hstrerror(), most notably Solaris...
*/
diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
--- cups-2.0.1/scheduler/ipp.c.lspp 2014-11-15 15:22:47.739307542 +0100
+++ cups-2.0.1/scheduler/ipp.c 2014-11-15 15:22:47.851306090 +0100
diff -up cups-2.0.3/scheduler/ipp.c.lspp cups-2.0.3/scheduler/ipp.c
--- cups-2.0.3/scheduler/ipp.c.lspp 2015-06-09 17:38:42.740451739 +0200
+++ cups-2.0.3/scheduler/ipp.c 2015-06-09 17:41:48.818829874 +0200
@@ -16,6 +16,9 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/
@ -866,7 +866,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
static int check_quotas(cupsd_client_t *con, cupsd_printer_t *p);
static void close_job(cupsd_client_t *con, ipp_attribute_t *uri);
static void copy_attrs(ipp_t *to, ipp_t *from, cups_array_t *ra,
@@ -1215,6 +1229,21 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1214,6 +1228,21 @@ add_job(cupsd_client_t *con, /* I - Cl
"time-at-creation",
"time-at-processing"
};
@ -888,7 +888,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
cupsdLogMessage(CUPSD_LOG_DEBUG2, "add_job(%p[%d], %p(%s), %p(%s/%s))",
@@ -1531,6 +1560,106 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1530,6 +1559,106 @@ add_job(cupsd_client_t *con, /* I - Cl
return (NULL);
}
@ -995,7 +995,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
if ((job = cupsdAddJob(priority, printer->name)) == NULL)
{
send_ipp_status(con, IPP_INTERNAL_ERROR,
@@ -1539,6 +1668,32 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1538,6 +1667,32 @@ add_job(cupsd_client_t *con, /* I - Cl
return (NULL);
}
@ -1028,9 +1028,9 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
job->dtype = printer->type & (CUPS_PRINTER_CLASS | CUPS_PRINTER_REMOTE);
job->attrs = con->request;
job->dirty = 1;
@@ -1750,6 +1905,29 @@ add_job(cupsd_client_t *con, /* I - Cl
attr->values[0].string.text = _cupsStrRetain(printer->job_sheets[0]);
attr->values[1].string.text = _cupsStrRetain(printer->job_sheets[1]);
@@ -1711,6 +1866,29 @@ add_job(cupsd_client_t *con, /* I - Cl
ippSetString(job->attrs, &attr, 0, printer->job_sheets[0]);
ippSetString(job->attrs, &attr, 1, printer->job_sheets[1]);
}
+#ifdef WITH_LSPP
+ else
@ -1042,7 +1042,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
+
+ if (attr->num_values > 1)
+ userfooter = strdup(attr->values[1].string.text);
+
+
+ if (Classification != NULL && (strcmp(userheader, Classification) == 0)
+ && userfooter &&(strcmp(userfooter, Classification) == 0))
+ {
@ -1058,7 +1058,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
job->job_sheets = attr;
@@ -1780,6 +1958,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1741,6 +1919,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-sheets=\"%s,none\", "
"job-originating-user-name=\"%s\"",
Classification, job->username);
@ -1068,7 +1068,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
}
else if (attr->num_values == 2 &&
strcmp(attr->values[0].string.text,
@@ -1798,6 +1979,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1759,6 +1940,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-originating-user-name=\"%s\"",
attr->values[0].string.text,
attr->values[1].string.text, job->username);
@ -1078,7 +1078,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
}
else if (strcmp(attr->values[0].string.text, Classification) &&
strcmp(attr->values[0].string.text, "none") &&
@@ -1818,6 +2002,9 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1779,6 +1963,9 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-originating-user-name=\"%s\"",
attr->values[0].string.text,
attr->values[1].string.text, job->username);
@ -1088,7 +1088,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
}
}
else if (strcmp(attr->values[0].string.text, Classification) &&
@@ -1858,8 +2045,52 @@ add_job(cupsd_client_t *con, /* I - Cl
@@ -1819,8 +2006,52 @@ add_job(cupsd_client_t *con, /* I - Cl
"job-sheets=\"%s\", "
"job-originating-user-name=\"%s\"",
Classification, job->username);
@ -1141,7 +1141,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
/*
* See if we need to add the starting sheet...
@@ -3630,6 +3861,128 @@ check_rss_recipient(
@@ -3591,6 +3822,128 @@ check_rss_recipient(
}
@ -1270,7 +1270,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
/*
* 'check_quotas()' - Check quotas for a printer and user.
*/
@@ -4086,6 +4439,15 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4047,6 +4400,15 @@ copy_banner(cupsd_client_t *con, /* I -
char attrname[255], /* Name of attribute */
*s; /* Pointer into name */
ipp_attribute_t *attr; /* Attribute */
@ -1286,7 +1286,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
cupsdLogMessage(CUPSD_LOG_DEBUG2,
@@ -4121,6 +4483,85 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4082,6 +4444,85 @@ copy_banner(cupsd_client_t *con, /* I -
fchmod(cupsFileNumber(out), 0640);
fchown(cupsFileNumber(out), RunUser, Group);
@ -1372,7 +1372,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
/*
* Try the localized banner file under the subdirectory...
@@ -4215,6 +4656,24 @@ copy_banner(cupsd_client_t *con, /* I -
@@ -4176,6 +4617,24 @@ copy_banner(cupsd_client_t *con, /* I -
else
s = attrname;
@ -1397,7 +1397,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
if (!strcmp(s, "printer-name"))
{
cupsFilePuts(out, job->dest);
@@ -6125,6 +6584,22 @@ get_job_attrs(cupsd_client_t *con, /* I
@@ -6086,6 +6545,22 @@ get_job_attrs(cupsd_client_t *con, /* I
exclude = cupsdGetPrivateAttrs(policy, con, printer, job->username);
@ -1420,7 +1420,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
/*
* Copy attributes...
*/
@@ -6524,6 +6999,11 @@ get_jobs(cupsd_client_t *con, /* I - C
@@ -6485,6 +6960,11 @@ get_jobs(cupsd_client_t *con, /* I - C
if (username[0] && _cups_strcasecmp(username, job->username))
continue;
@ -1432,7 +1432,7 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
if (count > 0)
ippAddSeparator(con->response);
@@ -11093,6 +11573,11 @@ validate_user(cupsd_job_t *job, /* I
@@ -11044,6 +11524,11 @@ validate_user(cupsd_job_t *job, /* I
strlcpy(username, get_username(con), userlen);
@ -1444,9 +1444,9 @@ diff -up cups-2.0.1/scheduler/ipp.c.lspp cups-2.0.1/scheduler/ipp.c
/*
* Check the username against the owner...
*/
diff -up cups-2.0.1/scheduler/job.c.lspp cups-2.0.1/scheduler/job.c
--- cups-2.0.1/scheduler/job.c.lspp 2014-11-15 15:22:47.755307335 +0100
+++ cups-2.0.1/scheduler/job.c 2014-11-15 15:22:47.855306038 +0100
diff -up cups-2.0.3/scheduler/job.c.lspp cups-2.0.3/scheduler/job.c
--- cups-2.0.3/scheduler/job.c.lspp 2015-06-09 17:38:42.757451683 +0200
+++ cups-2.0.3/scheduler/job.c 2015-06-09 17:38:42.810451506 +0200
@@ -13,6 +13,9 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/
@ -1692,7 +1692,7 @@ diff -up cups-2.0.1/scheduler/job.c.lspp cups-2.0.1/scheduler/job.c
/*
* Otherwise add them to the list...
*/
@@ -4601,6 +4790,18 @@ start_job(cupsd_job_t *job, /* I -
@@ -4596,6 +4785,18 @@ start_job(cupsd_job_t *job, /* I -
cupsd_printer_t *printer) /* I - Printer to print job */
{
const char *filename; /* Support filename */
@ -1711,7 +1711,7 @@ diff -up cups-2.0.1/scheduler/job.c.lspp cups-2.0.1/scheduler/job.c
ipp_attribute_t *cancel_after = ippFindAttribute(job->attrs,
"job-cancel-after",
IPP_TAG_INTEGER);
@@ -4777,6 +4978,113 @@ start_job(cupsd_job_t *job, /* I -
@@ -4772,6 +4973,113 @@ start_job(cupsd_job_t *job, /* I -
fcntl(job->side_pipes[1], F_SETFD,
fcntl(job->side_pipes[1], F_GETFD) | FD_CLOEXEC);
@ -1825,9 +1825,9 @@ diff -up cups-2.0.1/scheduler/job.c.lspp cups-2.0.1/scheduler/job.c
/*
* Now start the first file in the job...
*/
diff -up cups-2.0.1/scheduler/job.h.lspp cups-2.0.1/scheduler/job.h
--- cups-2.0.1/scheduler/job.h.lspp 2014-07-31 02:02:30.000000000 +0200
+++ cups-2.0.1/scheduler/job.h 2014-11-15 15:22:47.856306025 +0100
diff -up cups-2.0.3/scheduler/job.h.lspp cups-2.0.3/scheduler/job.h
--- cups-2.0.3/scheduler/job.h.lspp 2014-07-31 02:02:30.000000000 +0200
+++ cups-2.0.3/scheduler/job.h 2015-06-09 17:38:42.810451506 +0200
@@ -13,6 +13,13 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/
@ -1853,9 +1853,9 @@ diff -up cups-2.0.1/scheduler/job.h.lspp cups-2.0.1/scheduler/job.h
};
typedef struct cupsd_joblog_s /**** Job log message ****/
diff -up cups-2.0.1/scheduler/main.c.lspp cups-2.0.1/scheduler/main.c
--- cups-2.0.1/scheduler/main.c.lspp 2014-11-15 15:22:47.808306648 +0100
+++ cups-2.0.1/scheduler/main.c 2014-11-15 15:27:00.487987203 +0100
diff -up cups-2.0.3/scheduler/main.c.lspp cups-2.0.3/scheduler/main.c
--- cups-2.0.3/scheduler/main.c.lspp 2015-06-09 17:38:42.792451566 +0200
+++ cups-2.0.3/scheduler/main.c 2015-06-09 17:38:42.810451506 +0200
@@ -56,6 +56,9 @@ extern int launch_activate_socket(const
# include <sys/param.h>
#endif /* HAVE_SYS_PARAM_H */
@ -1902,7 +1902,7 @@ diff -up cups-2.0.1/scheduler/main.c.lspp cups-2.0.1/scheduler/main.c
/*
* Set the timezone info...
*/
@@ -1160,6 +1185,11 @@ main(int argc, /* I - Number of comm
@@ -1161,6 +1186,11 @@ main(int argc, /* I - Number of comm
cupsdStopSelect();
@ -1914,9 +1914,9 @@ diff -up cups-2.0.1/scheduler/main.c.lspp cups-2.0.1/scheduler/main.c
return (!stop_scheduler);
}
diff -up cups-2.0.1/scheduler/printers.c.lspp cups-2.0.1/scheduler/printers.c
--- cups-2.0.1/scheduler/printers.c.lspp 2014-11-15 15:22:47.716307840 +0100
+++ cups-2.0.1/scheduler/printers.c 2014-11-15 15:22:47.860305973 +0100
diff -up cups-2.0.3/scheduler/printers.c.lspp cups-2.0.3/scheduler/printers.c
--- cups-2.0.3/scheduler/printers.c.lspp 2015-06-09 17:38:42.727451783 +0200
+++ cups-2.0.3/scheduler/printers.c 2015-06-09 17:38:42.811451502 +0200
@@ -13,6 +13,8 @@
* file is missing or damaged, see the license at "http://www.cups.org/".
*/

View File

@ -10,8 +10,8 @@
Summary: CUPS printing system
Name: cups
Epoch: 1
Version: 2.0.2
Release: 5%{?dist}
Version: 2.0.3
Release: 1%{?dist}
License: GPLv2
Url: http://www.cups.org/
Source0: http://www.cups.org/software/%{version}/cups-%{version}-source.tar.bz2
@ -26,7 +26,7 @@ Source8: macros.cups
Patch1: cups-no-gzip-man.patch
Patch2: cups-system-auth.patch
Patch3: cups-multilib.patch
Patch4: cups-busy-loop.patch
Patch5: cups-banners.patch
Patch6: cups-serverbin-compat.patch
Patch7: cups-no-export-ssllibs.patch
@ -190,9 +190,7 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
%patch2 -p1 -b .system-auth
# Prevent multilib conflict in cups-config script.
%patch3 -p1 -b .multilib
# Avoid busy loop in cupsd when connection is closed after request
# sent (bug #1179596).
%patch4 -p1 -b .busy-loop
# Ignore rpm save/new files in the banners directory.
%patch5 -p1 -b .banners
# Use compatibility fallback path for ServerBin.
@ -500,15 +498,19 @@ rm -f %{cups_serverbin}/backend/smb
%config(noreplace) %{_sysconfdir}/pam.d/cups
%config(noreplace) %{_sysconfdir}/logrotate.d/cups
%dir %{_datadir}/%{name}/www
%dir %{_datadir}/%{name}/www/de
%dir %{_datadir}/%{name}/www/es
%dir %{_datadir}/%{name}/www/ja
%dir %{_datadir}/%{name}/www/ru
%{_datadir}/%{name}/www/images
%{_datadir}/%{name}/www/*.css
%doc %{_datadir}/%{name}/www/index.html
%doc %{_datadir}/%{name}/www/help
%doc %{_datadir}/%{name}/www/robots.txt
%doc %{_datadir}/%{name}/www/de/index.html
%doc %{_datadir}/%{name}/www/es/index.html
%doc %{_datadir}/%{name}/www/ja/index.html
%doc %{_datadir}/%{name}/www/ru/index.html
%doc %{_datadir}/%{name}/www/apple-touch-icon.png
%dir %{_datadir}/%{name}/usb
%{_datadir}/%{name}/usb/org.cups.usb-quirks
@ -543,11 +545,15 @@ rm -f %{cups_serverbin}/backend/smb
# client subpackage
%exclude %{_sbindir}/lpc.cups
%dir %{_datadir}/cups/templates
%dir %{_datadir}/cups/templates/de
%dir %{_datadir}/cups/templates/es
%dir %{_datadir}/cups/templates/ja
%dir %{_datadir}/cups/templates/ru
%{_datadir}/cups/templates/*.tmpl
%{_datadir}/cups/templates/de/*.tmpl
%{_datadir}/cups/templates/es/*.tmpl
%{_datadir}/cups/templates/ja/*.tmpl
%{_datadir}/cups/templates/ru/*.tmpl
%dir %attr(1770,root,lp) %{_localstatedir}/spool/cups/tmp
%dir %attr(0710,root,lp) %{_localstatedir}/spool/cups
%dir %attr(0755,lp,sys) %{_localstatedir}/log/cups
@ -609,6 +615,9 @@ rm -f %{cups_serverbin}/backend/smb
%{_mandir}/man5/ipptoolfile.5.gz
%changelog
* Tue Jun 09 2015 Jiri Popelka <jpopelka@redhat.com> - 1:2.0.3-1
- 2.0.3
* Mon Mar 16 2015 Tim Waugh <twaugh@redhat.com> - 1:2.0.2-5
- Avoid busy loop in cupsd when connection is closed after request
sent (bug #1179596).

View File

@ -1 +1 @@
6e0ea72dbafcf5baaa1cf4178e71096d cups-2.0.2-source.tar.bz2
8d98b85edbdab7ab03739c9622f570e8 cups-2.0.3-source.tar.bz2