fix lspp.patch to not include "config.h" in cups/cups.h (#709384)
This commit is contained in:
parent
6152e4bf54
commit
770e272bad
201
cups-lspp.patch
201
cups-lspp.patch
@ -1,6 +1,6 @@
|
||||
diff -up cups-1.5b1/config.h.in.lspp cups-1.5b1/config.h.in
|
||||
--- cups-1.5b1/config.h.in.lspp 2011-05-20 05:49:49.000000000 +0200
|
||||
+++ cups-1.5b1/config.h.in 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/config.h.in.lspp cups-1.5b2/config.h.in
|
||||
--- cups-1.5b2/config.h.in.lspp 2011-05-20 05:49:49.000000000 +0200
|
||||
+++ cups-1.5b2/config.h.in 2011-05-31 17:17:46.861328762 +0200
|
||||
@@ -733,6 +733,12 @@
|
||||
|
||||
#undef HAVE_XPC
|
||||
@ -14,9 +14,9 @@ diff -up cups-1.5b1/config.h.in.lspp cups-1.5b1/config.h.in
|
||||
|
||||
#endif /* !_CUPS_CONFIG_H_ */
|
||||
|
||||
diff -up cups-1.5b1/config-scripts/cups-lspp.m4.lspp cups-1.5b1/config-scripts/cups-lspp.m4
|
||||
--- cups-1.5b1/config-scripts/cups-lspp.m4.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/config-scripts/cups-lspp.m4 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/config-scripts/cups-lspp.m4.lspp cups-1.5b2/config-scripts/cups-lspp.m4
|
||||
--- cups-1.5b2/config-scripts/cups-lspp.m4.lspp 2011-05-31 17:17:46.861328762 +0200
|
||||
+++ cups-1.5b2/config-scripts/cups-lspp.m4 2011-05-31 17:17:46.861328762 +0200
|
||||
@@ -0,0 +1,36 @@
|
||||
+dnl
|
||||
+dnl LSPP code for the Common UNIX Printing System (CUPS).
|
||||
@ -54,9 +54,9 @@ diff -up cups-1.5b1/config-scripts/cups-lspp.m4.lspp cups-1.5b1/config-scripts/c
|
||||
+ ;;
|
||||
+ esac
|
||||
+fi
|
||||
diff -up cups-1.5b1/configure.in.lspp cups-1.5b1/configure.in
|
||||
--- cups-1.5b1/configure.in.lspp 2010-11-20 02:03:46.000000000 +0100
|
||||
+++ cups-1.5b1/configure.in 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/configure.in.lspp cups-1.5b2/configure.in
|
||||
--- cups-1.5b2/configure.in.lspp 2010-11-20 02:03:46.000000000 +0100
|
||||
+++ cups-1.5b2/configure.in 2011-05-31 17:17:46.862328749 +0200
|
||||
@@ -41,6 +41,8 @@ sinclude(config-scripts/cups-defaults.m4
|
||||
sinclude(config-scripts/cups-pdf.m4)
|
||||
sinclude(config-scripts/cups-scripting.m4)
|
||||
@ -66,42 +66,9 @@ diff -up cups-1.5b1/configure.in.lspp cups-1.5b1/configure.in
|
||||
INSTALL_LANGUAGES=""
|
||||
UNINSTALL_LANGUAGES=""
|
||||
LANGFILES=""
|
||||
diff -up cups-1.5b1/cups/cups.h.lspp cups-1.5b1/cups/cups.h
|
||||
--- cups-1.5b1/cups/cups.h.lspp 2011-05-12 07:46:30.000000000 +0200
|
||||
+++ cups-1.5b1/cups/cups.h 2011-05-26 14:34:20.000000000 +0200
|
||||
@@ -15,12 +15,16 @@
|
||||
* This file is subject to the Apple OS-Developed Software exception.
|
||||
*/
|
||||
|
||||
+/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
|
||||
+/* (c) Copyright 2005-2006 Hewlett-Packard Development Company, L.P. */
|
||||
+
|
||||
#ifndef _CUPS_CUPS_H_
|
||||
# define _CUPS_CUPS_H_
|
||||
|
||||
/*
|
||||
* Include necessary headers...
|
||||
*/
|
||||
+# include "config.h"
|
||||
|
||||
# include <sys/types.h>
|
||||
# if defined(WIN32) && !defined(__CUPS_SSIZE_T_DEFINED)
|
||||
@@ -84,6 +88,12 @@ extern "C" {
|
||||
# define CUPS_WHICHJOBS_ACTIVE 0
|
||||
# define CUPS_WHICHJOBS_COMPLETED 1
|
||||
|
||||
+# ifdef WITH_LSPP
|
||||
+# define MLS_CONFIG "mls"
|
||||
+# define TE_CONFIG "te"
|
||||
+# define SELINUX_CONFIG "SELinux"
|
||||
+# define UNKNOWN_SL "UNKNOWN SL"
|
||||
+# endif /* WITH_LSPP */
|
||||
|
||||
/*
|
||||
* Types and structures...
|
||||
diff -up cups-1.5b1/data/Makefile.lspp cups-1.5b1/data/Makefile
|
||||
--- cups-1.5b1/data/Makefile.lspp 2011-05-12 07:21:56.000000000 +0200
|
||||
+++ cups-1.5b1/data/Makefile 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/data/Makefile.lspp cups-1.5b2/data/Makefile
|
||||
--- cups-1.5b2/data/Makefile.lspp 2011-05-12 07:21:56.000000000 +0200
|
||||
+++ cups-1.5b2/data/Makefile 2011-05-31 17:17:46.862328749 +0200
|
||||
@@ -25,7 +25,11 @@ BANNERS = \
|
||||
secret \
|
||||
standard \
|
||||
@ -115,9 +82,9 @@ diff -up cups-1.5b1/data/Makefile.lspp cups-1.5b1/data/Makefile
|
||||
|
||||
CHARSETS = \
|
||||
utf-8
|
||||
diff -up cups-1.5b1/data/mls.lspp cups-1.5b1/data/mls
|
||||
--- cups-1.5b1/data/mls.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/data/mls 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/data/mls.lspp cups-1.5b2/data/mls
|
||||
--- cups-1.5b2/data/mls.lspp 2011-05-31 17:17:46.863328736 +0200
|
||||
+++ cups-1.5b2/data/mls 2011-05-31 17:17:46.863328736 +0200
|
||||
@@ -0,0 +1,261 @@
|
||||
+%!PS-Adobe-3.0
|
||||
+%%BoundingBox: 0 0 612 792
|
||||
@ -380,9 +347,9 @@ diff -up cups-1.5b1/data/mls.lspp cups-1.5b1/data/mls
|
||||
+% End of "$Id: mls_template,v 1.1 2005/06/27 18:44:46 colmo Exp $".
|
||||
+%
|
||||
+%%EOF
|
||||
diff -up cups-1.5b1/data/selinux.lspp cups-1.5b1/data/selinux
|
||||
--- cups-1.5b1/data/selinux.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/data/selinux 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/data/selinux.lspp cups-1.5b2/data/selinux
|
||||
--- cups-1.5b2/data/selinux.lspp 2011-05-31 17:17:46.863328736 +0200
|
||||
+++ cups-1.5b2/data/selinux 2011-05-31 17:17:46.863328736 +0200
|
||||
@@ -0,0 +1,261 @@
|
||||
+%!PS-Adobe-3.0
|
||||
+%%BoundingBox: 0 0 612 792
|
||||
@ -645,9 +612,9 @@ diff -up cups-1.5b1/data/selinux.lspp cups-1.5b1/data/selinux
|
||||
+% End of "$Id: mls_template,v 1.1 2005/06/27 18:44:46 colmo Exp $".
|
||||
+%
|
||||
+%%EOF
|
||||
diff -up cups-1.5b1/data/te.lspp cups-1.5b1/data/te
|
||||
--- cups-1.5b1/data/te.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/data/te 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/data/te.lspp cups-1.5b2/data/te
|
||||
--- cups-1.5b2/data/te.lspp 2011-05-31 17:17:46.864328723 +0200
|
||||
+++ cups-1.5b2/data/te 2011-05-31 17:17:46.864328723 +0200
|
||||
@@ -0,0 +1,261 @@
|
||||
+%!PS-Adobe-3.0
|
||||
+%%BoundingBox: 0 0 612 792
|
||||
@ -910,9 +877,9 @@ diff -up cups-1.5b1/data/te.lspp cups-1.5b1/data/te
|
||||
+% End of "$Id: mls_template,v 1.1 2005/06/27 18:44:46 colmo Exp $".
|
||||
+%
|
||||
+%%EOF
|
||||
diff -up cups-1.5b1/filter/common.c.lspp cups-1.5b1/filter/common.c
|
||||
--- cups-1.5b1/filter/common.c.lspp 2011-05-20 05:49:49.000000000 +0200
|
||||
+++ cups-1.5b1/filter/common.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/filter/common.c.lspp cups-1.5b2/filter/common.c
|
||||
--- cups-1.5b2/filter/common.c.lspp 2011-05-20 05:49:49.000000000 +0200
|
||||
+++ cups-1.5b2/filter/common.c 2011-05-31 17:17:46.864328723 +0200
|
||||
@@ -30,6 +30,12 @@
|
||||
* Include necessary headers...
|
||||
*/
|
||||
@ -1081,9 +1048,9 @@ diff -up cups-1.5b1/filter/common.c.lspp cups-1.5b1/filter/common.c
|
||||
|
||||
|
||||
/*
|
||||
diff -up cups-1.5b1/filter/pstops.c.lspp cups-1.5b1/filter/pstops.c
|
||||
--- cups-1.5b1/filter/pstops.c.lspp 2011-05-20 08:52:23.000000000 +0200
|
||||
+++ cups-1.5b1/filter/pstops.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/filter/pstops.c.lspp cups-1.5b2/filter/pstops.c
|
||||
--- cups-1.5b2/filter/pstops.c.lspp 2011-05-20 08:52:23.000000000 +0200
|
||||
+++ cups-1.5b2/filter/pstops.c 2011-05-31 17:17:46.866328697 +0200
|
||||
@@ -3258,6 +3258,18 @@ write_label_prolog(pstops_doc_t *doc, /*
|
||||
{
|
||||
const char *classification; /* CLASSIFICATION environment variable */
|
||||
@ -1239,9 +1206,9 @@ diff -up cups-1.5b1/filter/pstops.c.lspp cups-1.5b1/filter/pstops.c
|
||||
|
||||
|
||||
/*
|
||||
diff -up cups-1.5b1/Makedefs.in.lspp cups-1.5b1/Makedefs.in
|
||||
--- cups-1.5b1/Makedefs.in.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/Makedefs.in 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/Makedefs.in.lspp cups-1.5b2/Makedefs.in
|
||||
--- cups-1.5b2/Makedefs.in.lspp 2011-05-31 17:17:46.841329012 +0200
|
||||
+++ cups-1.5b2/Makedefs.in 2011-05-31 17:17:46.867328685 +0200
|
||||
@@ -157,7 +157,7 @@ LDFLAGS = -L../cgi-bin -L../cups -L../f
|
||||
LEGACY_BACKENDS = @LEGACY_BACKENDS@
|
||||
LINKCUPS = @LINKCUPS@ $(LIBGSSAPI) $(SSLLIBS) $(DNSSDLIBS) $(LIBZ)
|
||||
@ -1251,9 +1218,9 @@ diff -up cups-1.5b1/Makedefs.in.lspp cups-1.5b1/Makedefs.in
|
||||
OPTIM = @OPTIM@
|
||||
OPTIONS =
|
||||
PAMLIBS = @PAMLIBS@
|
||||
diff -up cups-1.5b1/scheduler/client.c.lspp cups-1.5b1/scheduler/client.c
|
||||
--- cups-1.5b1/scheduler/client.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/client.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/client.c.lspp cups-1.5b2/scheduler/client.c
|
||||
--- cups-1.5b2/scheduler/client.c.lspp 2011-05-31 17:17:46.857328810 +0200
|
||||
+++ cups-1.5b2/scheduler/client.c 2011-05-31 17:17:46.869328661 +0200
|
||||
@@ -44,6 +44,7 @@
|
||||
* valid_host() - Is the Host: field valid?
|
||||
* write_file() - Send a file via HTTP.
|
||||
@ -1471,9 +1438,9 @@ diff -up cups-1.5b1/scheduler/client.c.lspp cups-1.5b1/scheduler/client.c
|
||||
/*
|
||||
* 'pipe_command()' - Pipe the output of a command to the remote client.
|
||||
*/
|
||||
diff -up cups-1.5b1/scheduler/client.h.lspp cups-1.5b1/scheduler/client.h
|
||||
--- cups-1.5b1/scheduler/client.h.lspp 2011-03-25 22:25:38.000000000 +0100
|
||||
+++ cups-1.5b1/scheduler/client.h 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/client.h.lspp cups-1.5b2/scheduler/client.h
|
||||
--- cups-1.5b2/scheduler/client.h.lspp 2011-03-25 22:25:38.000000000 +0100
|
||||
+++ cups-1.5b2/scheduler/client.h 2011-05-31 17:17:46.870328649 +0200
|
||||
@@ -18,6 +18,13 @@
|
||||
#endif /* HAVE_AUTHORIZATION_H */
|
||||
|
||||
@ -1509,9 +1476,9 @@ diff -up cups-1.5b1/scheduler/client.h.lspp cups-1.5b1/scheduler/client.h
|
||||
|
||||
|
||||
/*
|
||||
diff -up cups-1.5b1/scheduler/conf.c.lspp cups-1.5b1/scheduler/conf.c
|
||||
--- cups-1.5b1/scheduler/conf.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/conf.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/conf.c.lspp cups-1.5b2/scheduler/conf.c
|
||||
--- cups-1.5b2/scheduler/conf.c.lspp 2011-05-31 17:17:46.754330096 +0200
|
||||
+++ cups-1.5b2/scheduler/conf.c 2011-05-31 17:17:46.871328637 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
* read_location() - Read a <Location path> definition.
|
||||
* read_policy() - Read a <Policy name> definition.
|
||||
@ -1616,9 +1583,9 @@ diff -up cups-1.5b1/scheduler/conf.c.lspp cups-1.5b1/scheduler/conf.c
|
||||
|
||||
/*
|
||||
* 'read_policy()' - Read a <Policy name> definition.
|
||||
diff -up cups-1.5b1/scheduler/conf.h.lspp cups-1.5b1/scheduler/conf.h
|
||||
--- cups-1.5b1/scheduler/conf.h.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/conf.h 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/conf.h.lspp cups-1.5b2/scheduler/conf.h
|
||||
--- cups-1.5b2/scheduler/conf.h.lspp 2011-05-31 17:17:46.757330059 +0200
|
||||
+++ cups-1.5b2/scheduler/conf.h 2011-05-31 17:17:46.872328624 +0200
|
||||
@@ -250,6 +250,12 @@ VAR char *ServerKey VALUE(NULL);
|
||||
VAR int SSLOptions VALUE(CUPSD_SSL_NONE);
|
||||
/* SSL/TLS options */
|
||||
@ -1642,9 +1609,43 @@ diff -up cups-1.5b1/scheduler/conf.h.lspp cups-1.5b1/scheduler/conf.h
|
||||
|
||||
/*
|
||||
* Prototypes...
|
||||
diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
--- cups-1.5b1/scheduler/ipp.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/ipp.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/cupsd.h.lspp cups-1.5b2/scheduler/cupsd.h
|
||||
--- cups-1.5b2/scheduler/cupsd.h.lspp 2011-05-12 00:17:34.000000000 +0200
|
||||
+++ cups-1.5b2/scheduler/cupsd.h 2011-05-31 17:19:49.534795131 +0200
|
||||
@@ -13,6 +13,8 @@
|
||||
* file is missing or damaged, see the license at "http://www.cups.org/".
|
||||
*/
|
||||
|
||||
+/* Copyright (C) 2005 Trusted Computer Solutions, Inc. */
|
||||
+/* (c) Copyright 2005-2006 Hewlett-Packard Development Company, L.P. */
|
||||
|
||||
/*
|
||||
* Include necessary headers.
|
||||
@@ -37,13 +39,20 @@
|
||||
# include <unistd.h>
|
||||
#endif /* WIN32 */
|
||||
|
||||
+#include "config.h"
|
||||
+#ifdef WITH_LSPP
|
||||
+# define MLS_CONFIG "mls"
|
||||
+# define TE_CONFIG "te"
|
||||
+# define SELINUX_CONFIG "SELinux"
|
||||
+# define UNKNOWN_SL "UNKNOWN SL"
|
||||
+#endif /* WITH_LSPP */
|
||||
+
|
||||
#include "mime.h"
|
||||
|
||||
#if defined(HAVE_CDSASSL)
|
||||
# include <CoreFoundation/CoreFoundation.h>
|
||||
#endif /* HAVE_CDSASSL */
|
||||
|
||||
-
|
||||
/*
|
||||
* Some OS's don't have hstrerror(), most notably Solaris...
|
||||
*/
|
||||
diff -up cups-1.5b2/scheduler/ipp.c.lspp cups-1.5b2/scheduler/ipp.c
|
||||
--- cups-1.5b2/scheduler/ipp.c.lspp 2011-05-31 17:17:46.796329573 +0200
|
||||
+++ cups-1.5b2/scheduler/ipp.c 2011-05-31 17:17:46.876328572 +0200
|
||||
@@ -41,6 +41,7 @@
|
||||
* cancel_all_jobs() - Cancel all or selected print jobs.
|
||||
* cancel_job() - Cancel a print job.
|
||||
@ -1963,7 +1964,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
|
||||
/*
|
||||
* See if we need to add the starting sheet...
|
||||
@@ -4700,6 +4932,111 @@ check_rss_recipient(
|
||||
@@ -4703,6 +4935,111 @@ check_rss_recipient(
|
||||
}
|
||||
|
||||
|
||||
@ -2075,7 +2076,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
/*
|
||||
* 'check_quotas()' - Check quotas for a printer and user.
|
||||
*/
|
||||
@@ -5337,6 +5674,15 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
@@ -5340,6 +5677,15 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
char attrname[255], /* Name of attribute */
|
||||
*s; /* Pointer into name */
|
||||
ipp_attribute_t *attr; /* Attribute */
|
||||
@ -2091,7 +2092,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
|
||||
|
||||
cupsdLogMessage(CUPSD_LOG_DEBUG2,
|
||||
@@ -5372,6 +5718,82 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
@@ -5375,6 +5721,82 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
|
||||
fchmod(cupsFileNumber(out), 0640);
|
||||
fchown(cupsFileNumber(out), RunUser, Group);
|
||||
@ -2174,7 +2175,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
|
||||
/*
|
||||
* Try the localized banner file under the subdirectory...
|
||||
@@ -5466,6 +5888,24 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
@@ -5469,6 +5891,24 @@ copy_banner(cupsd_client_t *con, /* I -
|
||||
else
|
||||
s = attrname;
|
||||
|
||||
@ -2199,7 +2200,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
if (!strcmp(s, "printer-name"))
|
||||
{
|
||||
cupsFilePuts(out, job->dest);
|
||||
@@ -7457,6 +7897,22 @@ get_job_attrs(cupsd_client_t *con, /* I
|
||||
@@ -7460,6 +7900,22 @@ get_job_attrs(cupsd_client_t *con, /* I
|
||||
|
||||
exclude = cupsdGetPrivateAttrs(policy, con, printer, job->username);
|
||||
|
||||
@ -2222,7 +2223,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
/*
|
||||
* Copy attributes...
|
||||
*/
|
||||
@@ -7810,6 +8266,11 @@ get_jobs(cupsd_client_t *con, /* I - C
|
||||
@@ -7813,6 +8269,11 @@ get_jobs(cupsd_client_t *con, /* I - C
|
||||
if (username[0] && _cups_strcasecmp(username, job->username))
|
||||
continue;
|
||||
|
||||
@ -2234,7 +2235,7 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
if (count > 0)
|
||||
ippAddSeparator(con->response);
|
||||
|
||||
@@ -12249,6 +12710,11 @@ validate_user(cupsd_job_t *job, /* I
|
||||
@@ -12252,6 +12713,11 @@ validate_user(cupsd_job_t *job, /* I
|
||||
|
||||
strlcpy(username, get_username(con), userlen);
|
||||
|
||||
@ -2246,9 +2247,9 @@ diff -up cups-1.5b1/scheduler/ipp.c.lspp cups-1.5b1/scheduler/ipp.c
|
||||
/*
|
||||
* Check the username against the owner...
|
||||
*/
|
||||
diff -up cups-1.5b1/scheduler/job.c.lspp cups-1.5b1/scheduler/job.c
|
||||
--- cups-1.5b1/scheduler/job.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/job.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/job.c.lspp cups-1.5b2/scheduler/job.c
|
||||
--- cups-1.5b2/scheduler/job.c.lspp 2011-05-31 17:17:46.817329312 +0200
|
||||
+++ cups-1.5b2/scheduler/job.c 2011-05-31 17:17:46.880328524 +0200
|
||||
@@ -64,6 +64,9 @@
|
||||
* update_job_attrs() - Update the job-printer-* attributes.
|
||||
*/
|
||||
@ -2618,9 +2619,9 @@ diff -up cups-1.5b1/scheduler/job.c.lspp cups-1.5b1/scheduler/job.c
|
||||
/*
|
||||
* Now start the first file in the job...
|
||||
*/
|
||||
diff -up cups-1.5b1/scheduler/job.h.lspp cups-1.5b1/scheduler/job.h
|
||||
--- cups-1.5b1/scheduler/job.h.lspp 2011-05-18 04:27:11.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/job.h 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/job.h.lspp cups-1.5b2/scheduler/job.h
|
||||
--- cups-1.5b2/scheduler/job.h.lspp 2011-05-18 04:27:11.000000000 +0200
|
||||
+++ cups-1.5b2/scheduler/job.h 2011-05-31 17:17:46.883328486 +0200
|
||||
@@ -13,6 +13,13 @@
|
||||
* file is missing or damaged, see the license at "http://www.cups.org/".
|
||||
*/
|
||||
@ -2646,9 +2647,9 @@ diff -up cups-1.5b1/scheduler/job.h.lspp cups-1.5b1/scheduler/job.h
|
||||
};
|
||||
|
||||
typedef struct cupsd_joblog_s /**** Job log message ****/
|
||||
diff -up cups-1.5b1/scheduler/main.c.lspp cups-1.5b1/scheduler/main.c
|
||||
--- cups-1.5b1/scheduler/main.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/main.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/main.c.lspp cups-1.5b2/scheduler/main.c
|
||||
--- cups-1.5b2/scheduler/main.c.lspp 2011-05-31 17:17:46.782329749 +0200
|
||||
+++ cups-1.5b2/scheduler/main.c 2011-05-31 17:17:46.884328473 +0200
|
||||
@@ -36,6 +36,8 @@
|
||||
* usage() - Show scheduler usage.
|
||||
*/
|
||||
@ -2716,9 +2717,9 @@ diff -up cups-1.5b1/scheduler/main.c.lspp cups-1.5b1/scheduler/main.c
|
||||
return (!stop_scheduler);
|
||||
}
|
||||
|
||||
diff -up cups-1.5b1/scheduler/printers.c.lspp cups-1.5b1/scheduler/printers.c
|
||||
--- cups-1.5b1/scheduler/printers.c.lspp 2011-05-26 14:33:28.000000000 +0200
|
||||
+++ cups-1.5b1/scheduler/printers.c 2011-05-26 14:33:28.000000000 +0200
|
||||
diff -up cups-1.5b2/scheduler/printers.c.lspp cups-1.5b2/scheduler/printers.c
|
||||
--- cups-1.5b2/scheduler/printers.c.lspp 2011-05-31 17:17:46.769329910 +0200
|
||||
+++ cups-1.5b2/scheduler/printers.c 2011-05-31 17:17:46.889328411 +0200
|
||||
@@ -56,6 +56,8 @@
|
||||
* write_xml_string() - Write a string with XML escaping.
|
||||
*/
|
||||
@ -2739,7 +2740,7 @@ diff -up cups-1.5b1/scheduler/printers.c.lspp cups-1.5b1/scheduler/printers.c
|
||||
|
||||
/*
|
||||
* Local functions...
|
||||
@@ -2143,6 +2149,13 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
|
||||
@@ -2133,6 +2139,13 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
|
||||
"username",
|
||||
"password"
|
||||
};
|
||||
@ -2753,7 +2754,7 @@ diff -up cups-1.5b1/scheduler/printers.c.lspp cups-1.5b1/scheduler/printers.c
|
||||
|
||||
|
||||
DEBUG_printf(("cupsdSetPrinterAttrs: entering name = %s, type = %x\n", p->name,
|
||||
@@ -2280,6 +2293,45 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
|
||||
@@ -2270,6 +2283,45 @@ cupsdSetPrinterAttrs(cupsd_printer_t *p)
|
||||
attr->values[1].string.text = _cupsStrAlloc(Classification ?
|
||||
Classification : p->job_sheets[1]);
|
||||
}
|
||||
@ -2799,7 +2800,7 @@ diff -up cups-1.5b1/scheduler/printers.c.lspp cups-1.5b1/scheduler/printers.c
|
||||
}
|
||||
|
||||
p->raw = 0;
|
||||
@@ -5404,7 +5456,6 @@ write_irix_state(cupsd_printer_t *p) /*
|
||||
@@ -5394,7 +5446,6 @@ write_irix_state(cupsd_printer_t *p) /*
|
||||
}
|
||||
#endif /* __sgi */
|
||||
|
||||
|
@ -1,109 +0,0 @@
|
||||
diff -up cups-1.4.4/cups/http.c.serialize-gnutls cups-1.4.4/cups/http.c
|
||||
--- cups-1.4.4/cups/http.c.serialize-gnutls 2010-09-17 13:37:01.858871762 +0100
|
||||
+++ cups-1.4.4/cups/http.c 2010-09-17 13:55:22.579871934 +0100
|
||||
@@ -149,7 +149,7 @@ static int http_write_ssl(http_t *http,
|
||||
|
||||
# ifdef HAVE_GNUTLS
|
||||
# ifdef HAVE_PTHREAD_H
|
||||
-GCRY_THREAD_OPTION_PTHREAD_IMPL;
|
||||
+static pthread_mutex_t gnutls_lock;
|
||||
# endif /* HAVE_PTHREAD_H */
|
||||
|
||||
# elif defined(HAVE_LIBSSL) && defined(HAVE_PTHREAD_H)
|
||||
@@ -1231,7 +1231,7 @@ httpInitialize(void)
|
||||
*/
|
||||
|
||||
# ifdef HAVE_PTHREAD_H
|
||||
- gcry_control(GCRYCTL_SET_THREAD_CBS, &gcry_threads_pthread);
|
||||
+ pthread_mutex_init(&gnutls_lock, NULL);
|
||||
# endif /* HAVE_PTHREAD_H */
|
||||
|
||||
/*
|
||||
@@ -2228,6 +2228,7 @@ _httpWait(http_t *http, /* I - Connect
|
||||
if (SSL_pending((SSL *)(http->tls)))
|
||||
return (1);
|
||||
# elif defined(HAVE_GNUTLS)
|
||||
+ /* lock already held here... */
|
||||
if (gnutls_record_check_pending(((http_tls_t *)(http->tls))->session))
|
||||
return (1);
|
||||
# elif defined(HAVE_CDSASSL)
|
||||
@@ -2294,6 +2295,8 @@ int /* O - 1 if data is available, 0
|
||||
httpWait(http_t *http, /* I - Connection to server */
|
||||
int msec) /* I - Milliseconds to wait */
|
||||
{
|
||||
+ int ret;
|
||||
+
|
||||
/*
|
||||
* First see if there is data in the buffer...
|
||||
*/
|
||||
@@ -2318,7 +2321,17 @@ httpWait(http_t *http, /* I - Connecti
|
||||
* If not, check the SSL/TLS buffers and do a select() on the connection...
|
||||
*/
|
||||
|
||||
- return (_httpWait(http, msec, 1));
|
||||
+#if defined(HAVE_SSL) && defined(HAVE_GNUTLS) && defined(HAVE_PTHREAD_H)
|
||||
+ pthread_mutex_lock(&gnutls_lock);
|
||||
+#endif
|
||||
+
|
||||
+ ret = _httpWait(http, msec, 1);
|
||||
+
|
||||
+#if defined(HAVE_SSL) && defined(HAVE_GNUTLS) && defined(HAVE_PTHREAD_H)
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
+#endif
|
||||
+
|
||||
+ return (ret);
|
||||
}
|
||||
|
||||
|
||||
@@ -2769,7 +2782,9 @@ http_read_ssl(http_t *http, /* I - Conn
|
||||
ssize_t result; /* Return value */
|
||||
|
||||
|
||||
+ pthread_mutex_lock(&gnutls_lock);
|
||||
result = gnutls_record_recv(((http_tls_t *)(http->tls))->session, buf, len);
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
|
||||
if (result < 0 && !errno)
|
||||
{
|
||||
@@ -3085,6 +3100,7 @@ http_setup_ssl(http_t *http) /* I - Con
|
||||
return (-1);
|
||||
}
|
||||
|
||||
+ pthread_mutex_lock(&gnutls_lock);
|
||||
gnutls_certificate_allocate_credentials(credentials);
|
||||
|
||||
gnutls_init(&(conn->session), GNUTLS_CLIENT);
|
||||
@@ -3104,9 +3120,11 @@ http_setup_ssl(http_t *http) /* I - Con
|
||||
free(credentials);
|
||||
free(conn);
|
||||
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
return (-1);
|
||||
}
|
||||
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
conn->credentials = credentials;
|
||||
|
||||
# elif defined(HAVE_CDSASSL)
|
||||
@@ -3196,9 +3214,11 @@ http_shutdown_ssl(http_t *http) /* I -
|
||||
conn = (http_tls_t *)(http->tls);
|
||||
credentials = (gnutls_certificate_client_credentials *)(conn->credentials);
|
||||
|
||||
+ pthread_mutex_lock(&gnutls_lock);
|
||||
gnutls_bye(conn->session, GNUTLS_SHUT_RDWR);
|
||||
gnutls_deinit(conn->session);
|
||||
gnutls_certificate_free_credentials(*credentials);
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
free(credentials);
|
||||
free(conn);
|
||||
|
||||
@@ -3445,7 +3465,9 @@ http_write_ssl(http_t *http, /* I -
|
||||
# elif defined(HAVE_GNUTLS)
|
||||
ssize_t result; /* Return value */
|
||||
|
||||
+ pthread_mutex_lock(&gnutls_lock);
|
||||
result = gnutls_record_send(((http_tls_t *)(http->tls))->session, buf, len);
|
||||
+ pthread_mutex_unlock(&gnutls_lock);
|
||||
|
||||
if (result < 0 && !errno)
|
||||
{
|
13
cups.spec
13
cups.spec
@ -15,7 +15,7 @@
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.5
|
||||
Release: 0.2.%{alphatag}%{?dist}
|
||||
Release: 0.3.%{alphatag}%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Daemons
|
||||
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
||||
@ -61,7 +61,6 @@ Patch20: cups-filter-debug.patch
|
||||
Patch21: cups-uri-compat.patch
|
||||
Patch22: cups-cups-get-classes.patch
|
||||
Patch23: cups-str3382.patch
|
||||
Patch24: cups-serialize-gnutls.patch
|
||||
Patch25: cups-0755.patch
|
||||
Patch26: cups-snmp-quirks.patch
|
||||
Patch27: cups-hp-deviceid-oid.patch
|
||||
@ -262,9 +261,6 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
||||
%patch22 -p1 -b .cups-get-classes
|
||||
# Fix temporary filename creation.
|
||||
%patch23 -p1 -b .str3382
|
||||
# Perform locking for gnutls and avoid libgcrypt's broken
|
||||
# locking (bug #607159).
|
||||
#%patch24 -p1 -b .serialize-gnutls
|
||||
# Use mode 0755 for binaries and libraries where appropriate.
|
||||
%patch25 -p1 -b .0755
|
||||
# Handle SNMP supply level quirks (bug #581825).
|
||||
@ -617,12 +613,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_mandir}/man1/ipptool.1.gz
|
||||
|
||||
%changelog
|
||||
* Tue May 31 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.3.b2
|
||||
- fix lspp.patch to not include "config.h" in cups/cups.h (#709384)
|
||||
|
||||
* Thu May 26 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.2.b2
|
||||
- 1.5b2
|
||||
- TODO:
|
||||
- remove OR port cups-serialize-gnutls.patch ??? (STR#3605)
|
||||
- port avahi.patch
|
||||
- port icc.patch
|
||||
|
||||
* Tue May 24 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.1.b1
|
||||
- 1.5b1
|
||||
|
Loading…
Reference in New Issue
Block a user