- 1.4.2. No longer need str3380, str3332, str3356, str3396 patches.

- Removed postscript.ppd.gz (bug #533371).
- Renumbered patches and sources.
This commit is contained in:
Tim Waugh 2009-11-10 13:09:53 +00:00
parent 85cfb8e7e1
commit 6a7d7ab6fb
8 changed files with 95 additions and 232 deletions

View File

@ -39,3 +39,5 @@ cups-1.4b2-source.tar.bz2
cups-1.4b2-svn8404-source.tar.bz2
cups-1.4rc1-source.tar.bz2
cups-1.4.0-source.tar.bz2
cups-1.4b2-source.tar.bz2
cups-1.4b2-svn8404-source.tar.bz2

View File

@ -1,18 +1,35 @@
--- cups-1.2svn-r5238/conf/Makefile.system-auth 2006-03-07 09:34:20.000000000 +0000
+++ cups-1.2svn-r5238/conf/Makefile 2006-03-07 09:45:41.000000000 +0000
@@ -79,10 +79,16 @@
diff -up /dev/null cups-1.4.2/conf/cups.password-auth
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
+++ cups-1.4.2/conf/cups.password-auth 2009-11-10 11:15:42.750666738 +0000
@@ -0,0 +1,4 @@
+#%PAM-1.0
+# Use password-auth common PAM configuration for the daemon
+auth include password-auth
+account include password-auth
diff -up cups-1.4.2/conf/cups.system-auth cups-1.4.2/conf/cups
diff -up /dev/null cups-1.4.2/conf/cups.system-auth
--- /dev/null 2009-11-10 09:17:06.284031490 +0000
+++ cups-1.4.2/conf/cups.system-auth 2009-11-10 11:15:42.750666738 +0000
@@ -0,0 +1,3 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth
diff -up cups-1.4.2/conf/Makefile.system-auth cups-1.4.2/conf/Makefile
--- cups-1.4.2/conf/Makefile.system-auth 2009-09-22 22:53:31.000000000 +0100
+++ cups-1.4.2/conf/Makefile 2009-11-10 11:18:44.188791989 +0000
@@ -90,10 +90,16 @@ install-data:
done
-if test x$(PAMDIR) != x; then \
$(INSTALL_DIR) -m 755 $(BUILDROOT)$(PAMDIR); \
- if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
- if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
+ if test -f /etc/pam.d/password-auth; then \
+ $(INSTALL_DATA) cups.password-auth $(BUILDROOT)$(PAMDIR)/cups ; \
+ $(INSTALL_DATA) cups.password-auth $(BUILDROOT)$(PAMDIR)/cups; \
+ elif test -f /etc/pam.d/system-auth; then \
+ $(INSTALL_DATA) cups.system-auth $(BUILDROOT)$(PAMDIR)/cups ; \
+ $(INSTALL_DATA) cups.system-auth $(BUILDROOT)$(PAMDIR)/cups; \
else \
- $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
+ if test -r $(BUILDROOT)$(PAMDIR)/cups/$(PAMFILE) ; then \
+ if test -r $(BUILDROOT)$(PAMDIR)/cups ; then \
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups.N ; \
+ else \
+ $(INSTALL_DATA) $(PAMFILE) $(BUILDROOT)$(PAMDIR)/cups ; \
@ -20,16 +37,3 @@
fi ; \
fi
--- /dev/null 2006-03-07 09:12:30.964372750 +0000
+++ cups-1.2svn-r5238/conf/cups.system-auth 2006-03-07 09:43:12.000000000 +0000
@@ -0,0 +1,3 @@
+#%PAM-1.0
+auth include system-auth
+account include system-auth
--- /dev/null 2006-03-07 09:12:30.964372750 +0000
+++ cups-1.2svn-r5238/conf/cups.password-auth 2006-03-07 09:43:12.000000000 +0000
@@ -0,0 +1,4 @@
+#%PAM-1.0
+# Use password-auth common PAM configuration for the daemon
+auth include password-auth
+account include password-auth

View File

@ -1,12 +0,0 @@
diff -up cups-1.4.1/backend/usb-unix.c.function-decl cups-1.4.1/backend/usb-unix.c
--- cups-1.4.1/backend/usb-unix.c.function-decl 2009-09-14 17:36:06.087996470 +0100
+++ cups-1.4.1/backend/usb-unix.c 2009-09-14 17:36:13.656996607 +0100
@@ -605,7 +605,7 @@ open_device(const char *uri, /* I - Dev
* 'side_cb()' - Handle side-channel requests...
*/
-static void
+static int
side_cb(int print_fd, /* I - Print file */
int device_fd, /* I - Device file */
int snmp_fd, /* I - SNMP socket (unused) */

View File

@ -1,101 +0,0 @@
diff -up cups-1.4.1/scheduler/ipp.c.str3356 cups-1.4.1/scheduler/ipp.c
--- cups-1.4.1/scheduler/ipp.c.str3356 2009-10-07 17:26:27.504800579 +0100
+++ cups-1.4.1/scheduler/ipp.c 2009-10-07 17:26:31.311800539 +0100
@@ -2324,8 +2324,9 @@ add_printer(cupsd_client_t *con, /* I -
dstfile[1024]; /* Destination Script/PPD file */
int modify; /* Non-zero if we are modifying */
char newname[IPP_MAX_NAME]; /* New printer name */
- int need_restart_job; /* Need to restart job? */
- int set_device_uri, /* Did we set the device URI? */
+ int changed_driver, /* Changed the PPD/interface script? */
+ need_restart_job, /* Need to restart job? */
+ set_device_uri, /* Did we set the device URI? */
set_port_monitor; /* Did we set the port monitor? */
@@ -2469,6 +2470,7 @@ add_printer(cupsd_client_t *con, /* I -
* Look for attributes and copy them over as needed...
*/
+ changed_driver = 0;
need_restart_job = 0;
if ((attr = ippFindAttribute(con->request, "printer-location",
@@ -2731,6 +2733,7 @@ add_printer(cupsd_client_t *con, /* I -
if (con->filename)
{
need_restart_job = 1;
+ changed_driver = 1;
strlcpy(srcfile, con->filename, sizeof(srcfile));
@@ -2801,18 +2804,6 @@ add_printer(cupsd_client_t *con, /* I -
cupsdLogMessage(CUPSD_LOG_DEBUG,
"Copied PPD file successfully!");
chmod(dstfile, 0644);
-
-#ifdef __APPLE__
- /*
- * (Re)register color profiles...
- */
-
- if (!RunUser)
- {
- apple_unregister_profiles(printer);
- apple_register_profiles(printer);
- }
-#endif /* __APPLE__ */
}
else
{
@@ -2829,6 +2820,7 @@ add_printer(cupsd_client_t *con, /* I -
IPP_TAG_NAME)) != NULL)
{
need_restart_job = 1;
+ changed_driver = 1;
if (!strcmp(attr->values[0].string.text, "raw"))
{
@@ -2866,19 +2858,33 @@ add_printer(cupsd_client_t *con, /* I -
cupsdLogMessage(CUPSD_LOG_DEBUG,
"Copied PPD file successfully!");
chmod(dstfile, 0644);
+ }
+ }
+
+ if (changed_driver)
+ {
+ /*
+ * If we changed the PPD/interface script, then remove the printer's cache
+ * file...
+ */
+
+ char cache_name[1024]; /* Cache filename for printer attrs */
+
+ snprintf(cache_name, sizeof(cache_name), "%s/%s.ipp", CacheDir,
+ printer->name);
+ unlink(cache_name);
#ifdef __APPLE__
- /*
- * (Re)register color profiles...
- */
+ /*
+ * (Re)register color profiles...
+ */
- if (!RunUser)
- {
- apple_unregister_profiles(printer);
- apple_register_profiles(printer);
- }
-#endif /* __APPLE__ */
+ if (!RunUser)
+ {
+ apple_unregister_profiles(printer);
+ apple_register_profiles(printer);
}
+#endif /* __APPLE__ */
}
/*

View File

@ -1,12 +0,0 @@
diff -up cups-1.4.1/doc/de/index.html.in.str3380 cups-1.4.1/doc/de/index.html.in
--- cups-1.4.1/doc/de/index.html.in.str3380 2009-04-09 22:22:42.000000000 +0100
+++ cups-1.4.1/doc/de/index.html.in 2009-10-19 12:04:30.352768816 +0100
@@ -17,7 +17,7 @@ SRC="/images/left.gif" WIDTH="64" HEIGHT
<TD CLASS="unsel"><A HREF="/admin">&nbsp;&nbsp;Verwaltung&nbsp;&nbsp;</A></TD>
<TD CLASS="unsel"><A HREF="/classes/">&nbsp;&nbsp;Klassen&nbsp;&nbsp;</A></TD>
<TD CLASS="unsel"><A HREF="/help/">&nbsp;&nbsp;On-Line&nbsp;Hilfe&nbsp;&nbsp;</A></TD>
-<TD CLASS="unsel"><A HREF="/jobs/">&nbsp;&nbsp;Auftr&uuml;ge&nbsp;&nbsp;</A></TD>
+<TD CLASS="unsel"><A HREF="/jobs/">&nbsp;&nbsp;Auftr&auml;ge&nbsp;&nbsp;</A></TD>
<TD CLASS="unsel"><A HREF="/printers/">&nbsp;&nbsp;Drucker&nbsp;&nbsp;</A></TD>
<TD CLASS="unsel" WIDTH="100%"><FORM ACTION="/help/" METHOD="GET"><INPUT
TYPE="SEARCH" NAME="QUERY" SIZE="20" PLACEHOLDER="Search Help"

View File

@ -1,11 +0,0 @@
diff -up cups-1.4.1/templates/de/set-printer-options-header.tmpl.str3396 cups-1.4.1/templates/de/set-printer-options-header.tmpl
--- cups-1.4.1/templates/de/set-printer-options-header.tmpl.str3396 2009-04-03 17:55:28.000000000 +0200
+++ cups-1.4.1/templates/de/set-printer-options-header.tmpl 2009-10-27 15:17:53.000000000 +0100
@@ -1,6 +1,6 @@
<DIV CLASS="indent">
-<H2 CLASS="title">Standardeinstellungen f%uuml;r {printer_name} festlegen</H2>
+<H2 CLASS="title">Standardeinstellungen f&uuml;r {printer_name} festlegen</H2>
<FORM METHOD="POST" ACTION="/admin">
<INPUT TYPE="HIDDEN" NAME="PRINTER_NAME" VALUE="{printer_name}">

142
cups.spec
View File

@ -8,11 +8,11 @@
Summary: Common Unix Printing System
Name: cups
Version: 1.4.1
Release: 13%{?dist}
Version: 1.4.2
Release: 1%{?dist}
License: GPLv2
Group: System Environment/Daemons
Source: http://ftp.easysw.com/pub/cups/1.4.0/cups-%{version}-source.tar.bz2
Source: http://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
Source1: cups.init
Source2: cupsprinter.png
Source3: cups-libusb.rules
@ -20,44 +20,40 @@ Source4: pstopdf
Source5: cups-lpd
Source6: pstoraster
Source7: pstoraster.convs
Source9: cups.logrotate
Source10: ncp.backend
Source12: cups.cron
Source14: textonly.filter
Source15: textonly.ppd
Source8: cups.logrotate
Source9: ncp.backend
Source10: cups.cron
Source11: textonly.filter
Source12: textonly.ppd
Patch1: cups-no-gzip-man.patch
Patch2: cups-1.1.16-system-auth.patch
Patch3: cups-multilib.patch
Patch5: cups-serial.patch
Patch6: cups-banners.patch
Patch7: cups-serverbin-compat.patch
Patch8: cups-no-export-ssllibs.patch
Patch9: cups-paps.patch
Patch10: cups-str3380.patch
Patch11: cups-direct-usb.patch
Patch12: cups-lpr-help.patch
Patch13: cups-peercred.patch
Patch14: cups-pid.patch
Patch15: cups-page-label.patch
Patch16: cups-eggcups.patch
Patch17: cups-getpass.patch
Patch18: cups-driverd-timeout.patch
Patch19: cups-strict-ppd-line-length.patch
Patch20: cups-logrotate.patch
Patch21: cups-usb-paperout.patch
Patch22: cups-build.patch
Patch23: cups-res_init.patch
Patch25: cups-filter-debug.patch
Patch30: cups-uri-compat.patch
Patch35: cups-cups-get-classes.patch
Patch37: cups-avahi.patch
Patch38: cups-str3332.patch
Patch39: cups-str3356.patch
Patch40: cups-str3382.patch
Patch41: cups-str3285_v2.patch
Patch42: cups-str3390.patch
Patch43: cups-str3391.patch
Patch44: cups-str3396.patch
Patch4: cups-serial.patch
Patch5: cups-banners.patch
Patch6: cups-serverbin-compat.patch
Patch7: cups-no-export-ssllibs.patch
Patch8: cups-paps.patch
Patch9: cups-direct-usb.patch
Patch10: cups-lpr-help.patch
Patch11: cups-peercred.patch
Patch12: cups-pid.patch
Patch13: cups-page-label.patch
Patch14: cups-eggcups.patch
Patch15: cups-getpass.patch
Patch16: cups-driverd-timeout.patch
Patch17: cups-strict-ppd-line-length.patch
Patch18: cups-logrotate.patch
Patch19: cups-usb-paperout.patch
Patch20: cups-build.patch
Patch21: cups-res_init.patch
Patch22: cups-filter-debug.patch
Patch23: cups-uri-compat.patch
Patch24: cups-cups-get-classes.patch
Patch25: cups-avahi.patch
Patch26: cups-str3382.patch
Patch27: cups-str3285_v2.patch
Patch28: cups-str3390.patch
Patch29: cups-str3391.patch
Patch100: cups-lspp.patch
Epoch: 1
@ -189,36 +185,32 @@ module.
%patch1 -p1 -b .no-gzip-man
%patch2 -p1 -b .system-auth
%patch3 -p1 -b .multilib
%patch5 -p1 -b .serial
%patch6 -p1 -b .banners
%patch7 -p1 -b .serverbin-compat
%patch8 -p1 -b .no-export-ssllibs
%patch9 -p1 -b .paps
%patch10 -p1 -b .str3380
%patch11 -p1 -b .direct-usb
%patch12 -p1 -b .lpr-help
%patch13 -p1 -b .peercred
%patch14 -p1 -b .pid
%patch15 -p1 -b .page-label
%patch16 -p1 -b .eggcups
%patch17 -p1 -b .getpass
%patch18 -p1 -b .driverd-timeout
%patch19 -p1 -b .strict-ppd-line-length
%patch20 -p1 -b .logrotate
%patch21 -p1 -b .usb-paperout
%patch22 -p1 -b .build
%patch23 -p1 -b .res_init
%patch25 -p1 -b .filter-debug
%patch30 -p1 -b .uri-compat
%patch35 -p1 -b .cups-get-classes
%patch37 -p1 -b .avahi
%patch38 -p1 -b .str3332
%patch39 -p1 -b .str3356
%patch40 -p1 -b .str3382
%patch41 -p1 -b .str3285_v2
%patch42 -p1 -b .str3390
%patch43 -p1 -b .str3391
%patch44 -p1 -b .str3396
%patch4 -p1 -b .serial
%patch5 -p1 -b .banners
%patch6 -p1 -b .serverbin-compat
%patch7 -p1 -b .no-export-ssllibs
%patch8 -p1 -b .paps
%patch9 -p1 -b .direct-usb
%patch10 -p1 -b .lpr-help
%patch11 -p1 -b .peercred
%patch12 -p1 -b .pid
%patch13 -p1 -b .page-label
%patch14 -p1 -b .eggcups
%patch15 -p1 -b .getpass
%patch16 -p1 -b .driverd-timeout
%patch17 -p1 -b .strict-ppd-line-length
%patch18 -p1 -b .logrotate
%patch19 -p1 -b .usb-paperout
%patch20 -p1 -b .build
%patch21 -p1 -b .res_init
%patch22 -p1 -b .filter-debug
%patch23 -p1 -b .uri-compat
%patch24 -p1 -b .cups-get-classes
%patch25 -p1 -b .avahi
%patch26 -p1 -b .str3382
%patch27 -p1 -b .str3285_v2
%patch28 -p1 -b .str3390
%patch29 -p1 -b .str3391
%if %lspp
%patch100 -p1 -b .lspp
@ -290,11 +282,11 @@ popd
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps $RPM_BUILD_ROOT%{_sysconfdir}/X11/sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
install -c -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/pixmaps
install -c -m 644 cups-lpd.real $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.d/cups-lpd
install -c -m 644 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cups
install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{cups_serverbin}/backend/ncp
install -c -m 755 %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/cups
install -c -m 755 %{SOURCE14} $RPM_BUILD_ROOT%{cups_serverbin}/filter/textonly
install -c -m 644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/cups/model/textonly.ppd
install -c -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/cups
install -c -m 755 %{SOURCE9} $RPM_BUILD_ROOT%{cups_serverbin}/backend/ncp
install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/cups
install -c -m 755 %{SOURCE11} $RPM_BUILD_ROOT%{cups_serverbin}/filter/textonly
install -c -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/cups/model/textonly.ppd
# Ship pstopdf for LSPP systems to deal with malicious postscript
%if %lspp
@ -516,8 +508,10 @@ rm -rf $RPM_BUILD_ROOT
%{php_extdir}/phpcups.so
%changelog
* Tue Nov 10 2009 Tim Waugh <twaugh@redhat.com>
* Tue Nov 10 2009 Tim Waugh <twaugh@redhat.com> 1:1.4.2-1
- 1.4.2. No longer need str3380, str3332, str3356, str3396 patches.
- Removed postscript.ppd.gz (bug #533371).
- Renumbered patches and sources.
* Tue Nov 3 2009 Tim Waugh <twaugh@redhat.com> 1:1.4.1-13
- Removed stale patch from STR #2831 which was causing problems with

View File

@ -1,2 +1 @@
b0bb017098e8e76b8a25e666c41ce540 postscript.ppd.gz
587a58039c112ecb3c932e048c8a7b01 cups-1.4.1-source.tar.bz2
d95e2d588e3d36e563027a963b117b1b cups-1.4.2-source.tar.bz2