2047665 - cups-2.4.1 is available

This commit is contained in:
Zdenek Dohnal 2022-02-07 10:36:40 +01:00
parent db94fec396
commit 3ef4fd2c2d
7 changed files with 64 additions and 147 deletions

1
.gitignore vendored
View File

@ -96,3 +96,4 @@ cups-1.4.4-source.tar.bz2
/cups-2.3.3op1-source.tar.gz /cups-2.3.3op1-source.tar.gz
/cups-2.3.3op2-source.tar.gz /cups-2.3.3op2-source.tar.gz
/cups-2.4.0-source.tar.gz /cups-2.4.0-source.tar.gz
/cups-2.4.1-source.tar.gz

View File

@ -1,38 +0,0 @@
From d9924186325c89aefa56e36258f56f246dd2c4ad Mon Sep 17 00:00:00 2001
From: Richard Lescak <rlescak@redhat.com>
Date: Tue, 11 Jan 2022 10:53:34 +0100
Subject: [PATCH] cups/http.c,encode.c: Fix memory leaks
---
CHANGES.md | 3 ++-
cups/encode.c | 1 +
cups/http.c | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/cups/encode.c b/cups/encode.c
index 5bcbf6fe5..15b1c6b40 100644
--- a/cups/encode.c
+++ b/cups/encode.c
@@ -655,6 +655,7 @@ _cupsEncodeOption(
ippSetCollection(ipp, &attr, i, collection);
cupsEncodeOptions2(collection, num_cols, cols, IPP_TAG_JOB);
cupsFreeOptions(num_cols, cols);
+ ippDelete(collection);
break;
default :
diff --git a/cups/http.c b/cups/http.c
index bd41e6f8e..4b6a24bd3 100644
--- a/cups/http.c
+++ b/cups/http.c
@@ -4631,6 +4631,7 @@ http_tls_upgrade(http_t *http) /* I - HTTP connection */
* Restore the HTTP request data...
*/
+ httpClearFields(http);
memcpy(http->_fields, myhttp._fields, sizeof(http->_fields));
memcpy(http->fields, myhttp.fields, sizeof(http->fields));
--
2.31.1

View File

@ -1,27 +0,0 @@
From aa2507530076eaff042b096de55442dc8b665abb Mon Sep 17 00:00:00 2001
From: Zdenek Dohnal <zdohnal@redhat.com>
Date: Wed, 1 Dec 2021 12:00:16 +0100
Subject: [PATCH] de/index.html: Fix missing bracket (fixes issue #299)
The bracket was unintentionally removed by commit b76a97a.
---
CHANGES.md | 5 +++++
doc/de/index.html.in | 2 +-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/doc/de/index.html.in b/doc/de/index.html.in
index 30f7d288e..2b3f3a6b1 100644
--- a/doc/de/index.html.in
+++ b/doc/de/index.html.in
@@ -7,7 +7,7 @@
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=9">
<meta name="viewport" content="width=device-width">
- <title>Startseite - CUPS @CUPS_VERSION@/title>
+ <title>Startseite - CUPS @CUPS_VERSION@</title>
</head>
<body>
<div class="header">
--
2.33.1

View File

@ -1,6 +1,6 @@
diff -up cups-2.4.0/config.h.in.lspp cups-2.4.0/config.h.in diff -up cups-2.4.1/config.h.in.lspp cups-2.4.1/config.h.in
--- cups-2.4.0/config.h.in.lspp 2021-12-15 11:08:46.240015694 +0100 --- cups-2.4.1/config.h.in.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/config.h.in 2021-12-15 11:10:32.956049666 +0100 +++ cups-2.4.1/config.h.in 2022-02-07 08:14:29.583878197 +0100
@@ -684,6 +684,13 @@ static __inline int _cups_abs(int i) { r @@ -684,6 +684,13 @@ static __inline int _cups_abs(int i) { r
@ -15,9 +15,9 @@ diff -up cups-2.4.0/config.h.in.lspp cups-2.4.0/config.h.in
* Building as a snap (snapcraft.io)? * Building as a snap (snapcraft.io)?
*/ */
diff -up cups-2.4.0/config-scripts/cups-lspp.m4.lspp cups-2.4.0/config-scripts/cups-lspp.m4 diff -up cups-2.4.1/config-scripts/cups-lspp.m4.lspp cups-2.4.1/config-scripts/cups-lspp.m4
--- cups-2.4.0/config-scripts/cups-lspp.m4.lspp 2021-12-15 11:08:46.240015694 +0100 --- cups-2.4.1/config-scripts/cups-lspp.m4.lspp 2022-02-07 08:14:29.583878197 +0100
+++ cups-2.4.0/config-scripts/cups-lspp.m4 2021-12-15 11:08:46.240015694 +0100 +++ cups-2.4.1/config-scripts/cups-lspp.m4 2022-02-07 08:14:29.583878197 +0100
@@ -0,0 +1,36 @@ @@ -0,0 +1,36 @@
+dnl +dnl
+dnl LSPP code for the Common UNIX Printing System (CUPS). +dnl LSPP code for the Common UNIX Printing System (CUPS).
@ -55,9 +55,9 @@ diff -up cups-2.4.0/config-scripts/cups-lspp.m4.lspp cups-2.4.0/config-scripts/c
+ ;; + ;;
+ esac + esac
+fi +fi
diff -up cups-2.4.0/configure.ac.lspp cups-2.4.0/configure.ac diff -up cups-2.4.1/configure.ac.lspp cups-2.4.1/configure.ac
--- cups-2.4.0/configure.ac.lspp 2021-12-15 11:08:46.240015694 +0100 --- cups-2.4.1/configure.ac.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/configure.ac 2021-12-15 11:11:10.204061528 +0100 +++ cups-2.4.1/configure.ac 2022-02-07 08:14:29.583878197 +0100
@@ -40,6 +40,8 @@ sinclude(config-scripts/cups-container.m @@ -40,6 +40,8 @@ sinclude(config-scripts/cups-container.m
sinclude(config-scripts/cups-startup.m4) sinclude(config-scripts/cups-startup.m4)
sinclude(config-scripts/cups-defaults.m4) sinclude(config-scripts/cups-defaults.m4)
@ -67,9 +67,9 @@ diff -up cups-2.4.0/configure.ac.lspp cups-2.4.0/configure.ac
dnl See what languages are available and make sure we generate the localization dnl See what languages are available and make sure we generate the localization
dnl files as needed... dnl files as needed...
INSTALL_LANGUAGES="" INSTALL_LANGUAGES=""
diff -up cups-2.4.0/filter/common.c.lspp cups-2.4.0/filter/common.c diff -up cups-2.4.1/filter/common.c.lspp cups-2.4.1/filter/common.c
--- cups-2.4.0/filter/common.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/filter/common.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/filter/common.c 2021-12-15 11:08:46.240015694 +0100 +++ cups-2.4.1/filter/common.c 2022-02-07 08:14:29.584878189 +0100
@@ -11,6 +11,12 @@ @@ -11,6 +11,12 @@
* Include necessary headers... * Include necessary headers...
*/ */
@ -238,9 +238,9 @@ diff -up cups-2.4.0/filter/common.c.lspp cups-2.4.0/filter/common.c
/* /*
diff -up cups-2.4.0/filter/pstops.c.lspp cups-2.4.0/filter/pstops.c diff -up cups-2.4.1/filter/pstops.c.lspp cups-2.4.1/filter/pstops.c
--- cups-2.4.0/filter/pstops.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/filter/pstops.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/filter/pstops.c 2021-12-15 11:08:46.241015694 +0100 +++ cups-2.4.1/filter/pstops.c 2022-02-07 08:14:29.584878189 +0100
@@ -3170,6 +3170,18 @@ write_label_prolog(pstops_doc_t *doc, /* @@ -3170,6 +3170,18 @@ write_label_prolog(pstops_doc_t *doc, /*
{ {
const char *classification; /* CLASSIFICATION environment variable */ const char *classification; /* CLASSIFICATION environment variable */
@ -396,10 +396,9 @@ diff -up cups-2.4.0/filter/pstops.c.lspp cups-2.4.0/filter/pstops.c
/* /*
diff -up cups-2.4.0/Makedefs.in.lspp cups-2.4.0/Makedefs.in diff -up cups-2.4.1/scheduler/client.c.lspp cups-2.4.1/scheduler/client.c
diff -up cups-2.4.0/scheduler/client.c.lspp cups-2.4.0/scheduler/client.c --- cups-2.4.1/scheduler/client.c.lspp 2022-01-27 12:11:42.000000000 +0100
--- cups-2.4.0/scheduler/client.c.lspp 2021-11-29 15:27:31.000000000 +0100 +++ cups-2.4.1/scheduler/client.c 2022-02-07 08:14:29.585878181 +0100
+++ cups-2.4.0/scheduler/client.c 2021-12-15 11:08:46.242015694 +0100
@@ -20,12 +20,20 @@ @@ -20,12 +20,20 @@
#define _HTTP_NO_PRIVATE #define _HTTP_NO_PRIVATE
#include "cupsd.h" #include "cupsd.h"
@ -619,9 +618,9 @@ diff -up cups-2.4.0/scheduler/client.c.lspp cups-2.4.0/scheduler/client.c
/* /*
* 'pipe_command()' - Pipe the output of a command to the remote client. * 'pipe_command()' - Pipe the output of a command to the remote client.
diff -up cups-2.4.0/scheduler/client.h.lspp cups-2.4.0/scheduler/client.h diff -up cups-2.4.1/scheduler/client.h.lspp cups-2.4.1/scheduler/client.h
--- cups-2.4.0/scheduler/client.h.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/client.h.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/client.h 2021-12-15 11:12:47.620092552 +0100 +++ cups-2.4.1/scheduler/client.h 2022-02-07 08:14:29.585878181 +0100
@@ -14,6 +14,13 @@ @@ -14,6 +14,13 @@
#endif /* HAVE_AUTHORIZATION_H */ #endif /* HAVE_AUTHORIZATION_H */
@ -658,9 +657,9 @@ diff -up cups-2.4.0/scheduler/client.h.lspp cups-2.4.0/scheduler/client.h
#ifdef HAVE_TLS #ifdef HAVE_TLS
extern int cupsdEndTLS(cupsd_client_t *con); extern int cupsdEndTLS(cupsd_client_t *con);
extern int cupsdStartTLS(cupsd_client_t *con); extern int cupsdStartTLS(cupsd_client_t *con);
diff -up cups-2.4.0/scheduler/conf.c.lspp cups-2.4.0/scheduler/conf.c diff -up cups-2.4.1/scheduler/conf.c.lspp cups-2.4.1/scheduler/conf.c
--- cups-2.4.0/scheduler/conf.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/conf.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/conf.c 2021-12-15 11:08:46.242015694 +0100 +++ cups-2.4.1/scheduler/conf.c 2022-02-07 08:14:29.585878181 +0100
@@ -38,6 +38,9 @@ @@ -38,6 +38,9 @@
# define INADDR_NONE 0xffffffff # define INADDR_NONE 0xffffffff
#endif /* !INADDR_NONE */ #endif /* !INADDR_NONE */
@ -757,9 +756,9 @@ diff -up cups-2.4.0/scheduler/conf.c.lspp cups-2.4.0/scheduler/conf.c
/* /*
* 'read_policy()' - Read a <Policy name> definition. * 'read_policy()' - Read a <Policy name> definition.
diff -up cups-2.4.0/scheduler/conf.h.lspp cups-2.4.0/scheduler/conf.h diff -up cups-2.4.1/scheduler/conf.h.lspp cups-2.4.1/scheduler/conf.h
--- cups-2.4.0/scheduler/conf.h.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/conf.h.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/conf.h 2021-12-15 11:13:42.460110008 +0100 +++ cups-2.4.1/scheduler/conf.h 2022-02-07 08:14:29.586878172 +0100
@@ -242,6 +242,13 @@ VAR char *ServerKeychain VALUE(NULL); @@ -242,6 +242,13 @@ VAR char *ServerKeychain VALUE(NULL);
/* Keychain holding cert + key */ /* Keychain holding cert + key */
#endif /* HAVE_TLS */ #endif /* HAVE_TLS */
@ -784,9 +783,9 @@ diff -up cups-2.4.0/scheduler/conf.h.lspp cups-2.4.0/scheduler/conf.h
/* /*
* Prototypes... * Prototypes...
diff -up cups-2.4.0/scheduler/cupsd.h.lspp cups-2.4.0/scheduler/cupsd.h diff -up cups-2.4.1/scheduler/cupsd.h.lspp cups-2.4.1/scheduler/cupsd.h
--- cups-2.4.0/scheduler/cupsd.h.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/cupsd.h.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/cupsd.h 2021-12-15 11:08:46.243015695 +0100 +++ cups-2.4.1/scheduler/cupsd.h 2022-02-07 08:14:29.586878172 +0100
@@ -8,6 +8,8 @@ @@ -8,6 +8,8 @@
* information. * information.
*/ */
@ -811,9 +810,9 @@ diff -up cups-2.4.0/scheduler/cupsd.h.lspp cups-2.4.0/scheduler/cupsd.h
#include "mime.h" #include "mime.h"
#if defined(HAVE_CDSASSL) #if defined(HAVE_CDSASSL)
diff -up cups-2.4.0/scheduler/ipp.c.lspp cups-2.4.0/scheduler/ipp.c diff -up cups-2.4.1/scheduler/ipp.c.lspp cups-2.4.1/scheduler/ipp.c
--- cups-2.4.0/scheduler/ipp.c.lspp 2021-12-15 11:08:46.230015691 +0100 --- cups-2.4.1/scheduler/ipp.c.lspp 2022-02-07 08:14:29.559878397 +0100
+++ cups-2.4.0/scheduler/ipp.c 2021-12-15 11:08:46.247015696 +0100 +++ cups-2.4.1/scheduler/ipp.c 2022-02-07 08:14:29.588878156 +0100
@@ -12,6 +12,9 @@ @@ -12,6 +12,9 @@
* information. * information.
*/ */
@ -1427,10 +1426,10 @@ diff -up cups-2.4.0/scheduler/ipp.c.lspp cups-2.4.0/scheduler/ipp.c
/* /*
* Check the username against the owner... * Check the username against the owner...
*/ */
diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c diff -up cups-2.4.1/scheduler/job.c.lspp cups-2.4.1/scheduler/job.c
--- cups-2.4.0/scheduler/job.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/job.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/job.c 2021-12-15 11:08:46.248015696 +0100 +++ cups-2.4.1/scheduler/job.c 2022-02-07 08:15:43.118252372 +0100
@@ -8,6 +8,9 @@ @@ -9,6 +9,9 @@
* information. * information.
*/ */
@ -1440,7 +1439,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
/* /*
* Include necessary headers... * Include necessary headers...
*/ */
@@ -23,6 +26,14 @@ @@ -24,6 +27,14 @@
# endif /* HAVE_IOKIT_PWR_MGT_IOPMLIBPRIVATE_H */ # endif /* HAVE_IOKIT_PWR_MGT_IOPMLIBPRIVATE_H */
#endif /* __APPLE__ */ #endif /* __APPLE__ */
@ -1455,10 +1454,10 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
/* /*
* Design Notes for Job Management * Design Notes for Job Management
@@ -545,6 +556,14 @@ cupsdContinueJob(cupsd_job_t *job) /* I @@ -544,6 +555,14 @@ cupsdContinueJob(cupsd_job_t *job) /* I
/* PRINTER env variable */
*printer_state_reasons = NULL;
/* PRINTER_STATE_REASONS env var */ /* PRINTER_STATE_REASONS env var */
rip_max_cache[255];
/* RIP_MAX_CACHE env variable */
+#ifdef WITH_LSPP +#ifdef WITH_LSPP
+ char *audit_message = NULL; /* Audit message string */ + char *audit_message = NULL; /* Audit message string */
+ context_t jobcon; /* SELinux context of the job */ + context_t jobcon; /* SELinux context of the job */
@ -1470,7 +1469,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
cupsdLogMessage(CUPSD_LOG_DEBUG2, cupsdLogMessage(CUPSD_LOG_DEBUG2,
@@ -1065,6 +1084,67 @@ cupsdContinueJob(cupsd_job_t *job) /* I @@ -1063,6 +1082,67 @@ cupsdContinueJob(cupsd_job_t *job) /* I
if (final_content_type[0]) if (final_content_type[0])
envp[envc ++] = final_content_type; envp[envc ++] = final_content_type;
@ -1538,7 +1537,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
if (Classification && !banner_page) if (Classification && !banner_page)
{ {
if ((attr = ippFindAttribute(job->attrs, "job-sheets", if ((attr = ippFindAttribute(job->attrs, "job-sheets",
@@ -1843,6 +1923,22 @@ cupsdLoadJob(cupsd_job_t *job) /* I - J @@ -1841,6 +1921,22 @@ cupsdLoadJob(cupsd_job_t *job) /* I - J
ippSetString(job->attrs, &job->reasons, 0, "none"); ippSetString(job->attrs, &job->reasons, 0, "none");
} }
@ -1561,7 +1560,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
job->impressions = ippFindAttribute(job->attrs, "job-impressions-completed", IPP_TAG_INTEGER); job->impressions = ippFindAttribute(job->attrs, "job-impressions-completed", IPP_TAG_INTEGER);
job->sheets = ippFindAttribute(job->attrs, "job-media-sheets-completed", IPP_TAG_INTEGER); job->sheets = ippFindAttribute(job->attrs, "job-media-sheets-completed", IPP_TAG_INTEGER);
job->job_sheets = ippFindAttribute(job->attrs, "job-sheets", IPP_TAG_NAME); job->job_sheets = ippFindAttribute(job->attrs, "job-sheets", IPP_TAG_NAME);
@@ -2251,6 +2347,14 @@ cupsdSaveJob(cupsd_job_t *job) /* I - J @@ -2249,6 +2345,14 @@ cupsdSaveJob(cupsd_job_t *job) /* I - J
{ {
char filename[1024]; /* Job control filename */ char filename[1024]; /* Job control filename */
cups_file_t *fp; /* Job file */ cups_file_t *fp; /* Job file */
@ -1576,7 +1575,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
cupsdLogMessage(CUPSD_LOG_DEBUG2, "cupsdSaveJob(job=%p(%d)): job->attrs=%p", cupsdLogMessage(CUPSD_LOG_DEBUG2, "cupsdSaveJob(job=%p(%d)): job->attrs=%p",
@@ -2273,6 +2377,78 @@ cupsdSaveJob(cupsd_job_t *job) /* I - J @@ -2271,6 +2375,78 @@ cupsdSaveJob(cupsd_job_t *job) /* I - J
fchown(cupsFileNumber(fp), RunUser, Group); fchown(cupsFileNumber(fp), RunUser, Group);
@ -1655,7 +1654,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
job->attrs->state = IPP_IDLE; job->attrs->state = IPP_IDLE;
if (ippWriteIO(fp, (ipp_iocb_t)cupsFileWrite, 1, NULL, if (ippWriteIO(fp, (ipp_iocb_t)cupsFileWrite, 1, NULL,
@@ -3972,6 +4148,19 @@ get_options(cupsd_job_t *job, /* I - Jo @@ -3970,6 +4146,19 @@ get_options(cupsd_job_t *job, /* I - Jo
banner_page) banner_page)
continue; continue;
@ -1675,7 +1674,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
/* /*
* Otherwise add them to the list... * Otherwise add them to the list...
*/ */
@@ -4782,6 +4971,18 @@ start_job(cupsd_job_t *job, /* I - @@ -4780,6 +4969,18 @@ start_job(cupsd_job_t *job, /* I -
cupsd_printer_t *printer) /* I - Printer to print job */ cupsd_printer_t *printer) /* I - Printer to print job */
{ {
const char *filename; /* Support filename */ const char *filename; /* Support filename */
@ -1694,7 +1693,7 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
ipp_attribute_t *cancel_after = ippFindAttribute(job->attrs, ipp_attribute_t *cancel_after = ippFindAttribute(job->attrs,
"job-cancel-after", "job-cancel-after",
IPP_TAG_INTEGER); IPP_TAG_INTEGER);
@@ -4970,6 +5171,113 @@ start_job(cupsd_job_t *job, /* I - @@ -4968,6 +5169,113 @@ start_job(cupsd_job_t *job, /* I -
fcntl(job->side_pipes[1], F_SETFD, fcntl(job->side_pipes[1], F_SETFD,
fcntl(job->side_pipes[1], F_GETFD) | FD_CLOEXEC); fcntl(job->side_pipes[1], F_GETFD) | FD_CLOEXEC);
@ -1808,9 +1807,9 @@ diff -up cups-2.4.0/scheduler/job.c.lspp cups-2.4.0/scheduler/job.c
/* /*
* Now start the first file in the job... * Now start the first file in the job...
*/ */
diff -up cups-2.4.0/scheduler/job.h.lspp cups-2.4.0/scheduler/job.h diff -up cups-2.4.1/scheduler/job.h.lspp cups-2.4.1/scheduler/job.h
--- cups-2.4.0/scheduler/job.h.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/job.h.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/job.h 2021-12-15 11:08:46.249015697 +0100 +++ cups-2.4.1/scheduler/job.h 2022-02-07 08:14:29.590878139 +0100
@@ -7,6 +7,13 @@ @@ -7,6 +7,13 @@
* Licensed under Apache License v2.0. See the file "LICENSE" for more information. * Licensed under Apache License v2.0. See the file "LICENSE" for more information.
*/ */
@ -1836,9 +1835,9 @@ diff -up cups-2.4.0/scheduler/job.h.lspp cups-2.4.0/scheduler/job.h
}; };
typedef struct cupsd_joblog_s /**** Job log message ****/ typedef struct cupsd_joblog_s /**** Job log message ****/
diff -up cups-2.4.0/scheduler/main.c.lspp cups-2.4.0/scheduler/main.c diff -up cups-2.4.1/scheduler/main.c.lspp cups-2.4.1/scheduler/main.c
--- cups-2.4.0/scheduler/main.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/main.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/main.c 2021-12-15 11:08:46.249015697 +0100 +++ cups-2.4.1/scheduler/main.c 2022-02-07 08:14:29.590878139 +0100
@@ -58,6 +58,9 @@ @@ -58,6 +58,9 @@
# include <sys/param.h> # include <sys/param.h>
#endif /* HAVE_SYS_PARAM_H */ #endif /* HAVE_SYS_PARAM_H */
@ -1897,9 +1896,9 @@ diff -up cups-2.4.0/scheduler/main.c.lspp cups-2.4.0/scheduler/main.c
return (!stop_scheduler); return (!stop_scheduler);
} }
diff -up cups-2.4.0/scheduler/printers.c.lspp cups-2.4.0/scheduler/printers.c diff -up cups-2.4.1/scheduler/printers.c.lspp cups-2.4.1/scheduler/printers.c
--- cups-2.4.0/scheduler/printers.c.lspp 2021-11-29 15:27:31.000000000 +0100 --- cups-2.4.1/scheduler/printers.c.lspp 2022-01-27 12:11:42.000000000 +0100
+++ cups-2.4.0/scheduler/printers.c 2021-12-15 11:08:46.249015697 +0100 +++ cups-2.4.1/scheduler/printers.c 2022-02-07 08:14:29.591878131 +0100
@@ -9,6 +9,8 @@ @@ -9,6 +9,8 @@
* information. * information.
*/ */

View File

@ -1,13 +0,0 @@
diff --git a/config-scripts/cups-defaults.m4 b/config-scripts/cups-defaults.m4
index d153fbc..ecbb291 100644
--- a/config-scripts/cups-defaults.m4
+++ b/config-scripts/cups-defaults.m4
@@ -10,7 +10,7 @@ dnl information.
dnl
dnl Set a default systemd WantedBy directive
-SYSTEMD_WANTED_BY="printers.target"
+SYSTEMD_WANTED_BY="printer.target"
dnl Default languages...
LANGUAGES="$(ls -1 locale/cups_*.po 2>/dev/null | sed -e '1,$s/locale\/cups_//' -e '1,$s/\.po//' | tr '\n' ' ')"

View File

@ -14,8 +14,8 @@
Summary: CUPS printing system Summary: CUPS printing system
Name: cups Name: cups
Epoch: 1 Epoch: 1
Version: 2.4.0 Version: 2.4.1
Release: 3%{?dist} Release: 1%{?dist}
License: ASL 2.0 License: ASL 2.0
Url: https://openprinting.github.io/cups/ Url: https://openprinting.github.io/cups/
# Apple stopped uploading the new versions into github, use OpenPrinting fork # Apple stopped uploading the new versions into github, use OpenPrinting fork
@ -67,11 +67,6 @@ Patch100: cups-lspp.patch
%endif %endif
#### UPSTREAM PATCHES (starts with 1000) #### #### UPSTREAM PATCHES (starts with 1000) ####
Patch1000: cups-service-typo.patch
Patch1001: 0001-de-index.html-Fix-missing-bracket-fixes-issue-299.patch
# Memory leak fixes
# https://github.com/OpenPrinting/cups/pull/322
Patch1002: 0001-cups-http-encode-memleaks-fixes-issue-322.patch
##### Patches removed because IMHO they aren't no longer needed ##### Patches removed because IMHO they aren't no longer needed
##### but still I'll leave them in git in case their removal ##### but still I'll leave them in git in case their removal
@ -272,9 +267,6 @@ to CUPS daemon. This solution will substitute printer drivers and raw queues in
%patch13 -p1 -b .dymo-deviceid %patch13 -p1 -b .dymo-deviceid
# UPSTREAM PATCHES # UPSTREAM PATCHES
%patch1000 -p1 -b .service-typo
%patch1001 -p1 -b .de-index-missing-bracket
%patch1002 -p1 -b .memleak-fixes
%if %{lspp} %if %{lspp}
@ -656,6 +648,9 @@ rm -f %{cups_serverbin}/backend/smb
%{_mandir}/man7/ippeveps.7.gz %{_mandir}/man7/ippeveps.7.gz
%changelog %changelog
* Mon Feb 07 2022 Zdenek Dohnal <zdohnal@redhat.com> - 1:2.4.1-1
- 2047665 - cups-2.4.1 is available
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.4.0-3 * Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1:2.4.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (cups-2.4.0-source.tar.gz) = f86daaee5a3be76f5643bfb59b862de80d821256e16c74a82b0c37b5f488a422c76775ecd23554367ea62e61119386afe3f1e2660813b732ef66bea69a5eec9f SHA512 (cups-2.4.1-source.tar.gz) = 74e83728fcc3baf709176442b26711250fd4d4ede1e81e35b02a5607711067e28cd5a05d5bc3337953f6b2236c5a429b13f3a7f1218a08a2d3c30a8c9b0d96fd