1.5rc1
This commit is contained in:
parent
ab7ce8068f
commit
24f46305c8
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@ cups-1.4.4-source.tar.bz2
|
|||||||
/cups-1.4.6-source.tar.bz2
|
/cups-1.4.6-source.tar.bz2
|
||||||
/cups-1.5b1-source.tar.bz2
|
/cups-1.5b1-source.tar.bz2
|
||||||
/cups-1.5b2-source.tar.bz2
|
/cups-1.5b2-source.tar.bz2
|
||||||
|
/cups-1.5rc1-source.tar.bz2
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff -up cups-1.5b2/config-scripts/cups-common.m4.15b-workaround cups-1.5b2/config-scripts/cups-common.m4
|
|
||||||
--- cups-1.5b2/config-scripts/cups-common.m4.15b-workaround 2011-05-26 14:39:11.000000000 +0200
|
|
||||||
+++ cups-1.5b2/config-scripts/cups-common.m4 2011-05-26 15:19:35.000000000 +0200
|
|
||||||
@@ -406,7 +406,7 @@ AC_ARG_WITH(components, [ --with-compon
|
|
||||||
|
|
||||||
case "$COMPONENTS" in
|
|
||||||
all)
|
|
||||||
- BUILDDIRS="filter backend berkeley cgi-bin driver monitor notifier ppdc scheduler systemv conf data locale man doc examples templates"
|
|
||||||
+ BUILDDIRS="filter backend berkeley cgi-bin driver monitor notifier ppdc scheduler systemv conf data locale man doc examples templates desktop"
|
|
||||||
;;
|
|
||||||
|
|
||||||
core)
|
|
||||||
diff -up cups-1.5b2/scheduler/client.c.15b-workaround cups-1.5b2/scheduler/client.c
|
|
||||||
--- cups-1.5b2/scheduler/client.c.15b-workaround 2011-05-20 05:49:49.000000000 +0200
|
|
||||||
+++ cups-1.5b2/scheduler/client.c 2011-05-26 15:17:34.000000000 +0200
|
|
||||||
@@ -3220,7 +3220,7 @@ encrypt_client(cupsd_client_t *con) /* I
|
|
||||||
gnutls_certificate_set_x509_key_file(*credentials, ServerCertificate,
|
|
||||||
ServerKey, GNUTLS_X509_FMT_PEM);
|
|
||||||
|
|
||||||
- gnutls_init(&con->http.tls), GNUTLS_SERVER);
|
|
||||||
+ gnutls_init(&con->http.tls, GNUTLS_SERVER);
|
|
||||||
gnutls_set_default_priority(con->http.tls);
|
|
||||||
gnutls_credentials_set(con->http.tls, GNUTLS_CRD_CERTIFICATE, *credentials);
|
|
||||||
gnutls_transport_set_ptr(con->http.tls, (gnutls_transport_ptr)HTTP(con));
|
|
@ -797,9 +797,9 @@ diff --git a/scheduler/printers.c b/scheduler/printers.c
|
|||||||
index 9b876e3..cfb0db3 100644
|
index 9b876e3..cfb0db3 100644
|
||||||
--- a/scheduler/printers.c
|
--- a/scheduler/printers.c
|
||||||
+++ b/scheduler/printers.c
|
+++ b/scheduler/printers.c
|
||||||
@@ -77,6 +77,9 @@
|
@@ -80,6 +80,9 @@
|
||||||
# include <sys/vfs.h>
|
# include <asl.h>
|
||||||
#endif /* HAVE_SYS_VFS_H */
|
#endif /* __APPLE__ */
|
||||||
|
|
||||||
+#ifdef HAVE_DBUS
|
+#ifdef HAVE_DBUS
|
||||||
+# include "colord.h"
|
+# include "colord.h"
|
||||||
|
@ -1,67 +0,0 @@
|
|||||||
diff -up cups-1.5b1/backend/ieee1284.c.usb-parallel cups-1.5b1/backend/ieee1284.c
|
|
||||||
--- cups-1.5b1/backend/ieee1284.c.usb-parallel 2011-05-20 05:49:49.000000000 +0200
|
|
||||||
+++ cups-1.5b1/backend/ieee1284.c 2011-05-24 17:56:40.000000000 +0200
|
|
||||||
@@ -65,7 +65,7 @@ backendGetDeviceID(
|
|
||||||
# if defined(__sun) && defined(ECPPIOC_GETDEVID)
|
|
||||||
struct ecpp_device_id did; /* Device ID buffer */
|
|
||||||
# endif /* __sun && ECPPIOC_GETDEVID */
|
|
||||||
-
|
|
||||||
+ char *c;
|
|
||||||
|
|
||||||
DEBUG_printf(("backendGetDeviceID(fd=%d, device_id=%p, device_id_size=%d, "
|
|
||||||
"make_model=%p, make_model_size=%d, scheme=\"%s\", "
|
|
||||||
@@ -186,7 +186,7 @@ backendGetDeviceID(
|
|
||||||
* and then limit the length to the size of our buffer...
|
|
||||||
*/
|
|
||||||
|
|
||||||
- if (length > device_id_size)
|
|
||||||
+ if ((length > device_id_size) || (length < 14))
|
|
||||||
length = (((unsigned)device_id[1] & 255) << 8) +
|
|
||||||
((unsigned)device_id[0] & 255);
|
|
||||||
|
|
||||||
@@ -224,11 +224,16 @@ backendGetDeviceID(
|
|
||||||
device_id[length] = '\0';
|
|
||||||
}
|
|
||||||
}
|
|
||||||
-# ifdef DEBUG
|
|
||||||
else
|
|
||||||
+ {
|
|
||||||
+# ifdef DEBUG
|
|
||||||
+
|
|
||||||
DEBUG_printf(("backendGetDeviceID: ioctl failed - %s\n",
|
|
||||||
strerror(errno)));
|
|
||||||
# endif /* DEBUG */
|
|
||||||
+ /* Clean up after failed attempt to get device ID */
|
|
||||||
+ *device_id = '\0';
|
|
||||||
+ }
|
|
||||||
# endif /* __linux */
|
|
||||||
|
|
||||||
# if defined(__sun) && defined(ECPPIOC_GETDEVID)
|
|
||||||
@@ -256,14 +261,24 @@ backendGetDeviceID(
|
|
||||||
# endif /* __sun && ECPPIOC_GETDEVID */
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * Check whether device ID is valid. Turn line breaks and tabs to spaces
|
|
||||||
+ * and abort device IDs with non-printable characters
|
|
||||||
+ */
|
|
||||||
+ for (c = device_id; *c; c++)
|
|
||||||
+ if (isspace(*c))
|
|
||||||
+ *c = ' ';
|
|
||||||
+ else if (!isprint(*c))
|
|
||||||
+ {
|
|
||||||
+ *device_id = '\0';
|
|
||||||
+ break;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
DEBUG_printf(("backendGetDeviceID: device_id=\"%s\"\n", device_id));
|
|
||||||
|
|
||||||
if (scheme && uri)
|
|
||||||
*uri = '\0';
|
|
||||||
|
|
||||||
- if (!*device_id)
|
|
||||||
- return (-1);
|
|
||||||
-
|
|
||||||
/*
|
|
||||||
* Get the make and model...
|
|
||||||
*/
|
|
15
cups.spec
15
cups.spec
@ -10,12 +10,12 @@
|
|||||||
# but we use lib for compatibility with 3rd party drivers (at upstream request).
|
# but we use lib for compatibility with 3rd party drivers (at upstream request).
|
||||||
%global cups_serverbin %{_exec_prefix}/lib/cups
|
%global cups_serverbin %{_exec_prefix}/lib/cups
|
||||||
|
|
||||||
%global alphatag b2
|
%global alphatag rc1
|
||||||
|
|
||||||
Summary: Common Unix Printing System
|
Summary: Common Unix Printing System
|
||||||
Name: cups
|
Name: cups
|
||||||
Version: 1.5
|
Version: 1.5
|
||||||
Release: 0.6.%{alphatag}%{?dist}
|
Release: 0.7.%{alphatag}%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
Source: http://ftp.easysw.com/pub/cups/%{version}%{alphatag}/cups-%{version}%{alphatag}-source.tar.bz2
|
||||||
@ -66,10 +66,10 @@ Patch26: cups-snmp-quirks.patch
|
|||||||
Patch27: cups-hp-deviceid-oid.patch
|
Patch27: cups-hp-deviceid-oid.patch
|
||||||
Patch28: cups-dnssd-deviceid.patch
|
Patch28: cups-dnssd-deviceid.patch
|
||||||
Patch29: cups-ricoh-deviceid-oid.patch
|
Patch29: cups-ricoh-deviceid-oid.patch
|
||||||
Patch30: cups-usb-parallel.patch
|
|
||||||
Patch31: cups-avahi.patch
|
Patch31: cups-avahi.patch
|
||||||
Patch32: cups-icc.patch
|
Patch32: cups-icc.patch
|
||||||
Patch33: cups-1.5b-workaround.patch
|
|
||||||
|
|
||||||
Patch100: cups-lspp.patch
|
Patch100: cups-lspp.patch
|
||||||
|
|
||||||
@ -271,16 +271,12 @@ Sends IPP requests to the specified URI and tests and/or displays the results.
|
|||||||
%patch28 -p1 -b .dnssd-deviceid
|
%patch28 -p1 -b .dnssd-deviceid
|
||||||
# Add an SNMP query for Ricoh's device ID OID (STR #3552).
|
# Add an SNMP query for Ricoh's device ID OID (STR #3552).
|
||||||
%patch29 -p1 -b .ricoh-deviceid-oid
|
%patch29 -p1 -b .ricoh-deviceid-oid
|
||||||
# Till's patch to fix USB-Parallel adapter cable problem (bug #624564).
|
|
||||||
%patch30 -p1 -b .usb-parallel
|
|
||||||
|
|
||||||
# Avahi support in the dnssd backend.
|
# Avahi support in the dnssd backend.
|
||||||
#%patch31 -p1 -b .avahi
|
#%patch31 -p1 -b .avahi
|
||||||
# ICC colord support.
|
# ICC colord support.
|
||||||
%patch32 -p1 -b .icc
|
%patch32 -p1 -b .icc
|
||||||
|
|
||||||
%patch33 -p1 -b .15b-workaround
|
|
||||||
|
|
||||||
%if %lspp
|
%if %lspp
|
||||||
# LSPP support.
|
# LSPP support.
|
||||||
%patch100 -p1 -b .lspp
|
%patch100 -p1 -b .lspp
|
||||||
@ -612,6 +608,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/ipptool.1.gz
|
%{_mandir}/man1/ipptool.1.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jun 15 2011 Jiri Popelka <jpopelka@redhat.com> 1:1.5-0.7.rc1
|
||||||
|
- 1.5rc1
|
||||||
|
|
||||||
* Sat Jun 04 2011 Richard Hughes <rhughes@redhat.com> 1:1.5-0.6.b2
|
* Sat Jun 04 2011 Richard Hughes <rhughes@redhat.com> 1:1.5-0.6.b2
|
||||||
- Updated colord patch with fixes from Tim Waugh.
|
- Updated colord patch with fixes from Tim Waugh.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user