- Sync with svn5706.
- No longer need localhost, str1740, str1758, str1736, str1776 patches.
This commit is contained in:
parent
dc85b541bf
commit
0bbee85568
@ -1,11 +1,16 @@
|
||||
--- cups-1.2rc1/backend/usb-unix.c.direct-usb 2006-04-04 15:57:47.000000000 +0100
|
||||
+++ cups-1.2rc1/backend/usb-unix.c 2006-04-04 15:58:26.000000000 +0100
|
||||
@@ -431,7 +431,7 @@
|
||||
|
||||
--- cups-1.2.1/backend/usb-unix.c.direct-usb 2006-07-04 17:50:28.000000000 +0100
|
||||
+++ cups-1.2.1/backend/usb-unix.c 2006-07-04 17:51:56.000000000 +0100
|
||||
@@ -327,12 +327,7 @@
|
||||
if (!strncmp(uri, "usb:/dev/", 9))
|
||||
#ifdef __linux
|
||||
- return (-1); /* Do not allow direct devices anymore */
|
||||
{
|
||||
- /*
|
||||
- * Do not allow direct devices anymore...
|
||||
- */
|
||||
-
|
||||
- errno = ENODEV;
|
||||
- return (-1);
|
||||
+ return (open(uri + 4, O_RDWR | O_EXCL));
|
||||
}
|
||||
else if (!strncmp(uri, "usb://", 6))
|
||||
{
|
||||
/*
|
||||
|
@ -1,17 +1,17 @@
|
||||
--- cups-1.2rc3/Makedefs.in.relro 2006-04-28 13:52:04.000000000 +0100
|
||||
+++ cups-1.2rc3/Makedefs.in 2006-04-28 13:52:22.000000000 +0100
|
||||
@@ -130,7 +130,7 @@
|
||||
IMGLIBS = @IMGLIBS@ -lm
|
||||
--- cups-1.2.1/Makedefs.in.relro 2006-07-04 17:52:05.000000000 +0100
|
||||
+++ cups-1.2.1/Makedefs.in 2006-07-04 17:52:54.000000000 +0100
|
||||
@@ -132,7 +132,7 @@
|
||||
IMGLIBS = @IMGLIBS@
|
||||
IMGFILTERS = @IMGFILTERS@
|
||||
LDFLAGS = -L../cups -L../filter $(RC_CFLAGS) $(ARCHFLAGS) \
|
||||
LDFLAGS = -L../cups -L../filter $(ARCHFLAGS) \
|
||||
- @LDFLAGS@ @PIEFLAGS@ $(OPTIM)
|
||||
+ @LDFLAGS@ @RELROFLAG@ @PIEFLAGS@ $(OPTIM)
|
||||
LINKCUPS = @LINKCUPS@ $(SSLLIBS)
|
||||
LINKCUPSIMAGE = @LINKCUPSIMAGE@
|
||||
LIBS = $(LINKCUPS) $(COMMONLIBS)
|
||||
--- cups-1.2rc3/config-scripts/cups-compiler.m4.relro 2006-04-28 13:51:49.000000000 +0100
|
||||
+++ cups-1.2rc3/config-scripts/cups-compiler.m4 2006-04-28 13:51:49.000000000 +0100
|
||||
@@ -79,6 +79,9 @@
|
||||
--- cups-1.2.1/config-scripts/cups-compiler.m4.relro 2006-07-04 17:52:05.000000000 +0100
|
||||
+++ cups-1.2.1/config-scripts/cups-compiler.m4 2006-07-04 17:52:05.000000000 +0100
|
||||
@@ -89,6 +89,9 @@
|
||||
CXXLIBS=""
|
||||
AC_SUBST(CXXLIBS)
|
||||
|
||||
@ -21,7 +21,7 @@
|
||||
PIEFLAGS=""
|
||||
AC_SUBST(PIEFLAGS)
|
||||
|
||||
@@ -98,6 +101,12 @@
|
||||
@@ -108,6 +111,12 @@
|
||||
|
||||
case $uname in
|
||||
Linux*)
|
||||
@ -32,5 +32,5 @@
|
||||
+ case $uname in
|
||||
+ Linux*)
|
||||
if test x$enable_pie = xyes; then
|
||||
PIEFLAGS="-pie -fpie"
|
||||
PIEFLAGS="-pie -fPIE"
|
||||
fi
|
||||
|
18
cups.spec
18
cups.spec
@ -5,7 +5,7 @@
|
||||
Summary: Common Unix Printing System
|
||||
Name: cups
|
||||
Version: 1.2.1
|
||||
Release: 16
|
||||
Release: 17
|
||||
License: GPL
|
||||
Group: System Environment/Daemons
|
||||
Source: ftp://ftp.easysw.com/pub/cups/%{version}/cups-%{version}-source.tar.bz2
|
||||
@ -20,6 +20,7 @@ Source10: ncp.backend
|
||||
Source11: cups.conf
|
||||
Source12: cups.cron
|
||||
Source13: pdftops.conf
|
||||
Patch0: cups-svn5706.patch
|
||||
Patch1: cups-1.1.15-initscript.patch
|
||||
Patch2: cups-no-gzip-man.patch
|
||||
Patch3: cups-1.1.16-system-auth.patch
|
||||
@ -28,13 +29,8 @@ Patch5: cups-ext.patch
|
||||
Patch6: cups-includeifexists.patch
|
||||
Patch7: cups-banners.patch
|
||||
Patch8: cups-str1705.patch
|
||||
Patch9: cups-localhost.patch
|
||||
Patch10: cups-str1740.patch
|
||||
Patch11: cups-serverbin-compat.patch
|
||||
Patch12: cups-locale.patch
|
||||
Patch13: cups-str1758.patch
|
||||
Patch14: cups-str1736.patch
|
||||
Patch15: cups-str1776.patch
|
||||
Patch16: cups-no-export-ssllibs.patch
|
||||
Patch17: cups-paps.patch
|
||||
Patch18: cups-language.patch
|
||||
@ -119,6 +115,7 @@ lpd emulation.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch0 -p1 -b .svn5706
|
||||
%patch1 -p1 -b .noinit
|
||||
%patch2 -p1 -b .no-gzip-man
|
||||
%patch3 -p1 -b .system-auth
|
||||
@ -127,13 +124,8 @@ lpd emulation.
|
||||
%patch6 -p1 -b .includeifexists
|
||||
%patch7 -p1 -b .banners
|
||||
%patch8 -p1 -b .str1705
|
||||
%patch9 -p1 -b .localhost
|
||||
%patch10 -p1 -b .str1740
|
||||
%patch11 -p1 -b .serverbin-compat
|
||||
%patch12 -p1 -b .locale
|
||||
%patch13 -p1 -b .str1758
|
||||
%patch14 -p1 -b .str1736
|
||||
%patch15 -p1 -b .str1776
|
||||
%patch16 -p1 -b .no-export-ssllibs
|
||||
%patch17 -p1 -b .paps
|
||||
%patch18 -p1 -b .language
|
||||
@ -401,6 +393,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{cups_serverbin}/daemon/cups-lpd
|
||||
|
||||
%changelog
|
||||
* Tue Jul 4 2006 Tim Waugh <twaugh@redhat.com> 1:1.2.1-17
|
||||
- Sync with svn5706.
|
||||
- No longer need localhost, str1740, str1758, str1736, str1776 patches.
|
||||
|
||||
* Thu Jun 29 2006 Tim Waugh <twaugh@redhat.com> 1:1.2.1-16
|
||||
- Bumped paps requirement.
|
||||
- Don't use texttopaps for application/* MIME types (bug #197214).
|
||||
|
Loading…
Reference in New Issue
Block a user