cryptominisat/cryptominisat-cmake.patch

46 lines
2.0 KiB
Diff

--- CMakeLists.txt.orig 2018-09-04 15:18:24.000000000 -0600
+++ CMakeLists.txt 2018-10-05 15:41:32.808943867 -0600
@@ -177,8 +177,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
add_definitions(-DNDEBUG)
- add_cxx_flag_if_supported("-fno-stack-protector")
- add_definitions(-D_FORTIFY_SOURCE=0)
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -283,14 +281,10 @@ if (NOT WIN32)
if(CMAKE_BUILD_TYPE STREQUAL "Release")
#add_cxx_flag_if_supported("-flto")
else()
- add_cxx_flag_if_supported("-mtune=native")
add_cxx_flag_if_supported("-Wall")
add_cxx_flag_if_supported("-Wextra")
add_cxx_flag_if_supported("-Wunused")
add_cxx_flag_if_supported("-Wsign-compare")
- if (NOT CMAKE_BUILD_TYPE STREQUAL "Release")
- add_cxx_flag_if_supported("-fno-omit-frame-pointer")
- endif()
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -302,7 +296,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Winit-self")
add_cxx_flag_if_supported("-Wparentheses")
add_cxx_flag_if_supported("-Wunreachable-code")
- add_cxx_flag_if_supported("-ggdb3")
endif()
endif()
@@ -322,10 +315,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------
-if (${CMAKE_SYSTEM_NAME} MATCHES "Linux" AND NOT SANITIZE)
- set(CMAKE_EXE_LINKER_FLAGS " ${CMAKE_EXE_LINKER_FLAGS} -Wl,--discard-all -Wl,--build-id=sha1")
-endif()
-
if ((${CMAKE_SYSTEM_NAME} MATCHES "Linux") OR (${CMAKE_SYSTEM_NAME} MATCHES "Darwin"))
if(STATICCOMPILE)
MESSAGE(STATUS "Compiling for static library use")