cryptominisat/cryptominisat-cmake.patch
2020-04-25 16:32:41 -06:00

41 lines
1.9 KiB
Diff

--- CMakeLists.txt.orig 2020-04-25 07:47:13.000000000 -0600
+++ CMakeLists.txt 2020-04-25 16:12:33.786301345 -0600
@@ -203,8 +203,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
add_definitions(-DNDEBUG)
- add_cxx_flag_if_supported("-fno-stack-protector")
- add_definitions(-D_FORTIFY_SOURCE=0)
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -322,9 +320,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Wextra")
add_cxx_flag_if_supported("-Wunused")
add_cxx_flag_if_supported("-Wsign-compare")
- if (NOT CMAKE_BUILD_TYPE STREQUAL "Release")
- add_cxx_flag_if_supported("-fno-omit-frame-pointer")
- endif()
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -338,7 +333,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Wunreachable-code")
add_cxx_flag_if_supported("-Wextra-semi-stmt")
add_cxx_flag_if_supported("-Wweak-vtables")
- add_cxx_flag_if_supported("-ggdb3")
# Apparently needed before OS X Maverics (2013)
#add_c_flag_if_supported("-stdlib=libc++")
@@ -361,10 +355,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------
-if (${CMAKE_SYSTEM_NAME} MATCHES "Linux" AND NOT SANITIZE)
- set(CMAKE_EXE_LINKER_FLAGS " ${CMAKE_EXE_LINKER_FLAGS} -Wl,--discard-all -Wl,--build-id=sha1")
-endif()
-
if ((${CMAKE_SYSTEM_NAME} MATCHES "Linux") OR (${CMAKE_SYSTEM_NAME} MATCHES "Darwin"))
if(NOT BUILD_SHARED_LIBS)
MESSAGE(STATUS "Compiling for static library use")