28 lines
919 B
Diff
28 lines
919 B
Diff
--- python/setup.py.in.orig 2020-07-06 15:45:41.000000000 -0600
|
|
+++ python/setup.py.in 2022-12-19 09:44:31.964206198 -0700
|
|
@@ -26,9 +26,8 @@
|
|
import sys
|
|
import os
|
|
import platform
|
|
-from distutils.core import setup, Extension
|
|
-from distutils import sysconfig
|
|
-from distutils.cmd import Command
|
|
+from setuptools import setup, Extension, Command
|
|
+import sysconfig
|
|
|
|
__PACKAGE_VERSION__ = "0.2.0"
|
|
__LIBRARY_VERSION__ = "${CMS_FULL_VERSION}"
|
|
@@ -59,10 +58,9 @@ def _init_posix(init):
|
|
Forces g++ instead of gcc on most systems
|
|
credits to eric jones (eric@enthought.com) (found at Google Groups)
|
|
"""
|
|
- def wrapper():
|
|
- init()
|
|
+ def wrapper(config_vars):
|
|
+ init(config_vars)
|
|
|
|
- config_vars = sysconfig.get_config_vars() # by reference
|
|
if config_vars["MACHDEP"].startswith("sun"):
|
|
# Sun needs forced gcc/g++ compilation
|
|
config_vars['CC'] = 'gcc'
|