cryptominisat/cryptominisat-cmake.patch
2018-08-08 20:13:47 -06:00

54 lines
2.3 KiB
Diff

--- CMakeLists.txt.orig 2018-08-05 07:17:15.000000000 -0600
+++ CMakeLists.txt 2018-08-08 20:08:10.858032991 -0600
@@ -177,8 +177,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
add_definitions(-DNDEBUG)
- add_cxx_flag_if_supported("-fno-stack-protector")
- add_definitions(-D_FORTIFY_SOURCE=0)
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -187,7 +185,6 @@ if (NOT MSVC)
add_compile_options( -pthread )
add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-O2>")
- add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-mtune=native>")
add_compile_options("$<$<CONFIG:RELEASE>:-O2>")
add_compile_options("$<$<CONFIG:RELEASE>:-g0>")
@@ -285,14 +282,10 @@ if (NOT WIN32)
if(CMAKE_BUILD_TYPE STREQUAL "Release")
#add_cxx_flag_if_supported("-flto")
else()
- add_cxx_flag_if_supported("-mtune=native")
add_cxx_flag_if_supported("-Wall")
add_cxx_flag_if_supported("-Wextra")
add_cxx_flag_if_supported("-Wunused")
add_cxx_flag_if_supported("-Wsign-compare")
- if (NOT CMAKE_BUILD_TYPE STREQUAL "Release")
- add_cxx_flag_if_supported("-fno-omit-frame-pointer")
- endif()
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -304,7 +297,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Winit-self")
add_cxx_flag_if_supported("-Wparentheses")
add_cxx_flag_if_supported("-Wunreachable-code")
- add_cxx_flag_if_supported("-ggdb3")
endif()
endif()
@@ -324,10 +316,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------
-if (${CMAKE_SYSTEM_NAME} MATCHES "Linux" AND NOT SANITIZE)
- set(CMAKE_EXE_LINKER_FLAGS " ${CMAKE_EXE_LINKER_FLAGS} -Wl,--discard-all -Wl,--build-id=sha1")
-endif()
-
if ((${CMAKE_SYSTEM_NAME} MATCHES "Linux") OR (${CMAKE_SYSTEM_NAME} MATCHES "Darwin"))
if(STATICCOMPILE)
MESSAGE(STATUS "Compiling for static library use")