New upstream release. Drop the python2 subpackage.

This commit is contained in:
Jerry James 2018-10-13 13:24:22 -06:00
parent 151f12ebfb
commit c5369b0c82
3 changed files with 21 additions and 49 deletions

View File

@ -1,5 +1,5 @@
--- CMakeLists.txt.orig 2018-08-05 07:17:15.000000000 -0600
+++ CMakeLists.txt 2018-08-08 20:08:10.858032991 -0600
--- CMakeLists.txt.orig 2018-09-04 15:18:24.000000000 -0600
+++ CMakeLists.txt 2018-10-05 15:41:32.808943867 -0600
@@ -177,8 +177,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
@ -9,15 +9,7 @@
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -187,7 +185,6 @@ if (NOT MSVC)
add_compile_options( -pthread )
add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-O2>")
- add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-mtune=native>")
add_compile_options("$<$<CONFIG:RELEASE>:-O2>")
add_compile_options("$<$<CONFIG:RELEASE>:-g0>")
@@ -285,14 +282,10 @@ if (NOT WIN32)
@@ -283,14 +281,10 @@ if (NOT WIN32)
if(CMAKE_BUILD_TYPE STREQUAL "Release")
#add_cxx_flag_if_supported("-flto")
else()
@ -32,7 +24,7 @@
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -304,7 +297,6 @@ if (NOT WIN32)
@@ -302,7 +296,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Winit-self")
add_cxx_flag_if_supported("-Wparentheses")
add_cxx_flag_if_supported("-Wunreachable-code")
@ -40,7 +32,7 @@
endif()
endif()
@@ -324,10 +316,6 @@ endif()
@@ -322,10 +315,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------

View File

@ -1,5 +1,5 @@
Name: cryptominisat
Version: 5.6.4
Version: 5.6.5
Release: 1%{?dist}
Summary: SAT solver
@ -15,7 +15,6 @@ BuildRequires: gcc-c++
BuildRequires: gperftools-devel
BuildRequires: help2man
BuildRequires: m4ri-devel
BuildRequires: python2-devel
BuildRequires: python3-devel
BuildRequires: tbb-devel
BuildRequires: zlib-devel
@ -40,6 +39,7 @@ Summary: Header files for developing with %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: m4ri-devel%{?_isa}
Requires: tbb-devel%{?_isa}
Requires: cmake-filesystem
# This can be removed once Fedora 28 reaches EOL
Obsoletes: cryptominisat4-devel < 4.5.4-1
@ -58,25 +58,20 @@ Provides: cryptominisat4-libs = %{version}-%{release}
%description libs
The %{name} library.
%package -n python2-%{name}
Summary: Python 2 interface to %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%{?python_provide:%python_provide python2-%{name}}
# This can be removed once Fedora 28 reaches EOL
Obsoletes: python2-cryptominisat4 < 4.5.4-1
Provides: python2-cryptominisat4 = %{version}-%{release}
%description -n python2-%{name}
Python 2 interface to %{name}.
%package -n python3-%{name}
Summary: Python 3 interface to %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%{?python_provide:%python_provide python3-%{name}}
# This can be removed once Fedora 28 reaches EOL
Obsoletes: python2-cryptominisat4 < 4.5.4-1
Provides: python2-cryptominisat4 = %{version}-%{release}
# This can be removed once Fedora 29 reaches EOL
Obsoletes: python2-%{name} < 5.6.5
Provides: python2-%{name} = %{version}-%{release}
%description -n python3-%{name}
Python 3 interface to %{name}.
@ -91,23 +86,11 @@ fi
# Fix the python install
sed -ri 's|install |&--root %{buildroot} |' python/CMakeLists.txt
# Prepare to build for both python 2 and 3
cp -a . ../python3
%build
%cmake -DCMAKE_INSTALL_LIBDIR=%{_lib} -DFORCE_PYTHON2=ON
%make_build
pushd ../python3
%cmake -DCMAKE_INSTALL_LIBDIR=%{_lib}
%make_build
popd
%install
pushd ../python3
%make_install
popd
%make_install
# Move cmake files to where they should go
@ -117,8 +100,6 @@ if [ "%{_libdir}" = "%{_prefix}/lib64" ]; then
%{buildroot}%{_libdir}/cmake/cryptominisat5/*.cmake
fi
%ldconfig_scriptlets libs
%files
%doc README.markdown
%{_bindir}/cryptominisat5
@ -128,24 +109,23 @@ fi
%files devel
%{_includedir}/cryptominisat5/
%{_libdir}/libcryptominisat5.so
%{_libdir}/cmake/
%{_libdir}/cmake/cryptominisat5/
%files libs
%doc AUTHORS
%license LICENSE.txt
%{_libdir}/libcryptominisat5.so.*
%files -n python2-%{name}
%doc python/README.rst
%license python/LICENSE
%{python2_sitearch}/pycryptosat*
%files -n python3-%{name}
%doc python/README.rst
%license python/LICENSE
%{python3_sitearch}/pycryptosat*
%changelog
* Sat Oct 13 2018 Jerry James <loganjerry@gmail.com> - 5.6.5-1
- New upstream release
- Drop the python2 subpackage
* Wed Aug 8 2018 Jerry James <loganjerry@gmail.com> - 5.6.4-1
- New upstream release

View File

@ -1 +1 @@
SHA512 (cryptominisat-5.6.4.tar.gz) = ef18ae6044455f6157c46b891798e7f153278b209f72c4cff8da7b91ee0117c869b7642315b1084d15165ccd1a79fd37eefa7829ac5eed41501d099ef5e129ce
SHA512 (cryptominisat-5.6.5.tar.gz) = ee2e6154e91d824f82c0d3a926de447de404147e591b36ad12c7e97924704da2ba4a185c26d6d72e99ae17df1681ef20be9f6635e5dc8d6948b980000d8af2ae