Version 5.8.0.

This commit is contained in:
Jerry James 2020-11-27 08:20:25 -07:00
parent 9ccdfa836d
commit 9e4601117c
3 changed files with 37 additions and 22 deletions

View File

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2020-04-25 07:47:13.000000000 -0600
+++ CMakeLists.txt 2020-04-25 16:12:33.786301345 -0600
@@ -203,8 +203,6 @@ if (ENABLE_ASSERTIONS)
--- CMakeLists.txt.orig 2020-07-06 15:45:41.000000000 -0600
+++ CMakeLists.txt 2020-11-22 11:43:02.146650954 -0700
@@ -210,8 +210,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
add_definitions(-DNDEBUG)
@ -9,7 +9,7 @@
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -322,9 +320,6 @@ if (NOT WIN32)
@@ -330,9 +328,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Wextra")
add_cxx_flag_if_supported("-Wunused")
add_cxx_flag_if_supported("-Wsign-compare")
@ -19,15 +19,15 @@
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -338,7 +333,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Wunreachable-code")
@@ -350,7 +345,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-msse4.2")
add_cxx_flag_if_supported("-Wextra-semi-stmt")
add_cxx_flag_if_supported("-Wweak-vtables")
- add_cxx_flag_if_supported("-ggdb3")
# Apparently needed before OS X Maverics (2013)
#add_c_flag_if_supported("-stdlib=libc++")
@@ -361,10 +355,6 @@ endif()
@@ -373,10 +367,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------

View File

@ -1,6 +1,11 @@
# Cryptominisat is more efficient when it can use BreakID.
# BreakID bundles saucy.
# Saucy has a "noncommercial use only" clause in the license, so it is non-free.
# Therefore, we have to do without BreakID.
Name: cryptominisat
Version: 5.7.1
Release: 4%{?dist}
Version: 5.8.0
Release: 1%{?dist}
Summary: SAT solver
License: MIT
@ -16,6 +21,7 @@ BuildRequires: gperftools-devel
BuildRequires: help2man
BuildRequires: make
BuildRequires: pkgconfig(m4ri)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(tbb)
BuildRequires: pkgconfig(zlib)
BuildRequires: python3-devel
@ -36,7 +42,6 @@ Summary: Header files for developing with %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
Requires: m4ri-devel%{?_isa}
Requires: tbb-devel%{?_isa}
Requires: cmake-filesystem
%description devel
Header files for developing applications that use %{name}.
@ -51,8 +56,6 @@ The %{name} library.
Summary: Python 3 interface to %{name}
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
%{?python_provide:%python_provide python3-%{name}}
%description -n python3-%{name}
Python 3 interface to %{name}.
@ -64,23 +67,32 @@ if [ "%{_libdir}" = "%{_prefix}/lib64" ]; then
sed -i 's,${dir}/lib,&64,g' cmake/FindPkgMacros.cmake
fi
# Remove flags we do not want in Fedora
sed -e '/-Wno-class-memaccess/d' \
-e '/-mpopcnt/d' \
-e '/-msse4.2/d' \
-e '/-ggdb3/d' \
-i CMakeLists.txt
# Fix the python install
sed -ri 's|install |&--root %{buildroot} |' python/CMakeLists.txt
# Fix the install directory for cmake files on 64-bit systems
if [ "%{_lib}" != "lib" ]; then
sed -i 's,lib/cmake,%{_lib}/cmake,' CMakeLists.txt
fi
%build
%cmake -DCMAKE_INSTALL_LIBDIR=%{_lib}
%cmake \
-DCMAKE_INSTALL_BINDIR=bin \
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
-DEXTFEAT:BOOL=ON \
-DNOBREAKID:BOOL=ON
%cmake_build
%install
%cmake_install
# Move cmake files to where they should go
if [ "%{_lib}" = "lib64" ]; then
mv %{buildroot}%{_prefix}/lib/cmake %{buildroot}%{_libdir}
sed -i 's|%{_prefix}/lib/|%{_libdir}/|' \
%{buildroot}%{_libdir}/cmake/cryptominisat5/*.cmake
fi
%files
%doc README.markdown
%{_bindir}/cryptominisat5
@ -95,7 +107,7 @@ fi
%files libs
%doc AUTHORS
%license LICENSE.txt
%{_libdir}/libcryptominisat5.so.5.7
%{_libdir}/libcryptominisat5.so.5.8
%files -n python3-%{name}
%doc python/README.rst
@ -103,6 +115,9 @@ fi
%{python3_sitearch}/pycryptosat*
%changelog
* Fri Nov 27 2020 Jerry James <loganjerry@gmail.com> - 5.8.0-1
- Version 5.8.0
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.7.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (cryptominisat-5.7.1.tar.gz) = 00e19572241ab9d9b6e9c7f2ac85b46615392fc82a5fc38ee964324cc18038e70def3f8024d2ecf743d957ab7abf72226297b4fc058b0bf89238ba43fcc2fe2c
SHA512 (cryptominisat-5.8.0.tar.gz) = 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496