New upstream release.

This commit is contained in:
Jerry James 2018-12-24 14:47:58 -07:00
parent c5369b0c82
commit 2e267de53f
3 changed files with 15 additions and 12 deletions

View File

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2018-09-04 15:18:24.000000000 -0600
+++ CMakeLists.txt 2018-10-05 15:41:32.808943867 -0600
@@ -177,8 +177,6 @@ if (ENABLE_ASSERTIONS)
--- CMakeLists.txt.orig 2018-12-18 14:48:48.000000000 -0700
+++ CMakeLists.txt 2018-12-24 14:34:21.698019713 -0700
@@ -193,8 +193,6 @@ if (ENABLE_ASSERTIONS)
else()
# Note this definition doesn't appear in the cache variables.
add_definitions(-DNDEBUG)
@ -9,7 +9,7 @@
endif()
# Note: O3 gives slight speed increase, 1 more solved from SAT Comp'14 @ 3600s
@@ -283,14 +281,10 @@ if (NOT WIN32)
@@ -300,14 +298,10 @@ if (NOT WIN32)
if(CMAKE_BUILD_TYPE STREQUAL "Release")
#add_cxx_flag_if_supported("-flto")
else()
@ -24,15 +24,15 @@
add_cxx_flag_if_supported("-Wtype-limits")
add_cxx_flag_if_supported("-Wuninitialized")
add_cxx_flag_if_supported("-Wno-deprecated")
@@ -302,7 +296,6 @@ if (NOT WIN32)
@@ -319,7 +313,6 @@ if (NOT WIN32)
add_cxx_flag_if_supported("-Winit-self")
add_cxx_flag_if_supported("-Wparentheses")
add_cxx_flag_if_supported("-Wunreachable-code")
- add_cxx_flag_if_supported("-ggdb3")
endif()
endif()
@@ -322,10 +315,6 @@ endif()
# Apparently needed before OS X Maverics (2013)
#add_c_flag_if_supported("-stdlib=libc++")
@@ -342,10 +335,6 @@ endif()
# -----------------------------------------------------------------------------
# Uncomment these for static compilation under Linux (messes up Valgrind)
# -----------------------------------------------------------------------------
@ -41,5 +41,5 @@
-endif()
-
if ((${CMAKE_SYSTEM_NAME} MATCHES "Linux") OR (${CMAKE_SYSTEM_NAME} MATCHES "Darwin"))
if(STATICCOMPILE)
if(NOT BUILD_SHARED_LIBS)
MESSAGE(STATUS "Compiling for static library use")

View File

@ -1,5 +1,5 @@
Name: cryptominisat
Version: 5.6.5
Version: 5.6.6
Release: 1%{?dist}
Summary: SAT solver
@ -94,7 +94,7 @@ sed -ri 's|install |&--root %{buildroot} |' python/CMakeLists.txt
%make_install
# Move cmake files to where they should go
if [ "%{_libdir}" = "%{_prefix}/lib64" ]; then
if [ "%{_lib}" = "lib64" ]; then
mv %{buildroot}%{_prefix}/lib/cmake %{buildroot}%{_libdir}
sed -i 's|%{_prefix}/lib/|%{_libdir}/|' \
%{buildroot}%{_libdir}/cmake/cryptominisat5/*.cmake
@ -122,6 +122,9 @@ fi
%{python3_sitearch}/pycryptosat*
%changelog
* Mon Dec 24 2018 Jerry James <loganjerry@gmail.com> - 5.6.6-1
- New upstream release
* Sat Oct 13 2018 Jerry James <loganjerry@gmail.com> - 5.6.5-1
- New upstream release
- Drop the python2 subpackage

View File

@ -1 +1 @@
SHA512 (cryptominisat-5.6.5.tar.gz) = ee2e6154e91d824f82c0d3a926de447de404147e591b36ad12c7e97924704da2ba4a185c26d6d72e99ae17df1681ef20be9f6635e5dc8d6948b980000d8af2ae
SHA512 (cryptominisat-5.6.6.tar.gz) = b43d097b7b06fe85665167f7747f95aa4aa3e4ad30492fd641a42794d4e7cfc36b6b9afb17c6793921e165cbe539171d7aff121344be548c68c74eb4b039d7b2