cryptlib 3.4.3.1
This commit is contained in:
commit
1d3cf6abe9
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,3 +1,7 @@
|
||||
/cl343_fedora.zip
|
||||
/cryptlib-perlfiles.tar.gz
|
||||
/cryptlib-tests.tar.gz
|
||||
/cl3431_fedora.zip
|
||||
/cl3431_fedora.zip.sig
|
||||
/cryptlib.spec
|
||||
/nativepatch
|
||||
|
@ -5,15 +5,15 @@
|
||||
%global with_python3 0
|
||||
|
||||
Name: cryptlib
|
||||
Version: 3.4.3
|
||||
Release: 8%{?dist}
|
||||
Version: 3.4.3.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Security library and toolkit for encryption and authentication services
|
||||
|
||||
Group: System Environment/Libraries
|
||||
License: Sleepycat and OpenSSL
|
||||
URL: https://www.cs.auckland.ac.nz/~pgut001/cryptlib
|
||||
Source0: https://crypto-bone.com/fedora/cl343_fedora.zip
|
||||
Source1: https://crypto-bone.com/fedora/cl343_fedora.zip.sig
|
||||
Source0: https://crypto-bone.com/fedora/cl3431_fedora.zip
|
||||
Source1: https://crypto-bone.com/fedora/cl3431_fedora.zip.sig
|
||||
# for security reasons a public signing key should always be stored in distgit
|
||||
# and never be used with a URL to make impersonation attacks harder
|
||||
# (verified: https://senderek.ie/keys/codesigningkey)
|
||||
@ -21,17 +21,11 @@ Source2: gpgkey-3274CB29956498038A9C874BFBF6E2C28E9C98DD.asc
|
||||
Source3: https://crypto-bone.com/fedora/README-manual
|
||||
Source4: https://crypto-bone.com/fedora/cryptlib-tests.tar.gz
|
||||
Source5: https://crypto-bone.com/fedora/cryptlib-perlfiles.tar.gz
|
||||
Source6: renamesymbols
|
||||
Source7: COPYING
|
||||
|
||||
Patch1: sonamepatch
|
||||
# soname is now libcl.so.3
|
||||
Patch2: ccflagspatch
|
||||
Patch3: sessionpatch
|
||||
Patch4: utilspatch
|
||||
Patch5: stackprotectorstrongpatch
|
||||
Patch6: javapatch
|
||||
Patch7: testlibpatch
|
||||
# soname is now libcl.so.3.4
|
||||
Patch1: ccflagspatch
|
||||
Patch2: javapatch
|
||||
Patch3: nativepatch
|
||||
|
||||
ExclusiveArch: x86_64 %{ix86} %{arm}
|
||||
|
||||
@ -162,10 +156,6 @@ cd %{name}-%{version}
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
# remove pre-build jar file
|
||||
rm %{_builddir}/%{name}-%{version}/bindings/cryptlib.jar
|
||||
# adapt perl files in bindings
|
||||
@ -175,11 +165,12 @@ cd %{_builddir}/%{name}-%{version}/bindings
|
||||
|
||||
%build
|
||||
cd %{name}-%{version}
|
||||
# rename cryptlib symbols that may collide with openssl symbols
|
||||
%{SOURCE6}
|
||||
# build java bindings
|
||||
chmod +x tools/mkhdr.sh
|
||||
tools/mkhdr.sh
|
||||
# rename cryptlib symbols that may collide with openssl symbols
|
||||
chmod +x tools/rename.sh
|
||||
tools/rename.sh
|
||||
# build java bindings
|
||||
cp /etc/alternatives/java_sdk/include/jni.h .
|
||||
cp /etc/alternatives/java_sdk/include/linux/jni_md.h .
|
||||
|
||||
@ -211,8 +202,8 @@ mkdir -p %{buildroot}%{_datadir}/licenses/%{name}
|
||||
mkdir -p %{buildroot}%{_docdir}/%{name}
|
||||
cp %{_builddir}/%{name}-%{version}/libcl.so.3.4.3 %{buildroot}%{_libdir}
|
||||
cd %{buildroot}%{_libdir}
|
||||
ln -s libcl.so.3.4.3 libcl.so.3
|
||||
ln -s libcl.so.3 libcl.so
|
||||
ln -s libcl.so.3.4.3 libcl.so.3.4
|
||||
ln -s libcl.so.3.4 libcl.so
|
||||
|
||||
# install header files
|
||||
mkdir -p %{buildroot}/%{_includedir}/%{name}
|
||||
@ -226,8 +217,6 @@ mkdir -p %{buildroot}/%{_jnidir}
|
||||
cp %{_builddir}/%{name}-%{version}/bindings/cryptlib.jar %{buildroot}%{_jnidir}
|
||||
|
||||
# install docs
|
||||
# apply the new license text
|
||||
cp %{SOURCE7} %{_builddir}/%{name}-%{version}/COPYING
|
||||
cp %{_builddir}/%{name}-%{version}/COPYING %{buildroot}%{_datadir}/licenses/%{name}
|
||||
cp %{_builddir}/%{name}-%{version}/README %{buildroot}%{_docdir}/%{name}/README
|
||||
echo "No tests performed." > %{_builddir}/%{name}-%{version}/stestlib.log
|
||||
@ -253,6 +242,7 @@ mkdir -p %{buildroot}%{_mandir}/man3
|
||||
cd %{_builddir}/%{name}-%{version}/bindings
|
||||
mkdir -p %{_builddir}/include
|
||||
cp ../cryptlib.h %{_builddir}/include
|
||||
cp ../tools/GenPerl.pl .
|
||||
export PERL_CRYPT_LIB_HEADER=%{_builddir}/include/cryptlib.h
|
||||
/usr/bin/perl Makefile.PL
|
||||
sed -i '/LDLOADLIBS = /s/thread/thread -L.. -lcl/' Makefile
|
||||
@ -282,7 +272,7 @@ tar xpzf %{SOURCE4}
|
||||
# in KOJI tests must be disabled as there is no networking
|
||||
%if %{includetests}
|
||||
cd %{_builddir}/%{name}-%{version}
|
||||
ln -s libcl.so.3.4.3 ./libcl.so.3
|
||||
ln -s libcl.so.3.4.3 ./libcl.so.3.4
|
||||
export LD_LIBRARY_PATH=.
|
||||
echo "Running tests on the cryptlib library. This will take a few minutes."
|
||||
echo "Network access is necessary to complete all tests!"
|
||||
@ -298,7 +288,8 @@ tar xpzf %{SOURCE4}
|
||||
|
||||
%files
|
||||
%{_libdir}/libcl.so.3.4.3
|
||||
%{_libdir}/libcl.so.3
|
||||
%{_libdir}/libcl.so.3.4
|
||||
%{_libdir}/libcl.so
|
||||
|
||||
%license %{_datadir}/licenses/%{name}/COPYING
|
||||
%doc %{_docdir}/%{name}/README
|
||||
@ -336,6 +327,15 @@ tar xpzf %{SOURCE4}
|
||||
|
||||
%changelog
|
||||
|
||||
* Sat Feb 11 2017 Senderek Web Security <innovation@senderek.ie> - 3.4.3.1-1
|
||||
- update to version 3.4.3.1
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.4.3-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jan 31 2017 Senderek Web Security <innovation@senderek.ie> - 3.4.3-9
|
||||
- compile with gcc-7.0 and -march=native
|
||||
|
||||
* Tue Jul 26 2016 Senderek Web Security <innovation@senderek.ie> - 3.4.3-8
|
||||
- change license tag (RHBZ #1352406)
|
||||
- rename symbols that collide with openssl (RHBZ #1352404)
|
||||
|
9
sources
9
sources
@ -1,3 +1,6 @@
|
||||
88f0c8dd9ef139d281dffc259c3f8cdc cl343_fedora.zip
|
||||
025fde7fb122ab2e945fa5287d69f19b cryptlib-tests.tar.gz
|
||||
e90177946732f82d820cbf0a37e90a05 cryptlib-perlfiles.tar.gz
|
||||
SHA512 (cl3431_fedora.zip) = b3dda368e94b9d100476b602941e45a2aebf76d1716193a43a28e3e10573c84f55d03140275e71763a6f9f2f456b7b05fa104016e317345dffb1d3e20fd350b4
|
||||
SHA512 (cl3431_fedora.zip.sig) = da064ad012d50721657e10fa2250df7eb54e87081890629e6d4a0643c4137ae3261b8364f83633ef6bf72de4a3da618e79db6cd4e7d34538452fb585d26d62a9
|
||||
SHA512 (cryptlib-perlfiles.tar.gz) = b975d34acfd1d99a224bbd5536483e5489feac8801a567740ec668bcef9a1eff67fddbdad53f61b2ff48bd43396e92f070ebf4de622f3edeb70428f4aaae2ff6
|
||||
SHA512 (cryptlib-tests.tar.gz) = 83bc6061f0b76e5e46100a21965b8362ab1a2c1c4fcb8bcd7b87971f9f4fd59861685b47d72394f40295076f2b2d7993223c535ed21c8ea352551b65f71e1801
|
||||
SHA512 (cryptlib.spec) = 8e604f1824d1a82817c2c6b4d78d57b351de0e3256e7c1ed562168e41ccec6b66da7552aabe2c0acad9daab59a64eb9fc5d28a9aad1914b6d536edef2de2679d
|
||||
SHA512 (nativepatch) = bd57d1099c9650c0ec4848485308ff01c55f2e3663780fd12648507e627dbe6ca5ee6ca078d2364494a679aff17da59429fa846580a539ce3f6d5de3ebece966
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- cl-original/tools/ccopts.sh 2016-03-04 17:54:34.000000000 +0000
|
||||
+++ cl-patched/tools/ccopts.sh 2016-05-06 07:03:49.000000000 +0100
|
||||
--- cl-original/tools/ccopts.sh 2017-01-31 10:34:12.532287343 +0100
|
||||
+++ cl-patched/tools/ccopts.sh 2017-01-31 13:02:39.088072895 +0100
|
||||
@@ -461,7 +461,7 @@
|
||||
CCARGS="$CCARGS -march=pentium" ;;
|
||||
esac ;
|
||||
else
|
||||
- CCARGS="$CCARGS -mcpu=pentium" ;
|
||||
+ CCARGS="$CCARGS -march=native" ;
|
||||
fi ;
|
||||
fi
|
||||
|
||||
@@ -604,7 +604,7 @@
|
||||
|
||||
if [ $GCC_VER -ge 42 ] ; then
|
||||
|
Loading…
Reference in New Issue
Block a user