Update to 1.83.

This commit is contained in:
Susi Lehtola 2018-04-14 16:49:48 +02:00
parent c00a51ea69
commit d4f19b3396
2 changed files with 23 additions and 21 deletions

View File

@ -1,13 +1,12 @@
diff -up cppcheck-1.81/cli/CMakeLists.txt.tinyxml cppcheck-1.81/cli/CMakeLists.txt
--- cppcheck-1.81/cli/CMakeLists.txt.tinyxml 2017-10-07 23:11:39.000000000 +0200
+++ cppcheck-1.81/cli/CMakeLists.txt 2017-10-18 16:40:18.898918748 +0200
@@ -1,5 +1,4 @@
--- cppcheck-1.83.orig/cli/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
+++ cppcheck-1.83.orig/cli/CMakeLists.txt 2018-04-12 12:46:04.990212969 -0400
@@ -1,5 +1,4 @@
include_directories(${PROJECT_SOURCE_DIR}/lib/)
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
include_directories(${PROJECT_SOURCE_DIR}/externals/simplecpp/)
file(GLOB hdrs "*.h")
@@ -8,10 +7,11 @@ file(GLOB mainfile "main.cpp")
@@ -8,13 +7,14 @@
list(REMOVE_ITEM srcs ${mainfile})
add_library(cli_objs OBJECT ${hdrs} ${srcs})
@ -16,14 +15,16 @@ diff -up cppcheck-1.81/cli/CMakeLists.txt.tinyxml cppcheck-1.81/cli/CMakeLists.t
if (HAVE_RULES)
target_link_libraries(cppcheck pcre)
endif()
if (MSVC)
target_link_libraries(cppcheck Shlwapi.lib)
endif()
+target_link_libraries(cppcheck tinyxml2)
install(TARGETS cppcheck
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
diff -up cppcheck-1.81/CMakeLists.txt.tinyxml cppcheck-1.81/CMakeLists.txt
--- cppcheck-1.81/CMakeLists.txt.tinyxml 2017-10-07 23:11:39.000000000 +0200
+++ cppcheck-1.81/CMakeLists.txt 2017-10-18 16:40:18.899918734 +0200
@@ -16,7 +16,6 @@ if (BUILD_TESTS)
--- cppcheck-1.83.orig/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
+++ cppcheck-1.83.orig/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
@@ -16,7 +16,6 @@
enable_testing()
endif()
@ -31,10 +32,9 @@ diff -up cppcheck-1.81/CMakeLists.txt.tinyxml cppcheck-1.81/CMakeLists.txt
add_subdirectory(externals/simplecpp)
add_subdirectory(lib) # CppCheck Library
add_subdirectory(cli) # Client application
diff -up cppcheck-1.81/gui/CMakeLists.txt.tinyxml cppcheck-1.81/gui/CMakeLists.txt
--- cppcheck-1.81/gui/CMakeLists.txt.tinyxml 2017-10-07 23:11:39.000000000 +0200
+++ cppcheck-1.81/gui/CMakeLists.txt 2017-10-18 16:41:12.083142778 +0200
@@ -10,7 +10,6 @@ if (BUILD_GUI)
--- cppcheck-1.83.orig/gui/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
+++ cppcheck-1.83.orig/gui/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
@@ -10,7 +10,6 @@
endif()
include_directories(${PROJECT_SOURCE_DIR}/lib/)
@ -42,7 +42,7 @@ diff -up cppcheck-1.81/gui/CMakeLists.txt.tinyxml cppcheck-1.81/gui/CMakeLists.t
file(GLOB hdrs "*.h")
file(GLOB srcs "*.cpp")
@@ -20,10 +19,11 @@ if (BUILD_GUI)
@@ -20,10 +19,11 @@
QT5_ADD_RESOURCES(resources "gui.qrc")
QT5_ADD_TRANSLATION(qms ${tss})
@ -55,10 +55,9 @@ diff -up cppcheck-1.81/gui/CMakeLists.txt.tinyxml cppcheck-1.81/gui/CMakeLists.t
qt5_use_modules(cppcheck-gui ${GUI_QT_COMPONENTS})
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
diff -up cppcheck-1.81/test/CMakeLists.txt.tinyxml cppcheck-1.81/test/CMakeLists.txt
--- cppcheck-1.81/test/CMakeLists.txt.tinyxml 2017-10-07 23:11:39.000000000 +0200
+++ cppcheck-1.81/test/CMakeLists.txt 2017-10-18 16:40:18.900918719 +0200
@@ -1,16 +1,16 @@
--- cppcheck-1.83.orig/test/CMakeLists.txt 2018-04-02 03:02:50.000000000 -0400
+++ cppcheck-1.83.orig/test/CMakeLists.txt 2018-04-12 12:45:04.959219411 -0400
@@ -1,16 +1,16 @@
if (BUILD_TESTS)
include_directories(${PROJECT_SOURCE_DIR}/lib/ ${PROJECT_SOURCE_DIR}/cli/)

View File

@ -1,6 +1,6 @@
Name: cppcheck
Version: 1.81
Release: 5%{?dist}
Version: 1.83
Release: 1%{?dist}
Summary: Tool for static C/C++ code analysis
Group: Development/Languages
License: GPLv3+
@ -8,7 +8,7 @@ URL: http://cppcheck.wiki.sourceforge.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# Use system tinyxml2
Patch0: cppcheck-1.81-tinyxml.patch
Patch0: cppcheck-1.83-tinyxml.patch
# Fix location of translations
Patch1: cppcheck-1.81-translations.patch
# Set location of config files
@ -91,6 +91,9 @@ cd objdir-%{_target_platform}/bin
%changelog
* Sat Apr 14 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.83-1
- Update to 1.83.
* Wed Feb 28 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.81-5
- Added gcc-c++ buildrequires.