Update to 1.85.

This commit is contained in:
Steve Grubb 2018-11-08 16:08:01 +01:00
parent 7eef217d85
commit 9d1bd55da1
4 changed files with 22 additions and 28 deletions

1
.gitignore vendored
View File

@ -35,3 +35,4 @@ cppcheck-1.44.tar.bz2
/cppcheck-1.81.tar.gz
/cppcheck-1.83.tar.gz
/cppcheck-1.84.tar.gz
/cppcheck-1.85.tar.gz

View File

@ -1,6 +1,6 @@
diff -ur cppcheck-1.84.orig/cli/CMakeLists.txt cppcheck-1.84/cli/CMakeLists.txt
--- cppcheck-1.84.orig/cli/CMakeLists.txt 2018-06-10 16:41:03.000000000 -0400
+++ cppcheck-1.84/cli/CMakeLists.txt 2018-08-13 13:11:17.191381897 -0400
diff -ur cppcheck-1.85.orig/cli/CMakeLists.txt cppcheck-1.85/cli/CMakeLists.txt
--- cppcheck-1.85.orig/cli/CMakeLists.txt 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/cli/CMakeLists.txt 2018-11-08 15:31:17.285998825 +0100
@@ -1,5 +1,4 @@
include_directories(${PROJECT_SOURCE_DIR}/lib/)
-include_directories(SYSTEM ${PROJECT_SOURCE_DIR}/externals/tinyxml/)
@ -16,18 +16,16 @@ diff -ur cppcheck-1.84.orig/cli/CMakeLists.txt cppcheck-1.84/cli/CMakeLists.txt
if (HAVE_RULES)
target_link_libraries(cppcheck pcre)
endif()
if (MSVC)
if (WIN32 AND NOT BORLAND)
target_link_libraries(cppcheck Shlwapi.lib)
endif()
+target_link_libraries(cppcheck tinyxml2)
install(TARGETS cppcheck
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}
Only in cppcheck-1.84/cli: CMakeLists.txt.orig
Only in cppcheck-1.84/cli: CMakeLists.txt.rej
diff -ur cppcheck-1.84.orig/CMakeLists.txt cppcheck-1.84/CMakeLists.txt
--- cppcheck-1.84.orig/CMakeLists.txt 2018-06-10 16:41:03.000000000 -0400
+++ cppcheck-1.84/CMakeLists.txt 2018-08-13 13:09:05.904395985 -0400
diff -ur cppcheck-1.85.orig/CMakeLists.txt cppcheck-1.85/CMakeLists.txt
--- cppcheck-1.85.orig/CMakeLists.txt 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/CMakeLists.txt 2018-11-08 15:28:12.574001686 +0100
@@ -16,7 +16,6 @@
enable_testing()
endif()
@ -36,11 +34,9 @@ diff -ur cppcheck-1.84.orig/CMakeLists.txt cppcheck-1.84/CMakeLists.txt
add_subdirectory(externals/simplecpp)
add_subdirectory(lib) # CppCheck Library
add_subdirectory(cli) # Client application
Only in cppcheck-1.84: .codacy.yml
Only in cppcheck-1.84: .gitignore
diff -ur cppcheck-1.84.orig/gui/CMakeLists.txt cppcheck-1.84/gui/CMakeLists.txt
--- cppcheck-1.84.orig/gui/CMakeLists.txt 2018-06-10 16:41:03.000000000 -0400
+++ cppcheck-1.84/gui/CMakeLists.txt 2018-08-13 13:13:52.843365194 -0400
diff -ur cppcheck-1.85.orig/gui/CMakeLists.txt cppcheck-1.85/gui/CMakeLists.txt
--- cppcheck-1.85.orig/gui/CMakeLists.txt 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/gui/CMakeLists.txt 2018-11-08 15:28:12.575001686 +0100
@@ -10,7 +10,6 @@
endif()
@ -63,12 +59,9 @@ diff -ur cppcheck-1.84.orig/gui/CMakeLists.txt cppcheck-1.84/gui/CMakeLists.txt
install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
Only in cppcheck-1.84/gui: CMakeLists.txt.orig
Only in cppcheck-1.84/gui: CMakeLists.txt.rej
Only in cppcheck-1.84: .mailmap
diff -ur cppcheck-1.84.orig/test/CMakeLists.txt cppcheck-1.84/test/CMakeLists.txt
--- cppcheck-1.84.orig/test/CMakeLists.txt 2018-06-10 16:41:03.000000000 -0400
+++ cppcheck-1.84/test/CMakeLists.txt 2018-08-13 13:09:05.949395981 -0400
diff -ur cppcheck-1.85.orig/test/CMakeLists.txt cppcheck-1.85/test/CMakeLists.txt
--- cppcheck-1.85.orig/test/CMakeLists.txt 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/test/CMakeLists.txt 2018-11-08 15:28:12.575001686 +0100
@@ -1,16 +1,16 @@
if (BUILD_TESTS)
@ -88,6 +81,3 @@ diff -ur cppcheck-1.84.orig/test/CMakeLists.txt cppcheck-1.84/test/CMakeLists.tx
add_custom_target(copy_cfg ALL
COMMENT "Copying cfg files")
Only in cppcheck-1.84: .travis_llvmcheck_suppressions
Only in cppcheck-1.84: .travis_suppressions
Only in cppcheck-1.84: .travis.yml

View File

@ -2,7 +2,7 @@
%global gui 1
Name: cppcheck
Version: 1.84
Version: 1.85
Release: 1%{?dist}
Summary: Tool for static C/C++ code analysis
License: GPLv3+
@ -10,7 +10,7 @@ URL: http://cppcheck.wiki.sourceforge.net/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
# Use system tinyxml2
Patch0: cppcheck-1.84-tinyxml.patch
Patch0: cppcheck-1.85-tinyxml.patch
# Fix location of translations
Patch1: cppcheck-1.84-translations.patch
# Set location of config files
@ -85,7 +85,7 @@ xsltproc --nonet -o man/manual.html \
mkdir objdir-%{_target_platform}
cd objdir-%{_target_platform}
# Upstream doesn't support shared libraries (unversioned solib)
%cmake .. -DCMAKE_BUILD_TYPE=Release -DHAVE_RULES=1 -DBUILD_GUI=%{gui} -DBUILD_SHARED_LIBS:BOOL=OFF -DBUILD_TESTS=1 -DCFGDIR=%{_datadir}/CppCheck
%cmake .. -DCMAKE_BUILD_TYPE=Release -DHAVE_RULES=1 -DBUILD_GUI=%{gui} -DBUILD_SHARED_LIBS:BOOL=OFF -DBUILD_TESTS=1 -DCFGDIR=%{_datadir}/Cppcheck
# SMP make doesn't seem to work
make cppcheck
@ -111,7 +111,7 @@ cd objdir-%{_target_platform}/bin
%files
%doc AUTHORS COPYING man/manual.html
%{_datadir}/CppCheck/
%{_datadir}/Cppcheck/
%{_bindir}/cppcheck
%{_mandir}/man1/cppcheck.1*
@ -128,6 +128,9 @@ cd objdir-%{_target_platform}/bin
%{_bindir}/cppcheck-htmlreport
%changelog
* Thu Nov 08 2018 Steve Grubb <sgrubb@redhat.com> - 1.85-1
- Update to 1.85.
* Tue Sep 11 2018 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.84-1
- Update to 1.84.

View File

@ -1 +1 @@
SHA512 (cppcheck-1.84.tar.gz) = a14a102447a099c66e0116b23364c845175dd803d49ee1030df349107f2a8585d701c3a5bf8b285d111199bc8fb8e55e3439d8e5c7b29062f44971c90e3dd35a
SHA512 (cppcheck-1.85.tar.gz) = cc984c751d87150839782e96b3762dbf918d9e3687562eabaff6473e48e3254995dd3bffe8605842f867d7ad76845ca2248a53bbd54b5c367281db8a1c1c7fad