Update to 1.78, patch in CFGDIR location.
This commit is contained in:
parent
baf899dcbd
commit
7d543feafe
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ cppcheck-1.44.tar.bz2
|
||||
/cppcheck-1.74.tar.bz2
|
||||
/cppcheck-1.75.tar.bz2
|
||||
/cppcheck-1.77.tar.bz2
|
||||
/cppcheck-1.78.tar.bz2
|
||||
|
16
cppcheck-1.78-cfgdir.patch
Normal file
16
cppcheck-1.78-cfgdir.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up cppcheck-1.78/CMakeLists.txt.orig cppcheck-1.78/CMakeLists.txt
|
||||
diff -up cppcheck-1.78/cmake/options.cmake.orig cppcheck-1.78/cmake/options.cmake
|
||||
--- cppcheck-1.78/cmake/options.cmake.orig 2017-04-01 11:05:13.000000000 +0200
|
||||
+++ cppcheck-1.78/cmake/options.cmake 2017-04-09 14:13:30.130818011 +0200
|
||||
@@ -23,6 +23,11 @@ option(ANALYZE_DATAFLOW "Clang dynam
|
||||
option(WARNINGS_ARE_ERRORS "Treat warnings as errors" OFF)
|
||||
option(WARNINGS_ANSI_ISO "Issue all the mandatory diagnostics Listed in C standard" ON)
|
||||
|
||||
+option(CFGDIR "Configuration file directory" OFF)
|
||||
+if(CFGDIR)
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DCFG=${CFGDIR}")
|
||||
+endif(CFGDIR)
|
||||
+
|
||||
set(USE_MATCHCOMPILER "Auto" CACHE STRING "Usage of match compliler")
|
||||
set_property(CACHE USE_MATCHCOMPILER PROPERTY STRINGS Auto Off On Verify)
|
||||
if (USE_MATCHCOMPILER STREQUAL "Auto")
|
@ -1,6 +1,6 @@
|
||||
Name: cppcheck
|
||||
Version: 1.77
|
||||
Release: 4%{?dist}
|
||||
Version: 1.78
|
||||
Release: 1%{?dist}
|
||||
Summary: Tool for static C/C++ code analysis
|
||||
Group: Development/Languages
|
||||
License: GPLv3+
|
||||
@ -12,6 +12,8 @@ BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
Patch0: cppcheck-1.77-tinyxml.patch
|
||||
# Fix location of translations
|
||||
Patch1: cppcheck-1.77-translations.patch
|
||||
# Set location of config files
|
||||
Patch2: cppcheck-1.78-cfgdir.patch
|
||||
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: tinyxml2-devel >= 2.1.0
|
||||
@ -41,6 +43,7 @@ This package contains the graphical user interface for cppcheck.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .tinyxml
|
||||
%patch1 -p1 -b .translations
|
||||
%patch2 -p1 -b .cfgdir
|
||||
# Make sure bundled tinyxml is not used
|
||||
rm -r externals/tinyxml
|
||||
|
||||
@ -55,7 +58,7 @@ xsltproc --nonet -o man/manual.html \
|
||||
mkdir objdir-%{_target_platform}
|
||||
cd objdir-%{_target_platform}
|
||||
# Upstream doesn't support shared libraries (unversioned solib)
|
||||
%cmake .. -DCMAKE_BUILD_TYPE=Release -DHAVE_RULES=1 -DBUILD_GUI=1 -DBUILD_SHARED_LIBS:BOOL=OFF -DBUILD_TESTS=1
|
||||
%cmake .. -DCMAKE_BUILD_TYPE=Release -DHAVE_RULES=1 -DBUILD_GUI=1 -DBUILD_SHARED_LIBS:BOOL=OFF -DBUILD_TESTS=1 -DCFGDIR=%{_datadir}/CppCheck
|
||||
# SMP make doesn't seem to work
|
||||
make cppcheck
|
||||
|
||||
@ -91,6 +94,10 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Apr 09 2017 Susi Lehtola <jussilehtola@fedoraproject.org> - 1.78-1
|
||||
- Make cppcheck able to find its configs once again (bug 1427788).
|
||||
- Update to 1.78.
|
||||
|
||||
* Mon Feb 27 2017 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.77-4
|
||||
- Remove Patch2: fixed in gcc side (gcc-7.0.1-10.fc26)
|
||||
(ref: bug 1423312)
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (cppcheck-1.77.tar.bz2) = df8dddf7758c342d45b3393246e07eaa11a53dca19e8a0d09de04f12ea6232538941328d9ca9ac52eb425871fd1c49d55c77e6e38b40772b6f856fd1e9e99779
|
||||
SHA512 (cppcheck-1.78.tar.bz2) = 598556e9d657a3a77ff889cb6647291160017f7f9322326771416ff59d44126ce47c39767657b863cdb8a1b46d7c83bb337ec2fe0574500b37e99c33377b5dd8
|
||||
|
Loading…
Reference in New Issue
Block a user