Switch to python3.

This commit is contained in:
Susi Lehtola 2019-08-14 11:04:52 +02:00
parent 5cf76bc1bc
commit 45daf4b0bf
3 changed files with 34 additions and 32 deletions

View File

@ -1,27 +0,0 @@
diff -urp cppcheck-1.85.orig/htmlreport/cppcheck-htmlreport cppcheck-1.85/htmlreport/cppcheck-htmlreport
--- cppcheck-1.85.orig/htmlreport/cppcheck-htmlreport 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/htmlreport/cppcheck-htmlreport 2018-11-08 16:26:00.527947956 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
from __future__ import unicode_literals
diff -urp cppcheck-1.85.orig/htmlreport/setup.py cppcheck-1.85/htmlreport/setup.py
--- cppcheck-1.85.orig/htmlreport/setup.py 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/htmlreport/setup.py 2018-11-08 16:26:40.266947340 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
from setuptools import setup
diff -urp cppcheck-1.85.orig/htmlreport/test_htmlreport.py cppcheck-1.85/htmlreport/test_htmlreport.py
--- cppcheck-1.85.orig/htmlreport/test_htmlreport.py 2018-10-14 14:56:51.000000000 +0200
+++ cppcheck-1.85/htmlreport/test_htmlreport.py 2018-11-08 16:26:25.963947562 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
"""Test cppcheck-htmlreport."""
import os

View File

@ -0,0 +1,27 @@
diff -up cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 cppcheck-1.88/htmlreport/cppcheck-htmlreport
--- cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 2019-06-29 09:51:25.000000000 +0200
+++ cppcheck-1.88/htmlreport/cppcheck-htmlreport 2019-08-14 11:02:23.791627296 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
from __future__ import unicode_literals
diff -up cppcheck-1.88/htmlreport/setup.py.python3 cppcheck-1.88/htmlreport/setup.py
--- cppcheck-1.88/htmlreport/setup.py.python3 2019-06-29 09:51:25.000000000 +0200
+++ cppcheck-1.88/htmlreport/setup.py 2019-08-14 11:02:28.570423533 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
from setuptools import setup
diff -up cppcheck-1.88/htmlreport/test_htmlreport.py.python3 cppcheck-1.88/htmlreport/test_htmlreport.py
--- cppcheck-1.88/htmlreport/test_htmlreport.py.python3 2019-06-29 09:51:25.000000000 +0200
+++ cppcheck-1.88/htmlreport/test_htmlreport.py 2019-08-14 11:02:20.296776345 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
"""Test cppcheck-htmlreport."""
import os

View File

@ -15,9 +15,8 @@ Patch0: cppcheck-1.88-tinyxml.patch
Patch1: cppcheck-1.88-translations.patch
# Set location of config files
Patch2: cppcheck-1.87-cfgdir.patch
# Select python2 explicitly because htmlreport/README.txt says it's
# implemented using Python2.7. Without it the package fails to build on F30.
Patch3: cppcheck-1.85-htmlreport-python2.patch
# Select python3 explicitly
Patch3: cppcheck-1.88-htmlreport-python3.patch
# BZ #1733663
Patch4: https://github.com/danmar/cppcheck/pull/1939.patch
@ -68,7 +67,7 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
# RHEL packages aren't versioned
Requires: python-pygments
%else
Requires: python2-pygments
Requires: python3-pygments
%endif
%description htmlreport
@ -80,7 +79,7 @@ from xml files first generated using cppcheck.
%patch0 -p1 -b .tinyxml
%patch1 -p1 -b .translations
%patch2 -p1 -b .cfgdir
%patch3 -p1 -b .python2
%patch3 -p1 -b .python3
%patch4 -p1 -b .bz1733663a
%patch5 -p1 -b .bz1733663b
# Make sure bundled tinyxml is not used
@ -140,6 +139,9 @@ cd objdir-%{_target_platform}/bin
%{_bindir}/cppcheck-htmlreport
%changelog
* Wed Aug 14 2019 Susi Lehtola <jussilehtola@redhat.com> - 1.89-5
- Switch to python3 in htmlreport (BZ #1737972).
* Mon Jul 29 2019 Susi Lehtola <jussilehtola@redhat.com> - 1.89-4
- Second patch for another issue in BZ #1733663.