coreutils/coreutils-6.10-configuratio...

196 lines
6.9 KiB
Diff

diff -urNp coreutils-8.21-orig/gnulib-tests/gnulib.mk coreutils-8.21/gnulib-tests/gnulib.mk
--- coreutils-8.21-orig/gnulib-tests/gnulib.mk 2013-02-07 17:58:44.000000000 +0100
+++ coreutils-8.21/gnulib-tests/gnulib.mk 2013-02-15 10:12:28.110593165 +0100
@@ -279,9 +279,9 @@ EXTRA_DIST += nap.h test-chown.h test-chown.c signature.h macros.h
## begin gnulib module cloexec-tests
-TESTS += test-cloexec
-check_PROGRAMS += test-cloexec
-EXTRA_DIST += test-cloexec.c macros.h
+#TESTS += test-cloexec
+#check_PROGRAMS += test-cloexec
+#EXTRA_DIST += test-cloexec.c macros.h
## end gnulib module cloexec-tests
@@ -392,9 +392,9 @@ EXTRA_DIST += test-dup.c signature.h macros.h
## begin gnulib module dup2-tests
-TESTS += test-dup2
-check_PROGRAMS += test-dup2
-EXTRA_DIST += test-dup2.c signature.h macros.h
+#TESTS += test-dup2
+#check_PROGRAMS += test-dup2
+#EXTRA_DIST += test-dup2.c signature.h macros.h
## end gnulib module dup2-tests
@@ -453,10 +453,10 @@ EXTRA_DIST += test-fadvise.c
## begin gnulib module fchdir-tests
-TESTS += test-fchdir
-check_PROGRAMS += test-fchdir
-test_fchdir_LDADD = $(LDADD) $(LIBINTL)
-EXTRA_DIST += test-fchdir.c signature.h macros.h
+#TESTS += test-fchdir
+#check_PROGRAMS += test-fchdir
+#test_fchdir_LDADD = $(LDADD) $(LIBINTL)
+#EXTRA_DIST += test-fchdir.c signature.h macros.h
## end gnulib module fchdir-tests
@@ -900,9 +900,9 @@ EXTRA_DIST += test-getloadavg.c signature.h
## begin gnulib module getlogin-tests
-TESTS += test-getlogin
-check_PROGRAMS += test-getlogin
-EXTRA_DIST += test-getlogin.c signature.h macros.h
+#TESTS += test-getlogin
+#check_PROGRAMS += test-getlogin
+#EXTRA_DIST += test-getlogin.c signature.h macros.h
## end gnulib module getlogin-tests
@@ -1147,10 +1147,10 @@ EXTRA_DIST += test-link.h test-link.c signature.h macros.h
## begin gnulib module linkat-tests
-TESTS += test-linkat
-check_PROGRAMS += test-linkat
-test_linkat_LDADD = $(LDADD) @LIBINTL@
-EXTRA_DIST += test-link.h test-linkat.c signature.h macros.h
+#TESTS += test-linkat
+#check_PROGRAMS += test-linkat
+#test_linkat_LDADD = $(LDADD) @LIBINTL@
+#EXTRA_DIST += test-link.h test-linkat.c signature.h macros.h
## end gnulib module linkat-tests
@@ -1359,9 +1359,9 @@ EXTRA_DIST += test-memcoll.c macros.h
## begin gnulib module memrchr-tests
-TESTS += test-memrchr
-check_PROGRAMS += test-memrchr
-EXTRA_DIST += test-memrchr.c zerosize-ptr.h signature.h macros.h
+#TESTS += test-memrchr
+#check_PROGRAMS += test-memrchr
+#EXTRA_DIST += test-memrchr.c zerosize-ptr.h signature.h macros.h
## end gnulib module memrchr-tests
@@ -1912,9 +1912,9 @@ EXTRA_DIST += test-statat.c
## begin gnulib module stdalign-tests
-TESTS += test-stdalign
-check_PROGRAMS += test-stdalign
-EXTRA_DIST += test-stdalign.c macros.h
+#TESTS += test-stdalign
+#check_PROGRAMS += test-stdalign
+#EXTRA_DIST += test-stdalign.c macros.h
## end gnulib module stdalign-tests
@@ -2269,9 +2269,9 @@ EXTRA_DIST += test-uname.c signature.h macros.h
## begin gnulib module unistd-safer-tests
-TESTS += test-dup-safer
-check_PROGRAMS += test-dup-safer
-EXTRA_DIST += test-dup-safer.c macros.h
+#TESTS += test-dup-safer
+#check_PROGRAMS += test-dup-safer
+#EXTRA_DIST += test-dup-safer.c macros.h
## end gnulib module unistd-safer-tests
@@ -2367,10 +2367,10 @@ EXTRA_DIST += test-userspec.c
## begin gnulib module utimens-tests
-TESTS += test-utimens
-check_PROGRAMS += test-utimens
-test_utimens_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_NANOSLEEP) @LIBINTL@
-EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
+#TESTS += test-utimens
+#check_PROGRAMS += test-utimens
+#test_utimens_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_NANOSLEEP) @LIBINTL@
+#EXTRA_DIST += nap.h test-futimens.h test-lutimens.h test-utimens.h test-utimens-common.h test-utimens.c macros.h
## end gnulib module utimens-tests
diff -urNp coreutils-8.21-orig/tests/local.mk coreutils-8.21/tests/local.mk
--- coreutils-8.21-orig/tests/local.mk 2013-02-11 11:30:12.000000000 +0100
+++ coreutils-8.21/tests/local.mk 2013-02-15 10:10:55.890532258 +0100
@@ -134,6 +134,7 @@ all_root_tests = \
tests/rm/no-give-up.sh \
tests/rm/one-file-system.sh \
tests/rm/read-only.sh \
+ tests/tail-2/inotify-hash-abuse.sh \
tests/tail-2/append-only.sh \
tests/touch/now-owned-by-other.sh
@@ -168,7 +169,6 @@ all_tests = \
tests/cp/link-heap.sh \
tests/cp/no-ctx.sh \
tests/misc/tty-eof.pl \
- tests/tail-2/inotify-hash-abuse.sh \
tests/tail-2/inotify-hash-abuse2.sh \
tests/tail-2/F-vs-missing.sh \
tests/tail-2/F-vs-rename.sh \
diff -urNp coreutils-8.21-orig/tests/touch/no-dereference.sh coreutils-8.21/tests/touch/no-dereference.sh
--- coreutils-8.21-orig/tests/touch/no-dereference.sh 2013-01-31 01:46:25.000000000 +0100
+++ coreutils-8.21/tests/touch/no-dereference.sh 2013-02-15 10:10:55.889593383 +0100
@@ -42,6 +42,8 @@ test -f nowhere && fail=1
grep '^#define HAVE_UTIMENSAT 1' "$CONFIG_HEADER" > /dev/null ||
grep '^#define HAVE_LUTIMES 1' "$CONFIG_HEADER" > /dev/null ||
skip_ 'this system lacks the utimensat function'
+grep '^#define HAVE_WORKINGKOJI 1' "$CONFIG_HEADER" > /dev/null ||
+ skip_ 'rest of the test disabled due to koji lack of utimensat function'
# Changing time of dangling symlink is okay.
# Skip the test if this fails, but the error text corresponds to
diff -urNp coreutils-8.22-orig/tests/misc/nohup.sh coreutils-8.22/tests/misc/nohup.sh
--- coreutils-8.22-orig/tests/misc/nohup.sh 2013-12-04 15:48:30.000000000 +0100
+++ coreutils-8.22/tests/misc/nohup.sh 2014-03-02 21:51:01.972887749 +0100
@@ -19,6 +19,8 @@
. "${srcdir=.}/tests/init.sh"; path_prepend_ ./src
print_ver_ nohup
+#mark it expensive, to temporarily skip the test in koji
+expensive_
nohup sh -c 'echo stdout; echo stderr 1>&2' 2>err || fail=1
diff -urNp coreutils-8.23-orig/tests/df/skip-duplicates.sh coreutils-8.23/tests/df/skip-duplicates.sh
--- coreutils-8.23-orig/tests/df/skip-duplicates.sh 2014-07-14 00:09:52.000000000 +0200
+++ coreutils-8.23/tests/df/skip-duplicates.sh 2014-07-24 15:53:33.473031545 +0200
@@ -25,6 +25,10 @@ require_gcc_shared_
# potentially very many remote mounts.
df --local || skip_ 'df fails'
+#mark it expensive, to temporarily skip the test in koji
+expensive_
+
+
export CU_NONROOT_FS=$(df --local --output=target 2>&1 | grep /. | head -n1)
export CU_REMOTE_FS=$(df --local --output=target 2>&1 | grep /. |
tail -n+2 | head -n1)
diff -urNp coreutils-8.23-orig/man/local.mk coreutils-8.23/man/local.mk
--- coreutils-8.23-orig/man/local.mk 2014-07-18 03:40:57.000000000 +0200
+++ coreutils-8.23/man/local.mk 2014-08-05 12:18:20.477524009 +0200
@@ -41,7 +41,7 @@ distclean-local:
test x$(srcdir) = x$(builddir) || rm -f $(ALL_MANS)
# Dependencies common to all man pages. Updated below.
-mandeps =
+mandeps = $(PROGRAMS)
# Depend on this to get version number changes.
mandeps += .version