new upstream release 8.4

This commit is contained in:
Ondrej Vasik 2010-01-14 09:36:45 +00:00
parent 3376fb410c
commit d3f2dba129
4 changed files with 42 additions and 64 deletions

View File

@ -1 +1 @@
coreutils-8.3.tar.xz
coreutils-8.4.tar.xz

View File

@ -1,58 +1,7 @@
diff -urNp coreutils-6.11-orig/tests/test-lib.sh coreutils-6.11/tests/test-lib.sh
--- coreutils-6.11-orig/tests/test-lib.sh 2008-04-19 23:34:23.000000000 +0200
+++ coreutils-6.11/tests/test-lib.sh 2008-04-24 14:18:59.000000000 +0200
@@ -97,8 +97,8 @@ skip_if_()
require_selinux_()
{
- case `ls -Zd .` in
- '? .'|'unlabeled .')
+ case `ls --scontext -d . | cut -f1 -d" "` in
+ '?'|'unlabeled')
skip_test_ "this system (or maybe just" \
"the current file system) lacks SELinux support"
;;
diff -urNp coreutils-7.1-orig/src/ls.c coreutils-7.1/src/ls.c
--- coreutils-7.1-orig/src/ls.c 2009-02-25 13:23:59.000000000 +0100
+++ coreutils-7.1/src/ls.c 2009-02-25 13:25:20.000000000 +0100
@@ -38,10 +38,6 @@
#include <config.h>
#include <sys/types.h>
-#ifdef HAVE_CAP
-# include <sys/capability.h>
-#endif
-
#if HAVE_TERMIOS_H
# include <termios.h>
#endif
@@ -84,6 +80,10 @@
#include "system.h"
#include <fnmatch.h>
+#ifdef HAVE_CAP
+# include <sys/capability.h>
+#endif
+
#include "acl.h"
#include "argmatch.h"
#include "dev-ino.h"
diff -urNp coreutils-8.1-orig/tests/touch/no-dereference coreutils-8.1/tests/touch/no-dereference
--- coreutils-8.1-orig/tests/touch/no-dereference 2009-10-30 12:51:07.000000000 +0100
+++ coreutils-8.1/tests/touch/no-dereference 2009-11-27 13:31:10.000000000 +0100
@@ -46,6 +46,8 @@ test -f nowhere && fail=1
grep '^#define HAVE_UTIMENSAT' "$CONFIG_HEADER" > /dev/null ||
grep '^#define HAVE_LUTIMES' "$CONFIG_HEADER" > /dev/null ||
skip_test_ 'this system lacks the utimensat function'
+grep '^#define HAVE_WORKINGKOJI' "$CONFIG_HEADER" > /dev/null ||
+ skip_test_ 'rest of the test disabled due to koji lack of utimensat function'
# Changing time of dangling symlink is okay.
touch -h dangling || fail=1
diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/gnulib.mk
--- coreutils-8.2-orig/gnulib-tests/gnulib.mk 2009-12-11 17:54:36.850815863 +0100
+++ coreutils-8.2/gnulib-tests/gnulib.mk 2009-12-11 18:03:01.034460289 +0100
@@ -233,9 +233,9 @@ EXTRA_DIST += test-chown.h test-chown.c
diff -urNp coreutils-8.4-orig/gnulib-tests/gnulib.mk coreutils-8.4/gnulib-tests/gnulib.mk
--- coreutils-8.4-orig/gnulib-tests/gnulib.mk 2010-01-13 22:01:30.000000000 +0100
+++ coreutils-8.4/gnulib-tests/gnulib.mk 2010-01-14 10:28:17.000000000 +0100
@@ -256,9 +256,9 @@ EXTRA_DIST += nap.h test-chown.h test-ch
## begin gnulib module cloexec-tests
@ -65,7 +14,7 @@ diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/
## end gnulib module cloexec-tests
@@ -293,9 +293,9 @@ EXTRA_DIST += test-dirname.c
@@ -332,9 +332,9 @@ EXTRA_DIST += test-dirname.c
## begin gnulib module dup2-tests
@ -78,7 +27,7 @@ diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/
## end gnulib module dup2-tests
@@ -337,9 +337,9 @@ EXTRA_DIST += test-exclude.c test-exclud
@@ -376,9 +376,9 @@ EXTRA_DIST += test-exclude.c test-exclud
## begin gnulib module fchdir-tests
@ -91,7 +40,7 @@ diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/
## end gnulib module fchdir-tests
@@ -1463,9 +1463,9 @@ EXTRA_DIST += test-uname.c
@@ -1532,9 +1532,9 @@ EXTRA_DIST += test-uname.c signature.h m
## begin gnulib module unistd-safer-tests
@ -104,9 +53,9 @@ diff -urNp coreutils-8.2-orig/gnulib-tests/gnulib.mk coreutils-8.2/gnulib-tests/
## end gnulib module unistd-safer-tests
diff -urNp coreutils-8.3-orig/tests/Makefile.am coreutils-8.3/tests/Makefile.am
--- coreutils-8.3-orig/tests/Makefile.am 2010-01-08 13:06:44.000000000 +0100
+++ coreutils-8.3/tests/Makefile.am 2010-01-08 13:25:14.000000000 +0100
diff -urNp coreutils-8.4-orig/tests/Makefile.am coreutils-8.4/tests/Makefile.am
--- coreutils-8.4-orig/tests/Makefile.am 2010-01-03 18:06:20.000000000 +0100
+++ coreutils-8.4/tests/Makefile.am 2010-01-14 10:28:17.000000000 +0100
@@ -79,7 +79,6 @@ TESTS = \
rm/ext3-perf \
rm/cycle \
@ -115,3 +64,29 @@ diff -urNp coreutils-8.3-orig/tests/Makefile.am coreutils-8.3/tests/Makefile.am
tail-2/inotify-hash-abuse2 \
tail-2/F-vs-rename \
tail-2/inotify-rotate \
diff -urNp coreutils-8.4-orig/tests/test-lib.sh coreutils-8.4/tests/test-lib.sh
--- coreutils-8.4-orig/tests/test-lib.sh 2010-01-03 18:06:20.000000000 +0100
+++ coreutils-8.4/tests/test-lib.sh 2010-01-14 10:28:17.000000000 +0100
@@ -218,8 +218,8 @@ skip_if_()
require_selinux_()
{
- case `ls -Zd .` in
- '? .'|'unlabeled .')
+ case `ls --scontext -d . | cut -f1 -d" "` in
+ '?'|'unlabeled')
skip_test_ "this system (or maybe just" \
"the current file system) lacks SELinux support"
;;
diff -urNp coreutils-8.4-orig/tests/touch/no-dereference coreutils-8.4/tests/touch/no-dereference
--- coreutils-8.4-orig/tests/touch/no-dereference 2010-01-12 15:36:17.000000000 +0100
+++ coreutils-8.4/tests/touch/no-dereference 2010-01-14 10:28:17.000000000 +0100
@@ -46,6 +46,8 @@ test -f nowhere && fail=1
grep '^#define HAVE_UTIMENSAT' "$CONFIG_HEADER" > /dev/null ||
grep '^#define HAVE_LUTIMES' "$CONFIG_HEADER" > /dev/null ||
skip_test_ 'this system lacks the utimensat function'
+grep '^#define HAVE_WORKINGKOJI' "$CONFIG_HEADER" > /dev/null ||
+ skip_test_ 'rest of the test disabled due to koji lack of utimensat function'
# Changing time of dangling symlink is okay.
# Skip the test if this fails, but the error text corresponds to

View File

@ -1,6 +1,6 @@
Summary: A set of basic GNU tools commonly used in shell scripts
Name: coreutils
Version: 8.3
Version: 8.4
Release: 1%{?dist}
License: GPLv3+
Group: System Environment/Base
@ -333,6 +333,9 @@ fi
%{_libdir}/coreutils
%changelog
* Thu Jan 14 2010 Ondrej Vasik <ovasik@redhat.com> - 8.4-1
- new upstream release 8.4
* Fri Jan 08 2010 Ondrej Vasik <ovasik@redhat.com> - 8.3-1
- new upstream release 8.3

View File

@ -1 +1 @@
90dcc992ecb6ce76390d11134aabc830 coreutils-8.3.tar.xz
1fde97f144b4699b18f36c2ec18b1f18 coreutils-8.4.tar.xz