fix build failure for undeclared O_SYNC in rawhide, remove su and pam relicts

This commit is contained in:
Ondřej Vašík 2012-11-01 20:52:47 +01:00
parent edc2e6afec
commit c718b5ec2a
2 changed files with 17 additions and 3 deletions

View File

@ -136,3 +136,18 @@ diff -urNp coreutils-8.13-orig/tests/touch/no-dereference.sh coreutils-8.13/test
# Changing time of dangling symlink is okay.
# Skip the test if this fails, but the error text corresponds to
diff -urNp coreutils-8.20-orig/src/dd.c coreutils-8.20/src/dd.c
--- coreutils-8.20-orig/src/dd.c 2012-10-23 16:14:12.000000000 +0200
+++ coreutils-8.20/src/dd.c 2012-11-01 20:50:18.341215667 +0100
@@ -71,6 +71,10 @@
# define O_CIO 0
#endif
+#ifndef O_SYNC
+# define O_SYNC 0
+#endif
+
/* On AIX 5.1 and AIX 5.2, O_NOCACHE is defined via <fcntl.h>
and would interfere with our use of that name, below. */
#undef O_NOCACHE

View File

@ -166,9 +166,9 @@ touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
aclocal -I m4
autoconf --force
automake --copy --add-missing
%configure --enable-largefile %{?!nopam:--enable-pam} \
%configure --enable-largefile \
%{?!noselinux:--enable-selinux} \
--enable-install-program=su,hostname,arch \
--enable-install-program=hostname,arch \
--with-tty-group \
DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
@ -176,7 +176,6 @@ automake --copy --add-missing
touch man/*.x
make all %{?_smp_mflags}
# %{?!nopam:CPPFLAGS="-DUSE_PAM"}
# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi