added requirements for util-linux-ng >= 2.14 (#472445), some sed cleanup

This commit is contained in:
Ondrej Vasik 2008-11-21 15:08:56 +00:00
parent e8a61f5499
commit 8283df33d5
2 changed files with 51 additions and 23 deletions

View File

@ -1,24 +1,46 @@
diff -urNp coreutils-7.0-orig/tests/df/total coreutils-7.0/tests/df/total
--- coreutils-7.0-orig/tests/df/total 2008-09-27 19:28:54.000000000 +0200
+++ coreutils-7.0/tests/df/total 2008-11-11 16:56:17.000000000 +0100
@@ -30,11 +30,8 @@ umask 22
+++ coreutils-7.0/tests/df/total 2008-11-12 12:29:24.000000000 +0100
@@ -18,7 +18,7 @@
if test "$VERBOSE" = yes; then
set -x
- ls --version
+ df --version
fi
. $srcdir/test-lib.sh
@@ -30,13 +30,10 @@ umask 22
RE_TOTAL='^total( +(-?[0-9]+|-)){3} +-?[0-9]+%$'
-df > tmp || fail=1
-$EGREP "$RE_TOTAL" tmp && fail=1
-
+df > tmp && $EGREP "$RE_TOTAL" tmp && fail=1
+df -i > tmp && $EGREP "$RE_TOTAL" tmp && fail=1
-df -i > tmp || fail=1
-$EGREP "$RE_TOTAL" tmp && fail=1
+df | $EGREP "$RE_TOTAL" tmp && fail=1
+df -i | $EGREP "$RE_TOTAL" tmp && fail=1
-
-df --total | $EGREP "$RE_TOTAL" || fail=1
-df -i --total | $EGREP "$RE_TOTAL" || fail=1
+df --total >tmp && $EGREP "$RE_TOTAL" tmp || fail=1
+df -i --total >tmp && $EGREP "$RE_TOTAL" tmp || fail=1
df --total | $EGREP "$RE_TOTAL" || fail=1
df -i --total | $EGREP "$RE_TOTAL" || fail=1
Exit $fail
diff -urNp coreutils-7.0-orig/tests/df/total-awk coreutils-7.0/tests/df/total-awk
--- coreutils-7.0-orig/tests/df/total-awk 2008-09-27 19:28:54.000000000 +0200
+++ coreutils-7.0/tests/df/total-awk 2008-11-11 16:54:49.000000000 +0100
@@ -23,58 +23,42 @@ fi
@@ -18,7 +18,7 @@
if test "$VERBOSE" = yes; then
set -x
- ls --version
+ df --version
fi
. $srcdir/test-lib.sh
@@ -23,58 +23,44 @@ fi
. $srcdir/test-lib.sh
@ -98,14 +120,16 @@ diff -urNp coreutils-7.0-orig/tests/df/total-awk coreutils-7.0/tests/df/total-aw
-$AWK -f compute_sum.awk tmp > out1 || fail=1
-$AWK -f parse_total.awk tmp > out2 || fail=1
-compare out1 out2 || fail=1
+df --total -P --block-size=512 |tee space || framework_failure
+df --total -i -P |tee inode || framework_failure
+fail=0
+df --total -P --block-size=512 >space || fail=1
+cat space # this helps when debugging any test failure
+df --total -i -P >inode || fail=1
+cat inode
-df -i --block-size=512 --total |tee tmp || fail=1
-$AWK -f compute_sum.awk tmp > out1 || fail=1
-$AWK -f parse_total.awk tmp > out2 || fail=1
-compare out1 out2 || fail=1
+fail=0
+$PERL -f check-df space || fail=1
+$PERL -f check-df inode || fail=1

View File

@ -1,7 +1,7 @@
Summary: The GNU core utilities: a set of tools commonly used in shell scripts
Name: coreutils
Version: 7.0
Release: 1%{?dist}
Release: 2%{?dist}
License: GPLv3+
Group: System Environment/Base
Url: http://www.gnu.org/software/coreutils/
@ -66,6 +66,9 @@ BuildRequires: libcap-devel >= 2.0.6
Requires(post): libselinux >= 1.25.6-1
Requires: libattr
#util-linux-ng requirement is here only to prevent /bin/arch conflict
#(could be removed after F-11/F-12 split, no idea how to solve it better)
Requires: util-linux-ng >= 2.14
Requires(pre): /sbin/install-info
Requires(preun): /sbin/install-info
Requires(post): /sbin/install-info
@ -133,19 +136,13 @@ the old GNU fileutils, sh-utils, and textutils packages.
chmod a+x tests/misc/sort-mb-tests
chmod a+x tests/misc/id-context
#Do require automake 1.10.1 instead of 1.10a
for conffile in aclocal.m4 configure.ac configure $(find ./*/Makefile.in)
do
sed -i 's/1.10a/1.10.1/' "$conffile"
done
sed -i 's/1.10a/1.10.1/' configure.ac
#fix typos/mistakes in localized documentation(#439410, #440056)
for pofile in $(find ./po/*.p*)
do
sed -i 's/-dpR/-cdpR/' "$pofile"
sed -i 's/commmand/command/' "$pofile"
done
find ./po/ -name "*.p*" | xargs \
sed -i \
-e 's/-dpR/-cdpR/' \
-e 's/commmand/command/'
%build
%ifarch s390 s390x
@ -155,6 +152,7 @@ export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fPIC -O1"
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
%endif
%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
#autoreconf -i -v
touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
aclocal -I m4
autoconf --force
@ -320,6 +318,12 @@ fi
/sbin/runuser
%changelog
* Fri Nov 21 2008 Ondrej Vasik <ovasik@redhat.com> - 7.0.2
- added requirements for util-linux-ng >= 2.14
because of file conflict in update from F-8/F-9(#472445)
- some sed cleanup, df totaltests patch changes (not working
correctly yet :( )
* Wed Nov 12 2008 Ondrej Vasik <ovasik@redhat.com> - 7.0-1
- new upstream release
- modification/removal of related patches