suppress mv diagnostics only for ENOTSUP and ENODATA, do not run

test-memchr gnulib test (koji failure)
This commit is contained in:
Ondrej Vasik 2009-04-17 13:27:36 +00:00
parent 187c0782af
commit 64938e3ecc
2 changed files with 34 additions and 12 deletions

View File

@ -1,6 +1,19 @@
diff -urNp coreutils-7.2-orig/gnulib-tests/gnulib.mk coreutils-7.2/gnulib-tests/gnulib.mk
--- coreutils-7.2-orig/gnulib-tests/gnulib.mk 2009-03-31 14:28:30.000000000 +0200
+++ coreutils-7.2/gnulib-tests/gnulib.mk 2009-04-01 12:37:00.000000000 +0200
@@ -606,9 +606,9 @@ EXTRA_DIST += test-mbsstr1.c test-mbsstr
## begin gnulib module memchr-tests
-TESTS += test-memchr
-check_PROGRAMS += test-memchr
-EXTRA_DIST += test-memchr.c
+#TESTS += test-memchr
+#check_PROGRAMS += test-memchr
+#EXTRA_DIST += test-memchr.c
## end gnulib module memchr-tests
@@ -910,9 +910,9 @@ EXTRA_DIST += test-strtod.c
## begin gnulib module strverscmp-tests

View File

@ -1,12 +1,21 @@
diff -urNp coreutils-7.2-orig/src/mv.c coreutils-7.2/src/mv.c
--- coreutils-7.2-orig/src/mv.c 2009-04-17 11:48:39.000000000 +0200
+++ coreutils-7.2/src/mv.c 2009-04-17 11:49:17.000000000 +0200
@@ -117,7 +117,7 @@ cp_option_init (struct cp_options *x)
x->preserve_timestamps = true;
x->preserve_security_context = selinux_enabled;
x->set_security_context = false;
- x->reduce_diagnostics = false;
+ x->reduce_diagnostics = true;
x->require_preserve = false; /* FIXME: maybe make this an option */
x->require_preserve_context = false;
x->preserve_xattr = true;
diff -urNp coreutils-7.2-orig/src/copy.c coreutils-7.2/src/copy.c
--- coreutils-7.2-orig/src/copy.c 2009-04-17 15:21:26.000000000 +0200
+++ coreutils-7.2/src/copy.c 2009-04-17 15:24:17.000000000 +0200
@@ -139,10 +139,13 @@ copy_attr_error (struct error_context *c
int err = errno;
va_list ap;
- /* use verror module to print error message */
- va_start (ap, fmt);
- verror (0, err, fmt, ap);
- va_end (ap);
+ if (errno != ENOTSUP && errno != ENODATA)
+ {
+ /* use verror module to print error message */
+ va_start (ap, fmt);
+ verror (0, err, fmt, ap);
+ va_end (ap);
+ }
}
static char const *